Bug 500544 - 855GM: F11 LiveCD Preview doesn't start; Computer freezes on start
855GM: F11 LiveCD Preview doesn't start; Computer freezes on start
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 04:38 EDT by Vladi
Modified: 2013-01-10 00:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:31:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
jkeating: fedora_requires_release_note?


Attachments (Terms of Use)
harware report (12.28 KB, text/plain)
2009-05-13 04:40 EDT, Vladi
no flags Details
lspci -nn output (2.34 KB, text/plain)
2009-05-13 04:40 EDT, Vladi
no flags Details
Logs: mandriva 2009.1 free (50.76 KB, application/zip)
2009-05-14 03:29 EDT, Vladi
no flags Details
logs: 03-f11-rc01-livecd-nomodeset (32.18 KB, application/zip)
2009-05-24 03:55 EDT, Vladi
no flags Details
logs: 04-f11-rc01-hdd-nomodeset (83.73 KB, application/zip)
2009-05-24 03:56 EDT, Vladi
no flags Details
logs: 05-f11-rc01-hdd-modeset (90.22 KB, application/zip)
2009-05-24 03:58 EDT, Vladi
no flags Details
logs: 06-f11-rc01-hdd-UXA + xorg.conf (118.61 KB, application/zip)
2009-05-24 03:59 EDT, Vladi
no flags Details
F11-2.6.29.4-167-LVDS-1-logs+fotos.tar.bz2 (1.89 MB, application/x-bzip)
2009-05-28 15:00 EDT, Vladi
no flags Details
F11-2.6.29.4-167-VGA-1-log+fotos.tar.bz2 (1.25 MB, application/x-bzip)
2009-05-28 15:01 EDT, Vladi
no flags Details

  None (edit)
Description Vladi 2009-05-13 04:38:57 EDT
Notebook 
Toshiba Portége M100
Pentium M 1300 MHz RAM 1 Gb
Display 1024x768
BIOS v. 1.50 

VGA compatible controller:
Intel Corporation 82852/855GM Integrated Graphics Device 


After CD start the cursor is blinking in the upper left corner for about 1 min and than turns the Display black. The background light is off. The Caps-Lock does switch on and off. 

Enclose:
hardware report and lspci -nn output
Comment 1 Vladi 2009-05-13 04:40:02 EDT
Created attachment 343720 [details]
harware report
Comment 2 Vladi 2009-05-13 04:40:37 EDT
Created attachment 343721 [details]
lspci -nn output
Comment 3 Vladi 2009-05-14 03:28:04 EDT
I wasn't able to log in with ssh to the computer with F11 Preview Live to copy the logs.

I'm not sure if it is important, but i have tried other distributions with current xorg (Ubuntu 9.04 - v.1.6 and Mandriva 2009.1 v.1.6.1). I have got the following results. Ubuntu starts X and works with "UXA", Mandriva can't start X and freeze. I installed Mandriva and copied the logs. These logs are enclosed.
Comment 4 Vladi 2009-05-14 03:29:23 EDT
Created attachment 343922 [details]
Logs: mandriva 2009.1 free
Comment 5 Bill Nottingham 2009-05-20 15:26:46 EDT
What happens if you pass 'nomodeset' on the kernel command line?
Comment 6 Vladi 2009-05-21 12:22:40 EDT
If i pass 'nomodeset' on the kernel command line, the line and text "Fedora 10.9" are seen. After the stripe and text turn white nothing happens. The Caps-Lock lamp
turn on and off, but i wasn't able to log in with ssh to the computer.
Comment 7 Kristian Høgsberg 2009-05-21 13:31:41 EDT
Try to add 'nomodeset' and remove the 'quiet' and 'rhgb' keywords from the command line.  That should tell us in more detail what goes wrong.  Thanks!
Comment 8 James Laska 2009-05-22 12:37:31 EDT
Vladi: Are you able to reproduce this failure with more current Live media?  You can find updated live media available at http://alt.fedoraproject.org/pub/alt/stage/f11-rc0.1/Fedora-11-i686-Live/
Comment 9 James Laska 2009-05-22 12:57:54 EDT
This issue was discussed during the May 22 F11 Blocker Review meeting.  This issue will remain on F11Live blocker list until either:
 1) Additional feedback from the reporter helps identify root cause
 2) Positive feedback from other users with the same graphics setup

The bug will be reviewed again on May 25.
Comment 10 Adam Williamson 2009-05-22 15:11:45 EDT
Feedback from Kamin Horvath in the other 855 bug (490366):

"I've never had an issue with X starting up for me. And I've been using Fedora
11 since beta."
Comment 11 Vladi 2009-05-24 03:54:35 EDT
(In reply to comment #7)
> Try to add 'nomodeset' and remove the 'quiet' and 'rhgb' keywords from the
> command line.  That should tell us in more detail what goes wrong.  Thanks!  

1. I have managed to log in to gnome with the preview-CD, the only problem was the failure in 50-udev-default.rules (which, as I understand, has been corrected). Booting process lasted 10 minutes.

(In reply to comment #8)
> Vladi: Are you able to reproduce this failure with more current Live media? 
> You can find updated live media available at
> http://alt.fedoraproject.org/pub/alt/stage/f11-rc0.1/Fedora-11-i686-Live/  

2. The situation which I described above repeats with the new updated live media: I get only black screen and the computer freezes. 
 
3. If I insert 'nomodeset' into the command line and remove 'rhgb' and 'quiet' keywords I could log in to gnome. Booting process was without problems described in N.1. I have collected logs from /ect. They are enclosed.
--> logs: 03-f11-rc01-livecd-nomodeset.zip 

------------------------------------------------------------------------------

4. I have installed live-CD on the hard disk. The installation had some problems (bugs: 500808, 499544) but was succsessful. After the installation there was 'nomodeset' in the command line. The booting from the hdd with 'nomodeset' runs well. I can log in to gnome.
--> logs: 04-f11-rc01-hdd-nomodeset.zip

5. If I remove only 'nomodeset' from the command line, booting fails. The computer freezes. I have collected logs and the are enclosed.
--> logs: 05-f11-rc01-hdd-modeset.zip

6. I have changed xorg.conf and inserted Option "AccelMethod" "UXA". I have tried to reboot with these changes and collect logs. Booting failed and the logs are enclosed.
--> logs: 06-f11-rc01-hdd-UXA.zip
Comment 12 Vladi 2009-05-24 03:55:45 EDT
Created attachment 345224 [details]
logs: 03-f11-rc01-livecd-nomodeset
Comment 13 Vladi 2009-05-24 03:56:34 EDT
Created attachment 345225 [details]
logs: 04-f11-rc01-hdd-nomodeset
Comment 14 Vladi 2009-05-24 03:58:11 EDT
Created attachment 345226 [details]
logs: 05-f11-rc01-hdd-modeset
Comment 15 Vladi 2009-05-24 03:59:12 EDT
Created attachment 345227 [details]
logs: 06-f11-rc01-hdd-UXA + xorg.conf
Comment 16 Vladi 2009-05-24 04:05:37 EDT
I must correct myself: I collected logs not from '/etc' but from /var/log. Sorry and thanks.
Comment 17 Jesse Keating 2009-05-26 13:54:57 EDT
Adam reports that this isn't happening on other 855 users he actively got testing for, so this is a limited case.  As such it will not be an F11 blocker.
Comment 18 Bill Nottingham 2009-05-26 14:12:03 EDT
Re: comment #14, there's nothing obvious in those logs. To be honest, it looks like the logs from the hanging boot never made it to the disk.
Comment 19 Adam Williamson 2009-05-27 00:47:18 EDT
Perhaps /var/log/messages might contain something useful in that case?
Comment 20 Adam Williamson 2009-05-27 16:52:49 EDT
can you please test with this koji build? it fixed similar issues with 865, and kristian believes they may well be the same issue.

https://koji.fedoraproject.org/koji/taskinfo?taskID=1379720
Comment 21 Adam Williamson 2009-05-27 17:12:22 EDT
actually, scratch that, please test with:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1380684

that's the build that we intend to use for final. please see if it resolves this problem.
Comment 22 Adam Williamson 2009-05-27 17:13:32 EDT
sorry, correction:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1380686
Comment 23 Vladi 2009-05-28 14:59:00 EDT
(In reply to comment #22,21)
I have installed new kernel-2.6.29.4-167.fc11.
I removed the 'quiet' and 'rhgb' keywords from the
command line and booted the computer. I saw boot messages, the last I saw were 

i915 0000:00:02.0: VGA-1: no EDID data
i2c-adapter i2c-1: unable to read EDID block
(see 005-F11.png)

The the screen turned black but the lamp HDD was for the next 10-15 seconds on.
Then the computer doesn't react.
Using the rescue CD I have collected logs which are attached as well as the photos that I've made while booting (--> F11-2.6.29.4-167-LVDS-1-logs+fotos.tar.bz2).

I have also tried to start the computer with an external display plugged to it. Kernel command line was the same, the result was also the same, only the booting process was a bit longer. I could see the messages of the starting services like cron and atd. These were the last services which started after that no changes are seen on the screen. The other special thing about this try was that the messages were not on the whole screen, but in the upper left corner, approximately 1/16th of the screen (see 004-f11-ext-vga.png).    

I have collected the logs and enclose them as well as the pictures of the second attempt (-->F11-2.6.29.4-167-VGA-1-log+fotos.tar.bz2).
Comment 24 Vladi 2009-05-28 15:00:15 EDT
Created attachment 345819 [details]
F11-2.6.29.4-167-LVDS-1-logs+fotos.tar.bz2
Comment 25 Vladi 2009-05-28 15:01:19 EDT
Created attachment 345820 [details]
F11-2.6.29.4-167-VGA-1-log+fotos.tar.bz2
Comment 26 Adam Williamson 2009-05-28 16:37:24 EDT
so it's *different*, but it still doesn't work?

and it still works with nomodeset?
Comment 27 Vladi 2009-05-29 02:30:21 EDT
(In reply to comment #26)
Yes, it still works with nomodeset.
Comment 28 Adam Williamson 2009-05-29 12:12:30 EDT
OK, thanks.
Comment 29 Bug Zapper 2009-06-09 11:43:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Bug Zapper 2010-04-27 10:18:11 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 Bug Zapper 2010-06-28 08:31:04 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.