This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 500933 - Update to Subversion 1.6.2
Update to Subversion 1.6.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 19:36 EDT by Matthew Saltzman
Modified: 2009-09-10 19:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.6.4-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 506781 (view as bug list)
Environment:
Last Closed: 2009-09-10 15:17:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2009-05-14 19:36:35 EDT
Description of problem:
Subversion is a major release behind.

Version-Release number of selected component (if applicable):
subversion-1.5.4-3.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install subversion RPM
2.
3.
  
Actual results:
Version is 1.5.4.

Expected results:
Version is 1.6.2

Additional info:
One of the major new features is that passwords need no longer be stored on the client machine in plain text.  There are hooks for kwallet and gnome-keyring.

Subversion maintains backward compatibility, so upgrades should be transparent to users who don't care to use the new features (except for the new password prompts.)  Client repo formats are automatically upgraded, but server ones are not.
Comment 1 Fedora Update System 2009-05-28 08:05:24 EDT
subversion-1.6.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/subversion-1.6.2-2.fc10
Comment 2 Fedora Update System 2009-05-29 22:35:11 EDT
subversion-1.6.2-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update subversion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5690
Comment 3 Matthew Saltzman 2009-06-01 15:02:41 EDT
Installed from updates-testing, but the connectors to gnome-keyring and kwallet do not seem to be enabled.  I gather that one places a command such as 

    password-stores = gnome-keyring

in ~/.subversion/config in order to enable the connection.  But I still get a message about not being able to store encrypted passwords.
Comment 4 Matthew Saltzman 2009-06-01 15:04:01 EDT
(In reply to comment #3)
> I gather that one places a command such as 
> 
>     password-stores = gnome-keyring
> 
> in ~/.subversion/config in order to enable the connection.

Should have said: in the [auth] section of ~/.subversion/config.
Comment 5 Joe Orton 2009-06-01 16:30:55 EDT
Matthew - I haven't yet enabled the options to get keyring/kwallet support; I've been playing with this in the Raw Hide build.
Comment 6 Matthew Saltzman 2009-06-01 17:05:48 EDT
OK Thanks.  That seems to be one of the most important new features, so it will be nice to see it enabled.

If I can help test, let me know how.

Everything else I've looked at so far (nothing too sophisticated) seems functional.
Comment 7 Scott Douglass 2009-06-12 22:03:36 EDT
Upgraded my workstation to F11. F11 release repo has an old subversion package: subversion-1.6.1-5.fc11.i586.

It would be nice to build the binary with support for the GNOME keyring... Otherwise it's a bit jarring to get this message when updating:

[scott@tablet mail]$ svn update
Authentication realm: <https://place.com:443> Place Subversion
Password for 'scott': 
-----------------------------------------------------------------------
ATTENTION!  Your password for authentication realm:

   <https://place.com:443> Place Subversion

can only be stored to disk unencrypted!  You are advised to configure
your system so that Subversion can store passwords encrypted, if
possible.  See the documentation for details.

You can avoid future appearances of this warning by setting the value
of the 'store-plaintext-passwords' option to either 'yes' or 'no' in
'/home/scott/.subversion/servers'.
-----------------------------------------------------------------------
Store password unencrypted (yes/no)?
Comment 8 Matthew Saltzman 2009-07-05 12:28:55 EDT
Latest is now Subversion 1.6.3.  Still looking forward to keyring compatibility.
Comment 9 Fedora Update System 2009-08-09 06:11:37 EDT
subversion-1.6.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/subversion-1.6.4-2.fc11
Comment 10 Fedora Update System 2009-08-09 06:20:12 EDT
subversion-1.6.4-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/subversion-1.6.4-2.fc10
Comment 11 Fedora Update System 2009-08-10 17:48:27 EDT
subversion-1.6.4-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 H.J. Lu 2009-09-10 13:38:45 EDT
subversion-gnome isn't enabled/built for Fedora 10. It will be nice
to have it for Fedora 10.
Comment 13 Matthew Saltzman 2009-09-10 14:49:54 EDT
Yeah, not enabled for F11, either.
Comment 14 H.J. Lu 2009-09-10 15:04:17 EDT
You need to install subversion-gnome by hand to enable gnome-keyring.
However, subversion-gnome isn't built for Fedora 10.
Comment 15 Joe Orton 2009-09-10 15:17:32 EDT
Please don't reopen closed bugs merely to repurpose them.

I've filed bug 522592 to track GNOME keyring/KDE wallet support in F10.

Re comment 13 - the F11 builds do have GNOME keyring/KDE wallet support enabled; install subversion-gnome or subversion-kde.

https://admin.fedoraproject.org/updates/F11/FEDORA-2009-8449
Comment 16 Matthew Saltzman 2009-09-10 19:35:40 EDT
(In reply to comment #15)
> Please don't reopen closed bugs merely to repurpose them.
> 
> Re comment 13 - the F11 builds do have GNOME keyring/KDE wallet support
> enabled; install subversion-gnome or subversion-kde.
> 
> https://admin.fedoraproject.org/updates/F11/FEDORA-2009-8449  

Ah, OK thanks.  Sorry to bother...

Note You need to log in before you can comment on or make changes to this bug.