Bug 500964 - RFE: issue_trackers::countgreaterthan::1 find all bugs with 1 or more issuetrackers
RFE: issue_trackers::countgreaterthan::1 find all bugs with 1 or more issuetr...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
devel
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: FutureFeature
: 501559 (view as bug list)
Depends On:
Blocks: 450098
  Show dependency treegraph
 
Reported: 2009-05-15 03:24 EDT by Chris Ward
Modified: 2013-06-23 22:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 19:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2009-05-15 03:24:26 EDT
Description of problem:
trying to find bugs which contain more than 1 issue tracker does not work using the following boolean query, which I believe should work.

cf_issue_trackers::greaterthan::1
cf_issue_trackers::greaterthan::2
cf_issue_trackers::greaterthan::3....

all these find all bugs with 1 or more issuetrackers. 

Expected:

cf_issue_trackers::greaterthan::1 would find all bugzillas which have 2 or more. 
cf_issue_trackers::greaterthan::2 would find all bugzillas which have 3 or more.
etc....
Comment 1 Noura El hawary 2009-05-15 07:16:12 EDT
Hi Chris,

Basically the search for issue trackers doesn't work as how you mentioned, greater than 1 0r 2 or 3 is not searching for how many issue trackers that a bug has, it is actually comparing actual issue tracker ids to 1 or 2 or 3 so searching for bugs with issue tracker greater than 1 will return all bugs that has issue tracker ids greater than 1, so it will not return a bug for example that has an issue tracker with is 0 if there was one. if you say greater than 200000 it will return for example something with id 290879 but not 129887.

I don't think there is actually a way to search for how many issue trackers are associated with a bug at the moment.

Noura
Comment 2 Chris Ward 2009-05-15 07:34:16 EDT
Ah ha. I guess this explains why when one tries to sort based on the issue trackers column it sorts not on the number of issue trackers but on the lowest to highest.

Well it would certainly be useful to be able to search based on the number of issue trackers because, for example, it's much more important a bug when a bug has multiple issue trackers rather than one. It helps to prioritize devel and testing focus.

So i guess i'll turn this into a feature request. :)
Comment 3 Noura El hawary 2009-05-15 07:48:45 EDT
Chris,

You can have a look at those reports 

https://engineering.redhat.com/metrics/bugzilla-metrics.cgi?page=it-check

Maybe you can find what you are trying to look for. Also i am CC'ing bgroh maybe he has a better ides.

Cheers,
Noura
Comment 4 Chris Ward 2009-05-15 08:54:07 EDT
the links on that page fail.
....


ACK Viewer Error

Error executing run mode 'it-with-many-bz': DBI connect('dbname=portal;host=cspdb2.db.dev.redhat.com;port=3306;','EngReportUser',...) failed: Access denied for user 'EngReportUser'@'bzutils.engineering.redhat.com' (using password: YES) at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 650 DBI::__ANON__('undef', 'undef') called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 705 DBI::connect('DBI', 'dbi:mysql:dbname=portal;host=cspdb2.db.dev.redhat.com;port=3306;', 'EngReportUser', ..., 'HASH(0x22c6a50)') called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 547 DBI::connect_cached('DBI', 'dbi:mysql:dbname=portal;host=cspdb2.db.dev.redhat.com;port=3306;', 'EngReportUser', ..., 'HASH(0x1fcc180)') called at lib/BugzillaMetrics/Database.pm line 45 eval {...} called at lib/BugzillaMetrics/Database.pm line 44 BugzillaMetrics::Database::connect('BugzillaMetrics') called at lib/BugzillaMetrics/IT.pm line 53 BugzillaMetrics::IT::get_it_bz_diff('BugzillaMetrics::IT') called at lib/BugzillaMetrics/WebApp/IT.pm line 93 BugzillaMetrics::WebApp::it_with_many_bz('BugzillaMetrics::WebApp=HASH(0x201f640)') called at /usr/lib/perl5/site_perl/5.8.5/CGI/Application.pm line 142 eval {...} called at /usr/lib/perl5/site_perl/5.8.5/CGI/Application.pm line 142 CGI::Application::run('BugzillaMetrics::WebApp=HASH(0x201f640)') called at lib/BugzillaMetrics/WebApp.pm line 45 BugzillaMetrics::WebApp::run('BugzillaMetrics::WebApp=HASH(0x201f640)') called at /var/www/html/metrics/bugzilla-metrics.cgi line 18 eval {...} called at /var/www/html/metrics/bugzilla-metrics.cgi line 11

2009-05-15 08:52:54
Comment 5 Chris Ward 2009-05-15 09:22:01 EDT
I reported it to engineering-services
Comment 6 Chris Ward 2009-05-20 03:42:32 EDT
this is the same issue with other fields too, like Partner/Verified fields for example also fail to return results which correspond to the greaterthan::X value.

But seems this request will have to turn into a feature request, as i don't think anyone's going to want modify the current behaviour....i imagine it's seen as a feature, not a defect. hmmm...
Comment 7 Chris Ward 2009-05-20 03:45:23 EDT
Changing description. Guess i already changed this into a feature a short while ago... and forgot. hehe. So basically, i think if we could have another type of boolean operator: 'countgreaterthan' and 'countlessthan' and 'countequals' which compared the value to the number of 'items' in the field, it would work like a charm.
Comment 8 Chris Ward 2009-07-06 16:14:08 EDT
*** Bug 501559 has been marked as a duplicate of this bug. ***
Comment 9 Andrius Benokraitis 2010-03-09 10:24:52 EST
This issue would be good for counting multiple partners listed in cf_partner as well.
Comment 10 Chris Ward 2010-10-07 06:40:45 EDT
This is still valid, even after 3.6 update.

The links in Comment #3 are interesting, but they're not what i'm after exactly. 
I'm lookig to be able, from BZ interface (web, xmlrpc) query all bugs which meet various boolean queries (eg, has this flag, in this state...) AND 'issuetrackers' 'countgreaterthan' '3'

Or to think of it another way, i need a way to be able to sort (prioritize) bugzillas based on the number of attached ITs (or the current equivalent).
Comment 11 Simon Green 2012-06-19 19:37:07 EDT
Issue trackers were removed from Bugzilla last year, so closing this issue. Please let me know if you still think it is a problem.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.