Bug 501559 - Querying by partner a bit quirky
Querying by partner a bit quirky
Status: CLOSED DUPLICATE of bug 500964
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 14:19 EDT by Andrius Benokraitis
Modified: 2015-07-14 00:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 16:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrius Benokraitis 2009-05-19 14:19:24 EDT
When going to the Advanced Search page, it shows searching by Partner as a boolean. It isn't clear if there are shortcuts for selecting all partners, or do all partner names need to be specifically typed in? Is there a wildcard available? Thanks!
Comment 1 Chris Ward 2009-05-20 03:38:32 EDT
Not sure of the example you're trying to squeeze out here, but if you do 

Partner::greatherthan::0

in the boolean query search, you will get a list of all bugs which have at leave one partnerID selected in the Partner field.

That's sorta like a * search.
Comment 2 Chris Ward 2009-05-20 03:42:46 EDT
... to bad though 

Partner::greatherthan::1

doesn't actually find bugs which contain more than 1 id selected... :)

https://bugzilla.redhat.com/show_bug.cgi?id=500964
Comment 3 David Lawrence 2009-07-02 11:00:41 EDT
Noura, can you please comment on this issue?
Thanks
Dave
Comment 4 Noura El hawary 2009-07-06 10:36:54 EDT
This bug is similar to bug #500964 and i have made a comment there that would have similar answer to this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=500964#c1

basically there is no current way at the moment to search by the number of or the count of partners, verified, issue trackers etc in a bug report, the way the current search works is by searching using the actual values of the fields instead of the number of its items/values. having a search that will look for the number of the values will be a new feature request in bugzilla, that we might be able to work on in the future.

Cheers,
Noura
Comment 5 Chris Ward 2009-07-06 10:59:23 EDT
I think comment #1 might answer the original post, Andrius? Otherwise, yea, bug #500964 is the RFE for the mentioned feature so we could search based on the number of items selected. It would be nice... :)
Comment 6 Andrius Benokraitis 2009-07-06 13:41:44 EDT
Yup, I think you are right - it would be an RFE then. In the meantime I'll need to be explicit with searching in the meantime.
Comment 7 Chris Ward 2009-07-06 15:34:29 EDT
Andrius, do you agree then to CLOSE->NOTABUG this and add your votes to the RFE noted above?
Comment 8 Andrius Benokraitis 2009-07-06 15:48:11 EDT
sounds good to me!
Comment 9 Chris Ward 2009-07-06 16:14:08 EDT
See bug #500964 for RFE

*** This bug has been marked as a duplicate of bug 500964 ***

Note You need to log in before you can comment on or make changes to this bug.