This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 500968 - virt-manager traceback on shutdown of qemu-kvm -no-acpi guest
virt-manager traceback on shutdown of qemu-kvm -no-acpi guest
Status: CLOSED DUPLICATE of bug 519667
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-15 04:24 EDT by Adrin Jalali
Modified: 2009-09-21 13:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 13:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
qemu log file (6.09 KB, text/plain)
2009-05-25 11:11 EDT, Adrin Jalali
no flags Details
libvirtd.log (9.39 MB, application/x-gzip)
2009-05-25 17:38 EDT, Adrin Jalali
no flags Details

  None (edit)
Description Adrin Jalali 2009-05-15 04:24:17 EDT
Using 
virt-manager-0.7.0-4.fc11.x86_64
libvirt-0.6.2-8.fc11.x86_64
libvirt-python-0.6.2-8.fc11.x86_64
python-virtinst-0.400.3-8.fc11.noarch
virt-viewer-0.0.3-4.fc11.x86_64


Installed a windows XP on kvm, when I try to shutdown virtual machine using toolbar button, not shutting down machine inside windows, I get this:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 507, in shutdown_domain
    vm.shutdown()
  File "/usr/share/virt-manager/virtManager/domain.py", line 566, in shutdown
    self._update_status()
  File "/usr/share/virt-manager/virtManager/domain.py", line 217, in _update_status
    info = self.vm.info()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 523, in info
    if ret is None: raise libvirtError ('virDomainGetInfo() failed', dom=self)
libvirtError: operation failed: could not query memory balloon allocation


and virtual machine is powered off immediately.
Comment 1 Mark McLoughlin 2009-05-25 10:04:11 EDT
That sounds like qemu may have crashed handling the "info balloon" monitor command.

What version of qemu-system-x86 is this? Could you attach the logfile for the guest from /var/log/qemu/ ?

Also, it may be worth trying libvirt-0.6.2-10.fc11 from updates-testing:

https://admin.fedoraproject.org/updates/libvirt-0.6.2-10.fc11
Comment 2 Adrin Jalali 2009-05-25 11:11:26 EDT
Created attachment 345330 [details]
qemu log file

and: qemu-system-x86-0.10.4-5.fc11.x86_64
Comment 3 Adrin Jalali 2009-05-25 11:23:12 EDT
also I can not update to libvirt-0.6.2-10.f11 because I can not find related libvirt-python rpm.
Comment 5 Adrin Jalali 2009-05-25 17:38:29 EDT
Created attachment 345359 [details]
libvirtd.log
Comment 6 Adrin Jalali 2009-05-25 17:39:30 EDT
I've also updated those two libvirt packages, but I get the same result.
Comment 7 Mark McLoughlin 2009-05-26 03:45:00 EDT
Okay, I can reproduce - the key is that this is a guest which doesn't have ACPI enabled.

With -no-acpi, qemu will exit immediately when issued the system_powerdown command.

Then when virt-manager does a virDomainGetInfo(), libvirtd detects an error on the monitor fd and returns an error rather than handling it as a normal guest shutdown.
Comment 8 Bug Zapper 2009-06-09 11:51:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Michal Nowak 2009-09-18 03:13:44 EDT
Moving to Rawhide version. Reproducible with:

libvirt-0.7.1-1.fc12.x86_64
qemu-system-x86-0.10.92-4.fc12.x86_64
virt-manager-0.8.0-3.fc12.noarch
Comment 10 Cole Robinson 2009-09-21 13:08:17 EDT
I think 519667 was also covering this, and the issue should be fixed with latest rawhide libvirt versions.

*** This bug has been marked as a duplicate of bug 519667 ***

Note You need to log in before you can comment on or make changes to this bug.