Bug 519667 - could not query memory balloon allocation
could not query memory balloon allocation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Reopened
: 500968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 06:57 EDT by Tim Waugh
Modified: 2009-11-19 04:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 532009 (view as bug list)
Environment:
Last Closed: 2009-09-21 12:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
RHEL54.xml (1.24 KB, text/plain)
2009-09-17 07:01 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2009-08-27 06:57:55 EDT
Description of problem:
After shutting down a guest, libvirtd is no longer running.  /var/log/messages says:

Aug 27 11:44:58 worm libvirtd: 11:44:58.794: error : qemudDomainGetMemoryBalloon:3229 : operation failed: could not query memory balloon allocation

Version-Release number of selected component (if applicable):
libvirt-0.7.0-6.fc12.x86_64
qemu-0.10.91-0.8.rc1.fc12.x86_64
kernel-2.6.31-0.174.rc7.git2.fc12.x86_64
qemu-system-x86-0.10.91-0.8.rc1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Start guest.
2.Shut down guest.
3.Attempt to start guest.
  
Actual results:
libvirtd is no longer running.

Expected results:
Still running after guest is shut down.
Comment 1 Tim Waugh 2009-08-28 04:59:26 EDT
Hmm, I don't seem to be seeing this now...
Comment 2 Tim Waugh 2009-08-28 05:01:47 EDT
...and of course it just happened again, while shutting down an F-11 guest.
Comment 3 Mark McLoughlin 2009-09-04 09:06:09 EDT
I can't reproduce this

Was it a segfault? Can you get a stack trace?
Comment 4 Daniel Berrange 2009-09-10 05:00:44 EDT
Can you provide the guest configuration file which exhibits this crash.

Also is this being seen with a guest whose disks are on NFS as per your other bugs ?
Comment 5 Tim Waugh 2009-09-17 06:53:57 EDT
It turns out libvirtd is still running but virt-manager's connection to it is broken.

No, the disks are not on NFS.

$ ls -Z /home/twaugh/VM/RHEL54.img 
-rw-rw-r--. root root system_u:object_r:virt_image_t:s0 /home/twaugh/VM/RHEL54.img
Comment 6 Tim Waugh 2009-09-17 07:01:02 EDT
Created attachment 361476 [details]
RHEL54.xml
Comment 7 Cole Robinson 2009-09-17 10:48:17 EDT
I was hitting this issue as well, but not anymore after updating libvirt to latest rawhide version (libvirt-0.7.1-1.fc12.x86_64). Tim, can you give that a shot?

Guest was win2003, no fancy setup, just a single ide disk. shutdown (not destroy) caused the issue. virsh list would show 'nostate' for the VM, and all 'info' calls would fail with "could not query memory balloon'.

There is another bug filed to handle virt-manager's poor behavior in coping with this situation (bz 522168).
Comment 8 Mark McLoughlin 2009-09-21 10:42:37 EDT
twaugh: has latest libvirt fixed it for you too?
Comment 9 Tim Waugh 2009-09-21 11:39:34 EDT
I'm not seeing it break with libvirt-0.7.1-4.fc12.x86_64.
Comment 10 Mark McLoughlin 2009-09-21 12:02:17 EDT
Thanks Tim
Comment 11 Cole Robinson 2009-09-21 13:08:17 EDT
*** Bug 500968 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.