Bug 500990 - blank display when starting X on radeon with KMS disabled
blank display when starting X on radeon with KMS disabled
Status: CLOSED DUPLICATE of bug 500801
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 08:01 EDT by Jeff Layton
Modified: 2014-06-18 03:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 21:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2009-05-15 08:01:32 EDT
On kernel-PAE-2.6.29.3-140.fc11.i686, with KMS disabled, starting X results in a blank screen (no display at all). It's also unresponsive to Ctrl-Alt-Backspace even though DontZap is off. The machine (a laptop) seems to be responsive, and if I hit the power button it eventually shuts down cleanly, so it seems to mainly be a problem with the display.

Booting with KMS enabled seems to "fix" this. But as it's a laptop, I still need the ability to suspend and hibernate, and that's not ever worked on this laptop with KMS enabled (see bug 471711).

Downgrading to kernel-PAE-2.6.29.2-126.fc11.i686 also corrects the issue.

The laptop has this display chip:

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)

Let me know if you need other info.
Comment 1 Yanko Kaneti 2009-05-15 09:16:58 EDT
Most likely a dupe of bug 500801
try upgrading xorg-x11-drv-ati from koji.
http://koji.fedoraproject.org/koji/buildinfo?buildID=102206
Comment 2 Jeff Layton 2009-05-15 21:48:00 EDT
Confirmed. Updating xorg-x11-drv-ati fixed the problem.

Thanks for the tip.

*** This bug has been marked as a duplicate of bug 500801 ***

Note You need to log in before you can comment on or make changes to this bug.