Bug 501104 - protobuf 2.1.0 is available
protobuf 2.1.0 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: protobuf (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lev Shamardin
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 05:37 EDT by Ruben Kerkhof
Modified: 2009-10-20 20:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.2.0-2.fc11
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 564548 (view as bug list)
Environment:
Last Closed: 2009-09-18 09:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Protobuf spec file for protobuf 2.2.0 (10.43 KB, text/plain)
2009-09-01 12:38 EDT, Eric Hopper
no flags Details

  None (edit)
Description Ruben Kerkhof 2009-05-16 05:37:58 EDT
Hi there,

Would you mind updating protobuf to the latest version? I'm trying to build drizzle and it needs a newer version of protobuf.

Thanks,

Ruben
Comment 1 Lev Shamardin 2009-05-16 15:05:30 EDT
That's on my todo list, as soon as I fix my laptops' hard drive.
Comment 2 Ruben Kerkhof 2009-05-16 20:25:06 EDT
Great, thanks.
Comment 3 John Poelstra 2009-06-08 15:29:14 EDT
Adding 'FutureFeature' keyword to avoid rawhide rebase.
Comment 4 Ismael Juma 2009-07-20 15:19:38 EDT
Any progress on fixing that hard drive? :)
Comment 5 Lev Shamardin 2009-07-20 16:04:16 EDT
Got it replaced last week. Now struggling with libtool.
Comment 6 Eric Hopper 2009-08-31 02:12:37 EDT
protobuf is now up to 2.2.0, so maybe the title of the bug ought to change.
Comment 7 Eric Hopper 2009-09-01 12:38:07 EDT
Created attachment 359421 [details]
Protobuf spec file for protobuf 2.2.0

This is an updated spec file that should work for protobuf 2.2.0.  I don't really know much about exactly what the Fedora project wants in a spec file so it's likely wrong in some important aspect.

Also, there are several packages that depend on protobuf.  banshee and akonadi seem to be at the root of it all.  These will need to be recompiled for a new version, though I believe that protobuf is largely source compatible so it shouldn't be a problem.

protobuf has also gained a dependency on pthread and threads in general, so this may affect the builds of dependent packages.
Comment 8 Milos Jakubicek 2009-09-01 19:45:10 EDT
I've just fixed at least the FTBFS of current version (BZ#511491), not sure about the deps you're mentioning:

>repoquery --queryformat="%{name}\n" --whatrequires "protobuf*" --alldeps --recursive --enablerepo=rawhide | sort | uniq

ccsm
compizconfig-backend-gconf
compizconfig-backend-kconfig
compizconfig-python
compiz-kde
compiz-manager
fusion-icon
fusion-icon-gtk
fusion-icon-qt
libcompizconfig
libcompizconfig-devel
protobuf
protobuf-compiler
protobuf-devel
protobuf-static

...if these are really the only deps, then the update shouldn't be that complicated.
Comment 9 Eric Hopper 2009-09-01 20:04:51 EDT
Well, that method is much nicer than what I did.

I went through every single thing in yum list and did 'yum deplist' on it and looked for libprotobuf in the list.  Re-examining my work, it seems that somehow something didn't go how I planned it.  :-(
Comment 10 Lev Shamardin 2009-09-18 09:26:14 EDT
New protobuf-2.2.0 was built for rawhide, see http://koji.fedoraproject.org/koji/taskinfo?taskID=1688814

If anyone thinks that this should also go to Fedora 10/11 updates, please write a notice here.
Comment 11 Ismael Juma 2009-09-18 09:32:56 EDT
I think it would be nice if an update for F11 was made available. I think the current version of protobuf has issues with the current Python version in F11.
Comment 12 Fedora Update System 2009-09-18 10:08:24 EDT
protobuf-2.2.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/protobuf-2.2.0-1.fc11?_csrf_token=f89479e14c4c04539a80be17962538eb233e8617
Comment 13 Lev Shamardin 2009-09-18 10:09:24 EDT
I've submitted this update to fc11-testing. Please test it and vote, if everything is fine.
Comment 14 leigh scott 2009-09-19 15:47:38 EDT
The libcompizconfig doesn't build against the 2.2.0 version of protobuf-devel.



checking for LIBX11... yes
checking for COMPIZ... yes
checking for LIBXML2... yes
checking for protoc... yes
checking for _ZN6google8protobuf7MessageD2Ev in -lprotobuf... no
WARNING: You need to install Protocol Buffers to get faster program startup.
 Sources are available at http://code.google.com/p/protobuf/downloads/list
 Package names for Ubuntu/Debian: libprotobuf0, libprotobuf-dev,
protobuf-compiler
 Package names for other distributions: protobuf, protobuf-devel
 Disabling protobuf.
checking sys/inotify.h usability... yes



For  full build logs

http://koji.fedoraproject.org/koji/taskinfo?taskID=1691110

I have reported upstream ( libcompizconfig ), I'm not convinced the fault lays with libcompizconfig.

http://bugs.opencompositing.org/show_bug.cgi?id=1205
Comment 15 Lev Shamardin 2009-09-19 16:42:10 EDT
One important point: you have downvoted an update to fedora-11 due a build misbehavior in rawhide. I don't think this is relevant. Please downvote updates to fedora-11 only if it breaks things in fedora-11, not in rawhide or any other fedora release, thanks.
Comment 16 leigh scott 2009-09-19 17:08:27 EDT
(In reply to comment #15)
> One important point: you have downvoted an update to fedora-11 due a build
> misbehavior in rawhide. I don't think this is relevant. Please downvote updates
> to fedora-11 only if it breaks things in fedora-11, not in rawhide or any other
> fedora release, thanks.  


It equally applies to F11 as I am the compiz-fusion repo maintainer.
Comment 17 leigh scott 2009-09-20 03:24:16 EDT


(In reply to comment #10)
 
> If anyone thinks that this should also go to Fedora 10/11 updates, please write
> a notice here.  


I dont want 2.2.0 in F11 till I have sorted out the mess you have made by bumping the soname without telling anyone first!

I don't like surprises.

>libcompizconfig has broken dependencies in the development tree:
>On ppc:
>        libcompizconfig-0.8.2-5.fc12.ppc64 requires libprotobuf.so.2()(64bit)
>On x86_64:
>        libcompizconfig-0.8.2-5.fc12.x86_64 requires libprotobuf.so.2()(64bit)
>On i386:
>        libcompizconfig-0.8.2-5.fc12.i686 requires libprotobuf.so.2
>On ppc64:
>        libcompizconfig-0.8.2-5.fc12.ppc64 requires libprotobuf.so.2()(64bit)
>Please resolve this as soon as possible.
Comment 18 Lev Shamardin 2009-09-20 06:03:57 EDT
Okay, I've removed this from fedora-11-updates-testing, should I also withdraw it from rawhide and announce soname change to fedora-devel, or will you try to fix libcompizconfig?
Comment 19 leigh scott 2009-09-20 06:49:31 EDT
(In reply to comment #18)
> Okay, I've removed this from fedora-11-updates-testing, should I also withdraw
> it from rawhide and announce soname change to fedora-devel, or will you try to
> fix libcompizconfig?  


Thanks , I have reported this to libcompizconfig upstream and also googled to see if anyone else has this issue, but didn't find anything yet.
I believe Archlinux uses libcompizconfig and the new protobuf version without issue, but I haven't checked it out properly to confirm this. 
Is there a possibility that the protobuf-devel package is faulty? 

As for libcompizconfig in Rawhide I have disabled protobuf support till I can find a solution.
I don't see any need to withdraw the 2.2.0 package from rawhide ( Fedora is meant to be cutting edge :-) )
Comment 20 Lev Shamardin 2009-09-20 07:26:24 EDT
I'm not sure if there are any problems with new protobuf-devel, since I myself use protobuf-compiler and protobuf-python. May be someone watching this bug could comment if there are problems with libprotobuf from the new protobuf-devel. But I doubt that because protobuf package has the %check section and it did pass all the tests (there are plenty of them bundled in protobuf sources).
Comment 21 leigh scott 2009-09-24 17:07:24 EDT
(In reply to comment #18)
> Okay, I've removed this from fedora-11-updates-testing, should I also withdraw
> it from rawhide and announce soname change to fedora-devel, or will you try to
> fix libcompizconfig?  


Hi Lev,

I have a solution for my F11 libcompizconfig package and I am working on back-porting the fix for the F12 libcompizconfig package.
Feel free to update the F11 package, thank you for not pushing it till I had a solution.


Many thanks

Leigh
Comment 22 Fedora Update System 2009-09-29 04:34:54 EDT
protobuf-2.2.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/protobuf-2.2.0-1.fc11
Comment 23 Lev Shamardin 2009-09-29 06:01:42 EDT
Could you please rebuild libcompizconfig with new protobuf from updates-testing now?
Comment 24 leigh scott 2009-09-29 18:50:39 EDT
(In reply to comment #23)
> Could you please rebuild libcompizconfig with new protobuf from updates-testing
> now?  


Ok I have built libcompizconfig for F12 and I am getting this error.


[leigh@localhost F-12]$ fusion-icon
 * Detected Session: gnome
 * Searching for installed applications...
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * Starting Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
compiz (core) - Error: Couldn't load plugin '/usr/lib64/compiz/libccp.so' : /usr/lib64/libprotobuf.so.4: undefined symbol: pthread_once
compiz (core) - Error: Couldn't load plugin 'ccp'
compiz (core) - Error: Couldn't load plugin '/usr/lib64/compiz/libccp.so' : /usr/lib64/libprotobuf.so.4: undefined symbol: pthread_once
compiz (core) - Error: Couldn't load plugin 'ccp'
 * Setting window manager to Metacity

/usr/lib64/compiz/libccp.so is provided by libcompizconfig

Here's the Koji build

http://koji.fedoraproject.org/koji/buildinfo?buildID=134340
Comment 25 Lev Shamardin 2009-09-30 00:09:17 EDT
And what about F11 build? Should I remove update from testing again?
Comment 26 Eric Hopper 2009-09-30 02:02:45 EDT
Basically the new protobuf adds a dependency on -lpthread for everything that depends on it.
Comment 27 leigh scott 2009-09-30 05:33:31 EDT
(In reply to comment #26)
> Basically the new protobuf adds a dependency on -lpthread for everything that
> depends on it.  


Are you saying I should recompile these packages ?

ccsm
compizconfig-backend-gconf
compizconfig-backend-kconfig
compizconfig-python
fusion-icon
fusion-icon-gtk
fusion-icon-qt


Here's the patch that I added to libcompizconfig.

http://cvs.fedoraproject.org/viewvc/rpms/libcompizconfig/F-12/protobuf_version.patch?revision=1.1
Comment 28 leigh scott 2009-09-30 05:50:29 EDT
(In reply to comment #25)
> And what about F11 build? Should I remove update from testing again?  

If it's OK could you leave it in updates-testing till I can resolve this issue.

Thanks

Leigh
Comment 29 leigh scott 2009-09-30 06:28:26 EDT
(In reply to comment #25)
> And what about F11 build? Should I remove update from testing again?  

The same error is also present in my F11 build.

[leigh@localhost x86_64]$ fusion-icon 
 * Detected Session: gnome
 * Searching for installed applications...
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * Starting Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding
compiz (core) - Error: Couldn't load plugin '/usr/lib64/compiz/libccp.so' : /usr/lib64/libprotobuf.so.4: undefined symbol: pthread_once
compiz (core) - Error: Couldn't load plugin 'ccp'
Comment 30 leigh scott 2009-09-30 07:18:00 EDT
Hi Lev,

Could you compile protobuf-2.2.0 with this option so it works properly.

export PTHREAD_LIBS="-lpthread"



i.e

%build
iconv -f iso8859-1 -t utf-8 CONTRIBUTORS.txt > CONTRIBUTORS.txt.utf8
mv CONTRIBUTORS.txt.utf8 CONTRIBUTORS.txt
export PTHREAD_LIBS="-lpthread" 
./autogen.sh
%configure

make %{?_smp_mflags}



Thanks

Leigh


P.S I have tested it and it works.
Comment 32 leigh scott 2009-09-30 08:26:52 EDT
This is from your protobuf rpm buildlog

checking for strchr... yes
checking for strerror... yes
checking for strtol... yes
checking for library containing zlibVersion... no
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking whether to check for GCC pthread/shared inconsistencies... yes
checking whether -pthread is sufficient with -shared... yes
checking the location of hash_map... <ext/hash_map>
configure: creating ./config.status




with the export PTHREAD_LIBS="-lpthread" option


checking for strchr... yes
checking for strerror... yes
checking for strtol... yes
checking for library containing zlibVersion... no
checking for pthread_join in LIBS=-lpthread with CFLAGS=... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking whether to check for GCC pthread/shared inconsistencies... yes
checking whether -pthread is sufficient with -shared... yes
checking the location of hash_map... <ext/hash_map>
configure: creating ./config.status


http://koji.fedoraproject.org/koji/getfile?taskID=1719532&name=build.log
Comment 33 Lev Shamardin 2009-09-30 08:49:56 EDT
Could you try the new build? 

http://koji.fedoraproject.org/koji/buildinfo?buildID=134477
Comment 34 leigh scott 2009-09-30 08:59:57 EDT
(In reply to comment #33)
> Could you try the new build? 
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=134477  


That works :-) , can you push the new F11 build to updates-testing and do new builds with this change for the  devel & F12 branches.
Comment 35 Fedora Update System 2009-09-30 09:10:45 EDT
protobuf-2.2.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/protobuf-2.2.0-2.fc11
Comment 37 leigh scott 2009-10-02 07:58:10 EDT
(In reply to comment #36)
> Done.
> F-12: http://koji.fedoraproject.org/koji/buildinfo?buildID=134485
> F-13 (devel): http://koji.fedoraproject.org/koji/buildinfo?buildID=134482  

You will need to tag the F12 package at bodhi.

https://admin.fedoraproject.org/updates/F12/pending?
Comment 38 Fedora Update System 2009-10-02 08:05:14 EDT
protobuf-2.2.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/protobuf-2.2.0-2.fc12
Comment 39 Lev Shamardin 2009-10-02 08:06:21 EDT
Just did that, at the time of original reply with build links, F12 was yet not available in Bodhi.
Comment 40 Fedora Update System 2009-10-20 20:56:12 EDT
protobuf-2.2.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.