Bug 50115 - Packages with same name, different arch indistinguishable
Packages with same name, different arch indistinguishable
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
: 52389 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 18:50 EDT by James Turner
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 11:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Turner 2001-07-26 18:50:19 EDT
Description of Problem:
(usability grumbles)

Where there are several packages with the same name but different
architecture, they are indistinguishable from each other in the "Install"
window. Also, for installed packages, it doesn't seem possible to
tell which arch version of the package was installed. (possibly RPM
limitations rather than GnoRPM?)

How Reproducible:
Every time

Steps to Reproduce:
1. Insert and mount Red Hat 7.1 installation disc 1 (for example)
2. Fire up GnoRPM
3. Click Install
4. Observe duplicate entries for "gzip", "kernel", "glibc", etc.
5. Note that it is not possible to tell which arch version was installed
   by querying the installed version of one of the above 3 packages.

Entries for "kernel" might appear as
kernel-2.4.2-2
kernel-2.4.2-2
kernel-2.4.2-2

Would look better as
kernel-2.4.2-2 (i386)
kernel-2.4.2-2 (i586)
kernel-2.4.2-2 (i686)
Comment 1 Alexander Larsson 2001-07-27 10:43:46 EDT
Ah, that does indeed make it slightly hard to use.
Comment 2 Alexander Larsson 2001-08-02 11:34:24 EDT
In order to get the developers and maintainers of GnoRPM to look at this bug I
have moved it to the GnoRPM category in the Gnome bug tracker. It can be found
at http://bugzilla.gnome.org/show_bug.cgi?id=58445, where you can add yourself
to the cc-field if you want to recieve information about changes to the bug tatus.


Comment 3 Alexander Larsson 2001-08-23 11:02:34 EDT
*** Bug 52389 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.