This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 501217 - RFE: autocompletion of previous input with Tab
RFE: autocompletion of previous input with Tab
Status: CLOSED DUPLICATE of bug 509480
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 00:23 EDT by Jens Petersen
Modified: 2009-07-24 00:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 00:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-05-18 00:23:15 EDT
Description of problem:
Apparently some input method systems on windows support autocompletion
of previous input with the Tab key - it would be a nice feature for
ibus-anthy.

Steps to Reproduce:
1. eg type internet in katakana
2. next time type inta- Tab
  
Expected results:
2. would complete to internet in katakana, etc

Additional info:
Takuro said this feature may exist in ATOK.
Comment 2 Takuro Nagamoto 2009-05-18 22:25:48 EDT
I would like to add some comment on the autocompletion function for Japanese.
Although it was first introduced with ATOK, SCIM+Anthy also has the same function.
I don't know when it was implemented, but I've been using it with my RHEL machine for quite some time.

Regards,
Takuro
Comment 3 Akira TAGOH 2009-05-18 22:39:13 EDT
You mean predicting words?
Comment 4 Takuro Nagamoto 2009-06-10 23:23:39 EDT
(In reply to comment #3)
> You mean predicting words?  

I meant 'auto-completion for previously entered words'. I think 'predicting words' is a bit different function. I normally turn off that function because it bothers me. 

With 'auto-completion', you can save keyboard strokes when you enter the same word. For example, when you typed 'コンポーネント' once, you only need to type 'コン' next time to enter 'コンポーネント'. If you hit Tab button, 'コン' is supplimented with 'ポーネント'.
Comment 5 Jens Petersen 2009-06-11 21:22:52 EDT
(In reply to comment #2)
> I don't know when it was implemented, but I've been using it with my RHEL
> machine for quite some time.

Ok cool.  So it works inside kbabel?

Perhaps it is quicker if you show me directly. :)
Comment 6 Akira TAGOH 2009-06-15 01:51:58 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > You mean predicting words?  
> 
> I meant 'auto-completion for previously entered words'. I think 'predicting
> words' is a bit different function. I normally turn off that function because
> it bothers me. 

I've not tried but just some research to my friends to see how it works. after that, I don't really see different between what you want and the behaviour of scim-anthy to select the candidate from the predicting words list with Tab. no such features in scim-anthy to do auto-completion with Enter (seems that Shift-Enter does in ATOK though).
Comment 7 Takuro Nagamoto 2009-06-15 20:53:57 EDT
>I don't really see different between what you want and the behaviour of
>scim-anthy to select the candidate from the predicting words list with Tab
It looks there is no difference between them. Both refers to the same entry history (previously entered words). The only difference is whether you manually show candidates by using Tab, or you automatically show candidates by turning on the option of scim. 

Sorry for some confusion.
Comment 8 Jens Petersen 2009-06-16 04:02:41 EDT
Thanks Takuro-san for demonstrating to me.

Seems Tab completion feature with scim-anthy does not require
the prediction feature to be enabled in setup.
Comment 9 fujiwara 2009-07-22 22:03:22 EDT
My understanding is this bug is duplicated of 509480.
I will close this bug later.
Comment 10 fujiwara 2009-07-24 00:40:18 EDT

*** This bug has been marked as a duplicate of bug 509480 ***

Note You need to log in before you can comment on or make changes to this bug.