Bug 501323 - Please update ftgl to 2.1.3rc5
Please update ftgl to 2.1.3rc5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ftgl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 502191
  Show dependency treegraph
 
Reported: 2009-05-18 10:50 EDT by Hans de Goede
Modified: 2009-06-02 04:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 04:57:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2009-05-18 10:50:10 EDT
I'm packaging chromium:
http://www.reptilelabour.com/software/chromium/

And that requires atleast version 2.1.3 of ftgl. Even though 2.1.3 is only
a release candidate it seems stable, even Debian is shipping it and it
has some important new features such as promised API stability and UTF-8
support.

Updating ftgl would affect the following packages:
[hans@localhost devel]$ repoquery -q --whatrequires --alldeps ftgl
cinepaint-libs-0:0.22.1-12.fc11.2.x86_64
sdljava-0:0.9.1-11.fc11.x86_64
libprojectM-0:1.2.0-9.fc11.x86_64
icc_examin-0:0.46-1.fc11.x86_64

cinepaint and icc_examin are maintained by the ftgl maintainer, sdljava is mainained by me. So that only leaves libprojectM, which is maintained by
imntreal (added to the CC). imntreal are you ok with updating ftgl to the latest version (and then rebuilding libprojectM, as this update will probably require rebuilds of the dependent packages) ?
Comment 1 Nicolas Chauvet (kwizart) 2009-05-18 13:01:08 EDT
I will propose a ftgl-2.1.3-0.1rc5 in few days in order to have things tested.
Then I will update it in F-12 (will be updated only there).
Comment 2 Nicolas Chauvet (kwizart) 2009-05-22 04:57:49 EDT
Package built just now.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1369999

Please wait at least one hour to rebuild yours, I will close the bug once every packages listed above are rebuilt.

Just for the record, I've check what's available in ftgl-svn and there is only one version bump to 2.2.0. (no code improvements).
Comment 3 Hans de Goede 2009-05-22 08:18:11 EDT
Thanks!

sdljava is rebuilding now (local rebuild was ok):
http://koji.fedoraproject.org/koji/taskinfo?taskID=1370376
Comment 4 Nicolas Chauvet (kwizart) 2009-06-02 04:57:28 EDT
@Jameson
libprojectM still need a rebuild, please do so it ASAP.
Closing the bug for now.

Note You need to log in before you can comment on or make changes to this bug.