Bug 501422 - [ta_IN][GPOS]" U+0BB[8-9] U+0BC2" have error results.
[ta_IN][GPOS]" U+0BB[8-9] U+0BC2" have error results.
Status: CLOSED DUPLICATE of bug 524457
Product: Fedora
Classification: Fedora
Component: lohit-tamil-fonts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 23:35 EDT by XinSun
Modified: 2009-09-23 01:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 01:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0BB8-0BC2.jpg (1.15 KB, image/jpeg)
2009-05-18 23:35 EDT, XinSun
no flags Details
0BB9-0BC2.jpg (1.23 KB, image/jpeg)
2009-05-18 23:35 EDT, XinSun
no flags Details
0B9C-0BC2.jpg (1.18 KB, image/jpeg)
2009-05-18 23:37 EDT, XinSun
no flags Details

  None (edit)
Description XinSun 2009-05-18 23:35:00 EDT
Created attachment 344553 [details]
0BB8-0BC2.jpg

Description of problem:
When inputing "U+0BB8 U+0BC2" or "U+0BB9 U+0BC2" in gedit, the results were
wrong.

Version-Release number of selected component (if applicable):
pangomm-2.14.1-1.fc10.x86_64
pango-1.22.3-1.fc10.i386
pango-1.22.3-1.fc10.x86_64
pango-devel-1.22.3-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Select "RAW CODE" in scim-bridge
2.Input "U+0BB8 U+0BC2" or "U+0BB9 U+0BC2" in gedit.

Actual results:
The result are 

U+0BB8 U+0BC2  ஸூ

U+0BB9 U+0BC2  ஹூ

and they are different from the correct images.

Expected results:
Please see the attachment: 0BB8-0BC2.jpg and 0BB9-0BC2.jpg
Comment 1 XinSun 2009-05-18 23:35:33 EDT
Created attachment 344554 [details]
0BB9-0BC2.jpg
Comment 2 XinSun 2009-05-18 23:36:30 EDT
"U+0B9C U+0BC2"  has the same problem.
Actural results:
"U+0B9C U+0BC2"  ஜூ

Expected results:
Please see the attachment 0B9C-0BC2.jpg
Comment 3 XinSun 2009-05-18 23:37:11 EDT
Created attachment 344555 [details]
0B9C-0BC2.jpg
Comment 4 Parag Nemade 2009-09-04 02:35:44 EDT
felix,
  Can you give correct image for following combination?

1) U+0BB8 U+0BC2
2) U+0BB9 U+0BC2
3) U+0B9C U+0BC2

Or you can just tell us if above(comment#1 and comment#3) attached images are the correct rendering for these combinations?
Comment 5 sandeep shedmake 2009-09-20 10:20:58 EDT
The character classes for the aforementioned characters (forming respective
syllable combination) are defined correctly in pango-1.22.3-1.fc10.i386.


Additionally, I noticed "serafettin-cartoon-fonts" yields correct/desired
results for following combination:

1) U+0BB8 U+0BC2
2) U+0BB9 U+0BC2
3) U+0B9C U+0BC2


Whereas, lohit-tamil-fonts fails to give correct results for above combination.

I have filed a bug against lohit-tamil-fonts (see bug 524457). 
I have attached corrected font file in the same bug, which yields the expected
results.
Comment 6 sandeep shedmake 2009-09-23 01:33:05 EDT
From Comment #5,

Correct behaviour of following combination:

1) U+0BB8 U+0BC2
2) U+0BB9 U+0BC2
3) U+0B9C U+0BC2

can now be  obtained from build lohit-tamil-fonts-2_4_4-1_fc12 (available in Rawhide).
Comment 7 sandeep shedmake 2009-09-23 01:52:40 EDT

*** This bug has been marked as a duplicate of bug 524457 ***

Note You need to log in before you can comment on or make changes to this bug.