Bug 524457 - [ta_IN] Anchor Point class for 0BC1 and OBC2 should not be "abvm"
Summary: [ta_IN] Anchor Point class for 0BC1 and OBC2 should not be "abvm"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-tamil-fonts
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 501422 501424 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-20 13:08 UTC by sandeep shedmake
Modified: 2009-09-23 05:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-23 05:34:09 UTC
Type: ---


Attachments (Terms of Use)
Correct behaviour of 0BC1 and 0BC2 (i.e. without "abvm"). (22.31 KB, image/png)
2009-09-20 13:08 UTC, sandeep shedmake
no flags Details
ttf file handling correct behaviour of 0BC1 & 0BC2 based syllables (66.10 KB, application/x-font-ttf)
2009-09-20 13:52 UTC, sandeep shedmake
no flags Details
patch handling correct behaviour of 0BC1 and 0BC2 based syllables (5.25 KB, patch)
2009-09-21 10:18 UTC, sandeep shedmake
no flags Details | Diff

Description sandeep shedmake 2009-09-20 13:08:29 UTC
Created attachment 361820 [details]
Correct behaviour of 0BC1 and 0BC2 (i.e. without "abvm").

Description of problem:
glyphs 0BC1 and OBC2 should not have Anchor Point class as "abvm".

Version-Release number of selected component (if applicable):
lohit-tamil-fonts-2.4.3-1.fc12.noarch

How reproducible:
always

Steps to Reproduce:
1. Open gedit
2. Input "U+0BB8" + "U+0BC1" 
3. Input "U+0BB8" + "U+0BC2"
  
Actual results:
0BB8 + 0BC1  ==>  ஸு
0BB8 + 0BC2  ==>  ஸூ

Expected results:
see attachment

Additional info:
1) As per http://unicode.org/charts/PDF/U0B80.pdf,

OBC1  == TAMIL VOWEL SIGN U
OBC2  == TAMIL VOWEL SIGN UU

2) Declaring 0BC1 and OBC2 as "abvm" causes syllable formation "above" the  base-glyph 
(which is wrong behaviour).

Comment 1 sandeep shedmake 2009-09-20 13:52:10 UTC
Created attachment 361822 [details]
ttf file handling correct behaviour of 0BC1 & 0BC2 based syllables

Comment 2 Pravin Satpute 2009-09-21 04:21:54 UTC
hi felix,
can you confirm this thing?

Comment 3 Felix 2009-09-21 08:02:50 UTC
From Comment #1

With the attached font file now it is looking fine and perfect.

Eg. the below combination are looking fine:

0BB8 + 0BC1  ==>  ஸு
0BB8 + 0BC2  ==>  ஸூ

Thanks

Comment 4 Pravin Satpute 2009-09-21 10:06:52 UTC
felix thanks,
sandeep can you put submit patch here?

Comment 5 sandeep shedmake 2009-09-21 10:18:06 UTC
Created attachment 361905 [details]
patch handling correct behaviour of 0BC1 and 0BC2 based syllables

Comment 6 Pravin Satpute 2009-09-21 12:18:23 UTC
build lohit-tamil-fonts-2_4_4-1_fc12
will be available in wed. rawhide

Comment 7 sandeep shedmake 2009-09-23 05:34:09 UTC
From Comment #6,


Correct behaviour of 0BC1 and 0BC2 based syllables can now be  obtained from build lohit-tamil-fonts-2_4_4-1_fc12 (available in Rawhide).


Hence, closing this bug.

Comment 8 sandeep shedmake 2009-09-23 05:52:40 UTC
*** Bug 501422 has been marked as a duplicate of this bug. ***

Comment 9 sandeep shedmake 2009-09-23 05:52:55 UTC
*** Bug 501424 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.