Bug 501428 - Installing livecd from usb stick, partitioning does not complete
Installing livecd from usb stick, partitioning does not complete
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 505363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 23:57 EDT by Traxtopel
Modified: 2009-09-26 17:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 502771 (view as bug list)
Environment:
Last Closed: 2009-07-02 10:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda error log (114.55 KB, text/plain)
2009-05-18 23:57 EDT, Traxtopel
no flags Details
Using anaconda-11.5.0.53-1 (25.42 KB, text/plain)
2009-05-19 01:00 EDT, Traxtopel
no flags Details
Install Error Log (265.64 KB, text/plain)
2009-05-25 11:09 EDT, Traxtopel
no flags Details

  None (edit)
Description Traxtopel 2009-05-18 23:57:56 EDT
Created attachment 344560 [details]
anaconda error log

If I create a usb stick from a live cd iso(rawhide/f11 - 20080515).
Boot from the usb stick, try to install using "liveinst". 
Partitioning never completes after clicking on Next.
Eventually if I do click next i.e. 20 minutes later a error dialog appears.
Asks me to format "/"
Then I get an Exception Occured Dialog.
Error attached to ticket.

Note
The same image booted from iso installs correctly.
This method worked previously with Fedora 10.  


If I manually format the partition from the console and only assign a mount
point in anaconda, it installs correctly.  

anaconda-11.5.0.52
Comment 1 Traxtopel 2009-05-19 01:00:05 EDT
Created attachment 344563 [details]
Using anaconda-11.5.0.53-1
Comment 2 Traxtopel 2009-05-19 01:02:02 EDT
Missed my entry, I tested using anaconda-11.5.0.53-1, anaconda fails now before I can partition. See log.
Comment 3 Chris Lumens 2009-05-19 14:30:14 EDT
This will be fixed in the next build of anaconda for F11.  Thanks for the bug report.
Comment 4 Traxtopel 2009-05-20 01:33:49 EDT
So I updated to anaconda-11.5.0.54-1 & pykickstart-1.54-1 from koji. Not sure if the initial bug would be fixed in this. Also seeing this which I am sure is related to the drive not getting formatted.

If I select "replace existing Linux system" or "Use entire drive".

The following errors occurred with your partitioning:

Your / partition does not match the the live image you are installing from.  It must be formatted as ext3.

This can happen if there is not enough space on your hard drive(s) for the installation. 

Press 'OK' to choose a different partitioning option.

"Use entire drive" should just nuke everything right?
Comment 5 Traxtopel 2009-05-20 04:54:17 EDT
Another finding.

When you have selected the partitioning of the harddisk, clicked next and waiting for the install to start. The NEXT button is still clickable, if you click on this by mistake or think the install is not running, it will fail.

Perhaps this is only present on slower machines.

Would it be possible to disable Next after paritioning starts, so this cannot fail?
Comment 6 Traxtopel 2009-05-25 11:09:15 EDT
Created attachment 345329 [details]
Install Error Log
Comment 7 Chris Lumens 2009-06-11 16:19:42 EDT
*** Bug 505363 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2009-07-02 10:25:22 EDT
These are completely separate bugs from the initial report.  Please use one bug per problem.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.