Bug 501633 - libnet 1.1.3 breaks heartbeat builds
libnet 1.1.3 breaks heartbeat builds
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: libnet (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
: 502400 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 01:24 EDT by Kevin Fenzi
Modified: 2009-06-11 09:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 09:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2009-05-20 01:24:49 EDT
I can't seem to build heartbeat anymore against libnet-devel 1.1.3.

n file included from /usr/include/libnet.h:120,
                 from send_arp.c:33:
/usr/include/./libnet/libnet-types.h:36:23: error: ../config.h: No such file or directory

Heartbeat does set: -DHAVE_CONFIG_H set for it's own needs... 

Older versions of that header file did not have the HAVE_CONFIG_H section... 
This happens in rawhide as well.
Comment 1 Robert Scheck 2009-05-20 02:42:04 EDT
Issue forwarded to upstream, upstream is on vacation until May 26th, 2009.
Comment 2 Robert Scheck 2009-05-24 16:51:29 EDT
*** Bug 502400 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Fenzi 2009-05-31 23:41:29 EDT
Any news from upstream here?
Comment 4 Robert Scheck 2009-06-06 09:26:46 EDT
Upstream replied, I built 1.1.3-2 on Rawhide, can you please test it first 
there? Because upstream seems to tend to release 1.1.4 soon, if fix works.
Comment 5 Kevin Fenzi 2009-06-06 17:11:58 EDT
Yep. This fixes the heartbeat build just fine. ;) 

Shall I wait for 1.1.4 to push heartbeat builds?
Comment 6 Robert Scheck 2009-06-07 17:01:15 EDT
Yes, please. Libnet 1.1.4 should get released on Tuesday according to upstream.
Comment 7 Robert Scheck 2009-06-11 09:53:07 EDT
Package: libnet-1.1.4-1.fc12 Tag: dist-f12 Status: complete

2527 (libnet): Build on target fedora-5-epel succeeded.
2528 (libnet): Build on target fedora-4-epel succeeded.

Note You need to log in before you can comment on or make changes to this bug.