Bug 501723 - yum-plugin-tmprepo-1.1.22-1.fc11 causes yum to crash
yum-plugin-tmprepo-1.1.22-1.fc11 causes yum to crash
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 506229 506515 507008 507417 513319 521469 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 09:57 EDT by Siobhan
Modified: 2014-01-21 18:09 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 10:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siobhan 2009-05-20 09:57:24 EDT
Description of problem:

Installing yum-plugin-tmprepo-1.1.22-1.fc11.noarch from updates-testing causes yum to fail unless the plugin is disabled (--disableplugin=yum-tmprepo).


Version-Release number of selected component (if applicable):

yum-plugin-tmprepo-1.1.22-1.fc11.noarch


How reproducible:

Install yum-plugin-tmprepo-1.1.22-1.fc11.noarch


Steps to Reproduce:
1. Enable updates-testing repo for F11
2. yum install yum-plugin-tmprepo-1.1.22-1.fc11.noarch
3. Issue any yum command without --disableplugin=yum-tmprepo


Actual results:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 189, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 649, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 237, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 408, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 163, in __init__
    self.run('config')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/tmprepo.py", line 179, in config_hook
    parser.values.tmp_repos = []
AttributeError: OptionGroup instance has no attribute 'values'


Expected results:

Expect yum to function without fatal python errors.


Additional info:

=================================================================================================================================================================================
 Package                                        Arch                               Version                                     Repository                                   Size
=================================================================================================================================================================================
Installing:
 yum-plugin-tmprepo                             noarch                             1.1.22-1.fc11                               updates-testing                              13 k

Transaction Summary
=================================================================================================================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 13 k
Is this ok [y/N]: y
Downloading Packages:
yum-plugin-tmprepo-1.1.22-1.fc11.noarch.rpm                                                                                                               |  13 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : yum-plugin-tmprepo-1.1.22-1.fc11.noarch                                                                                                                   1/1 

Installed:
  yum-plugin-tmprepo.noarch 0:1.1.22-1.fc11                                                                                                                                      

Complete!
[root@xxxxxxxxxx ~]# yum update
Loaded plugins: aliases, allowdowngrade, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, protect-packages, refresh-packagekit,
              : refresh-updatesd, remove-with-leaves, tmprepo, verify, versionlock
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 189, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 649, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 237, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 408, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 163, in __init__
    self.run('config')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/tmprepo.py", line 179, in config_hook
    parser.values.tmp_repos = []
AttributeError: OptionGroup instance has no attribute 'values'

[root@xxxxxxxxxx ~]# yum --disableplugin=tmprepo remove yum-tmprepo
Loaded plugins: aliases, allowdowngrade, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, protect-packages, refresh-packagekit,
              : refresh-updatesd, remove-with-leaves, verify, versionlock
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package yum-plugin-tmprepo.noarch 0:1.1.22-1.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================================================
 Package                                          Arch                                 Version                                     Repository                               Size
=================================================================================================================================================================================
Removing:
 yum-plugin-tmprepo                               noarch                               1.1.22-1.fc11                               installed                               7.6 k

Transaction Summary
=================================================================================================================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : yum-plugin-tmprepo-1.1.22-1.fc11.noarch                                                                                                                   1/1 

Removed:
  yum-plugin-tmprepo.noarch 0:1.1.22-1.fc11                                                                                                                                      
Complete!
Comment 1 James Antill 2009-05-20 10:07:08 EDT
  File "/usr/lib/yum-plugins/tmprepo.py", line 179, in config_hook
    parser.values.tmp_repos = []
AttributeError: OptionGroup instance has no attribute 'values'

...delete that line and it'll work, it's fixed upstream but no new yum-utils yet.
Comment 2 Bug Zapper 2009-06-09 12:10:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Joe Christy 2009-06-17 15:59:07 EDT
This also affects F10
Comment 4 John Guthrie 2009-06-19 11:38:34 EDT
*** Bug 506229 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Burgess 2009-06-20 15:59:52 EDT
Just happened to me in fc10 with yum-plugin-tmprepo.noarch 0:1.1.22-1.fc10 from updates. I deleted the package to work around it.
Comment 6 Yuri Timofeev 2009-06-22 09:01:17 EDT
I confirm, also worked :
rpm -e yum-plugin-tmprepo
Comment 7 James Antill 2009-06-22 10:36:52 EDT
*** Bug 507008 has been marked as a duplicate of this bug. ***
Comment 8 James Antill 2009-06-22 13:55:55 EDT
*** Bug 507417 has been marked as a duplicate of this bug. ***
Comment 9 John Guthrie 2009-06-22 23:05:59 EDT
(In reply to comment #5)
> Just happened to me in fc10 with yum-plugin-tmprepo.noarch 0:1.1.22-1.fc10 from
> updates. I deleted the package to work around it.  

I was able to work around simply by disabling the plugin in /etc/yum/pluginconf.d/tmprepo.conf.  In that file, change

enabled=1

to read

enabled=0

and yum should work again.
Comment 10 John Guthrie 2009-06-22 23:14:03 EDT
Also, shouldn't we think about changing the affected component of this bug from yum-utils to yum-plugin-tmprepo?
Comment 11 James Antill 2009-07-23 00:11:16 EDT
*** Bug 513319 has been marked as a duplicate of this bug. ***
Comment 12 seth vidal 2009-09-08 15:38:43 EDT
*** Bug 521469 has been marked as a duplicate of this bug. ***
Comment 13 seth vidal 2009-10-12 10:26:45 EDT
this is fixed in latest f11 yum-utils.
Comment 14 seth vidal 2009-10-12 17:22:24 EDT
*** Bug 506515 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.