Bug 506515 - yum-3.2.23-3.fc10 crashes every time on launch from command line
yum-3.2.23-3.fc10 crashes every time on launch from command line
Status: CLOSED DUPLICATE of bug 501723
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 11:45 EDT by Joe Christy
Modified: 2014-01-21 18:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 17:22:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cut&paste from konsole of attemting to run yum, w/ stack trace (1.50 KB, text/plain)
2009-06-17 11:45 EDT, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2009-06-17 11:45:41 EDT
Created attachment 348277 [details]
cut&paste from konsole of attemting to run yum, w/ stack trace

Description of problem:
yum-3.2.23-3.fc10 crashes every time on launch from command line

Version-Release number of selected component (if applicable):
3.2.23-3.fc10

How reproducible:
every time

Steps to Reproduce:
1.launch yum, e.g execute yum list installed
2.
3.
  
Actual results:
yum crashes w/ stack trace, attached

Expected results:
yum lists installed software

Additional info:
The same exact thing happens running "yum clean all" "yum check update", "yum", etc., ie. same instantaneous crash and stack trace.
Comment 1 Joe Christy 2009-06-17 11:57:37 EDT
Wait - moving all plugins and their configs out of the way restores functionality to yum.

Later this AM, I'll binary search my plugins to find the culprit.
Comment 2 seth vidal 2009-06-17 12:02:31 EDT
no need - it's tmprepo.

Why do you have almost EVERY plugin installed?
Comment 3 Joe Christy 2009-06-17 15:51:52 EDT
Well, I didn't exactly do binary search, simply reinstalled my yumm plugins one by one, which uncovered on anomaly and the buggy plugin. To wit:

I worked through the plugins in my moved copy of /usr/lib/yum-plugins, doing:
rpm -qf <whatever>.py
yum-reinstall <result of prior rpm -qf>
If that failed I manually did:
yum remove <result of prior rpm -qf>
yum install <result of prior command>

The following discrepancies arose - 
before I had:
yum-allowdowngrade.noarch                 1.1.19-1.fc10

afterwards I had:
yum-allowdowngrade.noarch                      1.1.18-2.fc10

Installing yum-plugin-tmprepo causes crash!!

I'll file a new bug for that plugin only.
Comment 4 Joe Christy 2009-06-17 15:53:26 EDT
WRT comment #2, believe it or not, I've used all of them at one time or other, some for ancient Fedora versions.
Comment 5 Joe Christy 2009-06-17 15:59:51 EDT
cf. https://bugzilla.redhat.com/show_bug.cgi?id=501723
Comment 6 seth vidal 2009-10-12 17:22:24 EDT

*** This bug has been marked as a duplicate of bug 501723 ***

Note You need to log in before you can comment on or make changes to this bug.