Bug 501805 - Ugly URLS that may change on rebuild due to DocBook section ID attribute not set
Ugly URLS that may change on rebuild due to DocBook section ID attribute not set
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
http://docs.fedoraproject.org/release...
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2009-05-20 15:07 EDT by Karsten Wade
Modified: 2009-05-22 01:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 01:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2009-05-20 15:07:06 EDT
It appears that none of the section ID attributes were set for the Fedora 11 release notes, so URLs are ugly ...

http://docs.fedoraproject.org/release-notes/f11preview/en-US/index.html#id2781534

... instead of pretty and welcoming ...

http://docs.fedoraproject.org/release-notes/f10/en_US/index.html#Welcome_to_Fedora_10

In addition, it is possible that the generated ID attributes are different every time the release notes are built from DocBook source.  This means that when the release notes are updated with bug fixes, it may break every single URL link inward.  That is not good.  (Not sure if this behavior is still the same in the DocBook toolchain.)

As a person who has done the manual ID attribute creation since forever, I know what a PITA it is.  There are ways to work this out with improvements to the toolchain (either how the DocbBook comes from the wiki or how Publican handles it by auto-generating ID attributes from the contents of the <title> block).  In the meanwhile, I can only see manual ID attributes as the way to go.
Comment 1 Ruediger Landmann 2009-05-22 01:02:51 EDT
Fixed in version 1.5 with Publican's "make clean_ids"

Note You need to log in before you can comment on or make changes to this bug.