Bug 501875 - Swedish yum strings incorrect or not translated
Swedish yum strings incorrect or not translated
Status: CLOSED CURRENTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Other language (Show other bugs)
unspecified
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Göran Uddeborg
A S Alam
:
Depends On: 502075 502312
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 04:17 EDT by Daniel Lindgren
Modified: 2013-07-02 20:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: yum-3.2.25-1.fc12.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-22 16:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Lindgren 2009-05-21 04:17:05 EDT
Description of problem:

Some yum strings are either misspelled or not translated, example:

[...]
Transaktionssamanfattning
==================================================================================================================
Installerar      0 Package(s)         
Uppdaterar       8 Package(s)         
Tar bort         0 Package(s)     
[...]

- "Transaktionssamanfattning" is misspelled, should be "Transaktionssammanfattning".
- "Package(s)" should be translated to "Paket".

Version-Release number of selected component (if applicable):

Fedora 11 RC.

How reproducible:

Very.

Steps to Reproduce:
1. Run "yum update" on a swedish FC11 RC. If there are any updates, you'll see.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Xavier Conde 2009-05-21 04:29:26 EDT
Hi,

I'm having a similar issue with "yum erase" command, when uninstalling a package, there's a message in Catalan (ca) that says 

"S'està esborran"

whereas it should be 

"S'està esborrant"

but I've not been able to find the incorrect string in the latest catalan yum PO file in Transifex, see:

https://translate.fedoraproject.org/tx/projects/yum/yum-3_2_X/raw/po/ca.po

Thanks in advance!
Comment 2 Thomas Spura 2009-05-21 13:07:21 EDT
For the Catalan issue:

I found it in:
https://translate.fedoraproject.org/tx/projects/yum/master/raw/po/ca.po

    Thomas
Comment 3 Göran Uddeborg 2009-05-21 14:28:48 EDT
Yum does not accept updates via transifex, but I'll file a separate bugzilla with a new translation.
Comment 4 Daniel Lindgren 2009-05-21 16:14:09 EDT
Checked the file submitted in bug 502075 and the string "Transaktionssamanfattning\n" is still misspelled (only one "m"). Should be "Transaktionssammanfattning\n".
Comment 5 Xavier Conde 2009-05-22 04:50:05 EDT
Hi Göran,

in the case of catalan, I've checked translation file and it's ok, but the string shown isn't.

I've created an .mo file from my translation and replaced with the .mo file distributed, wrong string is shown still. Is yum using any other contexts for loading gettext strings?

Thanks in advance!
Comment 6 Göran Uddeborg 2009-05-23 12:44:49 EDT
(In reply to comment #4)
> Checked the file submitted in bug 502075 and the string
> "Transaktionssamanfattning\n" is still misspelled (only one "m"). Should be
> "Transaktionssammanfattning\n".  

How did that happen?!?  That was the first thing I fixed.

Oh, well, I'll try again.
Comment 7 Göran Uddeborg 2009-05-23 15:13:22 EDT
(In reply to comment #5)
> I've created an .mo file from my translation and replaced with the .mo file
> distributed, wrong string is shown still. Is yum using any other contexts for
> loading gettext strings?

As far as I know, there is nothing special with yum.  When testing the Swedish translation, I've placed the compiled, mo, file as /usr/share/locale/sv/LC_MESSAGES/yum.mo, and that works for me.  If you replace /usr/share/locale/ca/LC_MESSAGES/yum.mo with your new mo file, it is strange if you don't get the new translations.

You are sure you put it in the right place?  It is easy to make silly mistakes!  (As can be seen in comment 6! :-)
Comment 8 Piotr Drąg 2009-06-13 00:11:01 EDT
Ping? Any progress?
Comment 9 Göran Uddeborg 2009-06-13 17:29:00 EDT
Oh, I should of course have handled this.  The corrected translation is forwarded upstreams according to bug 502312.  I'll check shortly if it got into Fedora 11.
Comment 10 Piotr Drąg 2009-06-13 17:49:26 EDT
According to git, it hasn't yet. We have to wait for yum update to version 3.2.24. Current version in updates-testing is 3.2.23.
Comment 11 Piotr Drąg 2009-09-04 18:24:10 EDT
Could you please check the issue with this package for F11?

http://koji.fedoraproject.org/koji/buildinfo?buildID=130500
Comment 12 Daniel Lindgren 2009-09-05 02:01:12 EDT
Doesn't look like it's fixed:

[root@testburk ~]# export LANG=sv_SE.UTF-8
[root@testburk ~]# yum --version
3.2.24
  Installerade: rpm-4.7.1-1.fc11.x86_64 2009-08-05 11:57
  Byggde      : Fedora Project 2009-07-24 05:07
  Verkställde : Panu Matilainen <pmatilai@redhat.com> 2009-07-23 12:00

  Installerade: yum-3.2.24-1.fc11.noarch 2009-09-05 05:40
  Byggde      : Fedora Project 2009-09-03 19:24
  Verkställde : Seth Vidal <skvidal at fedoraproject.org> 2009-09-03 12:00

  Installerade: yum-metadata-parser-1.1.2-12.fc11.x86_64 2009-07-17 08:35
  Byggde      : Fedora Project 2009-02-25 18:45
  Verkställde : Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 2009-02-25 22:00
[root@testburk ~]# ls -la /usr/share/locale/sv/LC_MESSAGES/yum.mo
-rw-r--r--. 1 root root 41043  3 sep 21.24 /usr/share/locale/sv/LC_MESSAGES/yum.mo
[root@testburk ~]# yum update
Inlästa insticksmoduler: refresh-packagekit
Förbereder uppdateringsprocessen
Löser upp beroenden
--> Kör transaktionskontroll

...

Installerar på grund av beroenden:
 hplip-common                     x86_64  3.9.8-12.fc11                         updates   63 k

Transaction Summary
===============================================================================================
Install       3 Package(s)
Upgrade     193 Package(s)

Total storlek att hämta: 308 M
Är detta ok [j/N]: 
Avslutar på användarens order
Klart!

As you can see, there are still english strings mixed in, "Transaction Summary", "Install/Upgrade", "Package(s)".
Comment 13 Göran Uddeborg 2009-09-05 10:39:22 EDT
But that is a different behaviour than before.  Now "Transaction Summary" isn't translated at all.  Before there was a misspelling in the translation.  And Install/Upgrade used to be translated.

Most likely, there has been developments since my last translation, and it needs to be updated.  I'll have a look at it.
Comment 14 Göran Uddeborg 2009-09-05 11:12:59 EDT
I've submitted an updated translation.  The current instructions is to use the upstreams ticket system for the purpose: http://yum.baseurl.org/ticket/238
Comment 15 Piotr Drąg 2009-10-16 18:45:36 EDT
Updated translation has been committed upstream.

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=8e9edba9b1fa0ce047f76ad0777654f90dfd4e17
Comment 16 Piotr Drąg 2009-11-22 15:43:22 EST
Is this issue fixed in yum-3.2.25?
Comment 17 Göran Uddeborg 2009-11-22 16:48:54 EST
Yes, it seems it got into 3.2.25 in F12:

22:41 mimmi$ rpm -q yum
yum-3.2.25-1.fc12.noarch
22:39 mimmi$ sudo yum upgrade selinux-policy-targeted
[...]
Transaktionssammanfattning
================================================================================
Installerar       0 Paket
Uppdaterar        6 Paket
[...]

Note You need to log in before you can comment on or make changes to this bug.