Bug 50197 - rpm --recompile creates binary rpm(s)
rpm --recompile creates binary rpm(s)
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-27 19:42 EDT by Michael Schwendt
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-20 19:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch suggestion (446 bytes, patch)
2001-12-20 19:25 EST, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2001-07-27 19:42:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628

Description of problem:
Contrary to the documentation (man rpm or rpm --help), option --recompile
creates binary rpm(s).


How reproducible:
Always

Steps to Reproduce:
1. rpm --recompile <sourcepkg.rpm>
2. watch-standard-output and check the RPMS/i386/ directory
	

Actual Results:  Option --recompile created binary rpm(s).

Expected Results:  Well, if the docs are to be believed, option --recompile
should not have created any binary rpms. Option --rebuild does that and
also the source rpm(s).

Additional info:

[This has come up on the Seawolf mailing-list where I mentioned that rpm
--recompile would create binary rpms only, but no source rpms. Someone
followed up that --recompile would not create any rpms at all. But since
I've been using --recompile to create binary rpms for some time, I had to
check the docs again and found this behaviour to be either a bug or
inconsistency at least.]
Comment 1 Jeff Johnson 2001-07-27 23:07:16 EDT
I have no clue what you are talking about. The option --recompile
creates *only* binary rpm's, but does *not* create another src.rpm.
That's the way it's always worked.
Comment 2 Michael Schwendt 2001-07-28 06:37:29 EDT
That's the way I've used it for a long time.
*But* the docs don't say that:

See "man rpm", section REBUILD AND RECOMPILE OPTIONS:

    [...] In addition, --rebuild builds a new binary package. [...]

Should either read "... a new source package..." or should be dropped, because
--recompile builds a new binary package, too. Hence "no addition".

And from rpm --help:

    --recompile <src_pkg>  - like --rebuild, but don't build any package

Wrong. It does build a package. Just not a source package.

(Previous bug comment explains why this issue has come up.)
Comment 3 Jeff Johnson 2001-12-09 13:46:38 EST
Hmmm, there appears only to be a doco problem
here, not a functional problem. Since the build
modes are now in a separate executable, and
the man page will be reworked in rpm-4.1,
I'm gonna mark this problem deferred.
Comment 4 Michael Schwendt 2001-12-09 14:36:53 EST
Yes, it is a docu problem and most likely *the* reason why people everywhere use
(and suggest) rpm --rebuild, although they want just binary rpms and could use
rpm --recompile.
Comment 6 Jeff Johnson 2001-12-20 13:08:34 EST
I'm not saying that there isn't a bug, only that I cannot reproduce.
I need to reproduce this if you want me to fix:

bash$ rpm --recompile /etc/inittab
Installing /etc/inittab
error: /etc/inittab cannot be installed
bash$
Comment 7 Michael Schwendt 2001-12-20 19:25:58 EST
Created attachment 41148 [details]
patch suggestion
Comment 8 Michael Schwendt 2001-12-21 21:34:02 EST
Sorry, the most recent comments belong to bug #57519. Will move them.

Note You need to log in before you can comment on or make changes to this bug.