Bug 502012 - cluster.ng secure tag
cluster.ng secure tag
Status: CLOSED DUPLICATE of bug 606826
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
Depends On:
  Show dependency treegraph
Reported: 2009-05-21 10:44 EDT by Ervin Horvath
Modified: 2010-11-09 08:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-07-01 15:07:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ervin Horvath 2009-05-21 10:44:58 EDT
Description of problem:
cluster.ng schema validator does not accept the new secure=<param> key in fence_bladecenter tag

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.have a basic cluster.conf file with
fencedevice name="blade_fence" agent="fence_bladecenter" ipaddr="" login="login" passwd="pwd"/
and check it against the schema validator with

2.xmllint --noout --relaxng /usr/share/system-config-cluster/misc/cluster.ng /tmp/basic.conf
and it says it is valid

3. no edit the config file, and add the the ssh-forcing tag mentioned in the manpage of fence_bladecenter
-x on command line OR
"secure = < param >
              Use secure connection over ssh." in xml
so it looks sg. like this:
fencedevice name="blade_fence" agent="fence_bladecenter" ipaddr="" login="login" passwd="pwd" secure="1"/

4. rerun the step2 validation, and it fails

Actual results:
Relax-NG validity error : Extra element fencedevices in interleave

Expected results:

Additional info:
probably the cluster.conf is good, only cluster.ng is not up to date in rhel5.3
Comment 1 Lon Hohberger 2010-07-01 15:07:36 EDT

*** This bug has been marked as a duplicate of bug 606826 ***

Note You need to log in before you can comment on or make changes to this bug.