Bug 502120 - All of the manpages in netpbm-progs appear to be merely textual, rather than troff source
All of the manpages in netpbm-progs appear to be merely textual, rather than ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: netpbm (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jindrich Novy
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 19:31 EDT by Dave Malcolm
Modified: 2013-07-02 19:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 09:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2009-05-21 19:31:01 EDT
Description of problem:
Minor issue: all of the manpages in netpbm-progs are plain text, rather than troff macros.
for f in `rpm -ql netpbm-progs | grep /man/` ; 
do 
  echo $f; gunzip -c $f | file - ; 
done

Looking at the manpages, either directly through "man", or via "gunzip -c $file | less" it looks like all of them have been already processed with troff, and the resulting text had been packaged.

Version-Release number of selected component (if applicable):
netpbm-progs-10.35-6.fc6

How reproducible:
100%

Steps to Reproduce:
As above; for instance: man /usr/share/man/man1/pamx.1.gz
  
Actual results:
- manpages have already been processed with troff; they appear without any emboldening on a tty that can handle it

Expected results:
- manpages should contain troff macros
Comment 1 Dave Malcolm 2009-05-21 19:31:54 EDT
(related to bug 204991 ?)
Comment 3 Radek Vokal 2010-04-13 09:01:09 EDT
Sounds like it should be fixed in current netpbm release.

Note You need to log in before you can comment on or make changes to this bug.