This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 502129 - Cannot choose left or right-handed options on mouse
Cannot choose left or right-handed options on mouse
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 517862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 22:28 EDT by Lawrence Graves
Modified: 2010-04-07 12:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-07 12:29:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The requested information (3.27 MB, image/x-portable-anymap)
2009-05-23 21:01 EDT, Lawrence Graves
no flags Details
The requested information (155 bytes, text/plain)
2009-05-23 21:27 EDT, Lawrence Graves
no flags Details
Current xorg.conf file (421 bytes, text/plain)
2009-05-25 20:53 EDT, Lawrence Graves
no flags Details
Current Xorg.o.log file (13.34 KB, text/plain)
2009-05-25 20:55 EDT, Lawrence Graves
no flags Details

  None (edit)
Description Lawrence Graves 2009-05-21 22:28:49 EDT
Cannot choose left or right-handed options on mouse selector


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.system
2.preference
3.mouse
  
Actual results:
Does not change at all

Expected results:
The ability to choose left or right-handed 

Additional info:Worked when first downloaded F11 Alpha and stop when F11-pre-lease was installed.
Comment 1 Matěj Cepl 2009-05-23 19:41:47 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Lawrence Graves 2009-05-23 21:01:01 EDT
Created attachment 345220 [details]
The requested information
Comment 3 Lawrence Graves 2009-05-23 21:27:13 EDT
Created attachment 345221 [details]
The requested information
Comment 4 Peter Hutterer 2009-05-25 18:23:37 EDT
Lawrence: Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report. Click on the "Add an attachment" link, the select the files (/etc/X11/xorg.conf and /var/log/Xorg.0.log) and enter the file name in the "short description" field.
Comment 5 Matěj Cepl 2009-05-25 18:42:41 EDT
a) I don't see /var/log/Xorg.0.log here
b) I don't get the point, where do you use nvidia binary-only driver? I thought vmware provides its own type of display (xorg-x11-drv-vmware)?

Could you please elaborate on your attachments (and next time, I would prefer text/plain attachments)?

Thank you
Comment 6 Matěj Cepl 2009-05-25 18:44:03 EDT
sorry, we crossed on posting comments, Peter explained better the process how to actually create correct attachment.
Comment 7 Lawrence Graves 2009-05-25 20:53:28 EDT
Created attachment 345373 [details]
Current xorg.conf file

Attaching xorg.conf file as plain text.
Comment 8 Lawrence Graves 2009-05-25 20:55:42 EDT
Created attachment 345374 [details]
Current Xorg.o.log file

Current Xorg.0.log file. Running with a different monitor than normal at the moment, but everything else is the same. Still have the same problems as well.
Comment 9 Peter Hutterer 2009-05-27 02:01:10 EDT
Please run xinput --list --short to get the list of devices. Your mouse device should be in there, named "Microsft Microsoft Wireless Desktop Receiver 3.1". Note that because you use a wireless combo, you'll see two of these devices, one should be an XExtensionPointer. This is your mouse device.

Then run xinput --get-button-map <id>, where <id> is the id of the mouse device. Do the same for the "Macintosh mousebutton emulation" device. Both should display "1 2 3 4 5 " etc.
Then tick the left-handed setting and run both commands again. Did the button mapping change for any device or stay the same for both?

I'm trying to narrow down whether the setting is generally not applied or not applied to the specific device you have.
Comment 10 Lawrence Graves 2009-05-29 11:53:48 EDT
I did as you ask on 05/27/2009 without any results.  I watched as I ticked the switch and there was no notable change in those numbers.  What else do you need from me.  I sit waiting.
Comment 11 Christopher A. Williams 2009-05-29 13:02:44 EDT
I propose running the same commands with an extra switch:

Please run xinput --list --short to get the list of devices. Your mouse device
should be in there, named "Microsft Microsoft Wireless Desktop Receiver 3.1".
Note that because you use a wireless combo, you'll see two of these devices,
one should be an XExtensionPointer. This is your mouse device.

Then run xinput --get-button-map <id> >>RightHand.txt, where <id> is the id of the mouse device. Do the same for the "Macintosh mousebutton emulation" device. Both should display "1 2 3 4 5 " etc.

The ">>RightHand.txt" part of the command will re-direct the output to a file called RightHand.txt. Since you run this command twice, the output of the 2nd command will just get appended to the RightHand.txt file.

Then tick the left-handed setting and run both commands again, but this time change the command to be xinput --get-button-map <id> >>LefttHand.txt.

Then add the RightHand.txt and LeftHand.txt files as attachments to this bug. That will allow everyone following this bug to see the output of the commands for themselves.
Comment 12 Lawrence Graves 2009-05-29 14:24:46 EDT
[legraves@localhost ~]$ su -
Password: 
[root@localhost ~]# xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Macintosh mouse button emulation"	id=2	[XExtensionPointer]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
"Logitech USB Receiver"	id=3	[XExtensionKeyboard]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
[root@localhost ~]# xinput --get-button-map RightHand.txt
unable to find device RightHand.txt
You have new mail in /var/spool/mail/root
[root@localhost ~]# xinput --get-button-map 2
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# xinput --get-button-map 2 RightHand.txt
usage: xinput get-button-map <device name>
[root@localhost ~]# xinput --get-button-map RightHand.txt 2
usage: xinput get-button-map <device name>
[root@localhost ~]# xinput --get-button-map 3
device has no buttons
[root@localhost ~]# xinput --get-button-map 


I am thoroughly confused  Help!!!!!
Comment 13 Lawrence Graves 2009-05-29 20:49:03 EDT
[legraves@localhost ~]$ su -
Password: 
[root@localhost ~]# xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Macintosh mouse button emulation"	id=2	[XExtensionPointer]
"Logitech USB Receiver"	id=3	[XExtensionKeyboard]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
[root@localhost ~]# xinput --get-button-map 2
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
You have new mail in /var/spool/mail/root
[root@localhost ~]# xinput --get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# xinput --get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# xinput --get-button-map 2
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# 

I've sent this again because I don't know if you received it before. It never posted to this site but it did post to the website. I hope I did this right.
Comment 14 Christopher A. Williams 2009-05-29 22:42:37 EDT
You got the information posted - just not in the way I said, but it's good enough. The command you ran was:

xinput --get-button-map 4

If you had followed the instructions of the extra switch, the command would be:

xinput --get-button-map 4 >>RightHand.txt

In any case, the info you posted should tell them what they were looking for.
Comment 15 Lawrence Graves 2009-05-29 23:49:07 EDT
[legraves@localhost /]$ su -
Password: 
[root@localhost ~]# xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Macintosh mouse button emulation"	id=2	[XExtensionPointer]
"Logitech USB Receiver"	id=3	[XExtensionKeyboard]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
[root@localhost ~]# xinput --get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
You have new mail in /var/spool/mail/root
[root@localhost ~]# xinput --get-button-map 2
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# 
[root@localhost ~]# xinput --get-button-map 2 >>RightHand.txt 
[root@localhost ~]# xinput --get-button-map 4 >>RightHand.txt 
[root@localhost ~]# xinput --get-button-map 4 >>LeftHand.txt 
[root@localhost ~]# xinput --get-button-map 2 >>LeftHand.txt 
[root@localhost ~]# ls
anaconda-ks.cfg  Desktop  LeftHand.txt  local.te  RightHand.txt  vmware-modules
[root@localhost ~]# pwd
/root/Desktop
/root/vmware-modules
/root/anaconda-ks.cfg
/root/LeftHand.txt
/root/local.te
/root/RightHand.txt
Comment 16 Peter Hutterer 2009-05-31 18:26:36 EDT
A few things:
1. you don't need to run xinput as root
2. if you redirect output into a file (that's what >> does), you need to attach the file afterwards so we can look at the output. Don't do this now though, the information we need is already there (the list of numbers after xinput --get-button-map is what I wanted)
3. why do you have a Logitech USB Receiver in the list now? the log file submitted earlier has a MS wireless receiver. Did you switch keyboards?
4. Please run "xmodmap -pp" and attach the output here
5. Please run xinput --get-button-map <deviceid> for _both_ Logitech devices in xinput --list. In the above output, you only ran it for device 4, not for 3. I don't know which one the mouse is.

From the output above it looks like the logitech thingy didn't get switched to right-handed (it still has a 1 2 3 mapping, not a 3 2 1). To be sure, I need the button mapping of the second logitech device though.
Comment 17 Lawrence Graves 2009-05-31 22:38:10 EDT
[legraves@localhost ~]$ xmodmap -pp
There are 32 pointer buttons defined.

    Physical        Button
     Button          Code
        1              1
        2              2
        3              3
        4              4
        5              5
        6              6
        7              7
        8              8
        9              9
       10             10
       11             11
       12             12
       13             13
       14             14
       15             15
       16             16
       17             17
       18             18
       19             19
       20             20
       21             21
       22             22
       23             23
       24             24
       25             25
       26             26
       27             27
       28             28
       29             29
       30             30
       31             31
       32             32

[legraves@localhost ~]$ xuboyt --get-button-map 4
bash: xuboyt: command not found
[legraves@localhost ~]$ input --get-button-map 4
bash: input: command not found
[legraves@localhost ~]$ su -
Password: 
[root@localhost ~]# xinput --get-button-map 4 
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# xinput --get-button-map 3
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# 

I had my computer over to a friends house trying to learn how to send the information requested in a way that would be of benefit to you. Hope this satisfies what you ask of me.
Comment 18 Peter Hutterer 2009-06-01 19:49:20 EDT
weird. so the 3 2 1 button mapping on device 3 indicates that it is indeed set to left-handed. Device 4 isn't though but I assumed that's the keyboard. The only explanation I can come up with why it's not working is that the events are posted through device 4.

To verify this, please run
xinput --set-button-man <deviceid> 3 2 1 4 5 6 7
In your case, this would most likely be:
xinput --set-button-map 4 3 2 1 4 5 6 7

Note that 4 is the device id and that may change after each X server restart. Make sure that the device id still corresponds to the logitech devices by checking with xinput --list --short.

After doing this, please check again that xinput --get-button-map <deviceid> shows the 3 2 1 mapping for both logitech devices.

Once you have done that, is the mouse set to left-handed?
Comment 19 Lawrence Graves 2009-06-02 01:33:06 EDT
[legraves@localhost ~]$ su -
Password: 
[root@localhost ~]# xinput --set-button-man 4
usage :
	xinput get-feedbacks <device name>
	xinput set-ptr-feedback <device name> <threshold> <num> <denom>
	xinput set-integer-feedback <device name> <feedback id> <value>
	xinput get-button-map <device name>
	xinput set-button-map <device name> <map button 1> [<map button 2> [...]]
	xinput set-pointer <device name> [<x index> <y index>]
	xinput set-mode <device name> ABSOLUTE|RELATIVE
	xinput list [--loop || --short || <device name>...]
	xinput query-state <device name>
	xinput test [-proximity] <device name>
	xinput version 
	xinput list-props <device> [<device> ...]
	xinput set-int-prop <device> <property> <format (8, 16, 32)> <val> [<val> ...]
	xinput set-float-prop <device> <property> <val> [<val> ...]
	xinput set-atom-prop <device> <property> <val> [<val> ...]
	xinput watch-props <device>
	xinput delete-prop <device> <property>
You have new mail in /var/spool/mail/root
[root@localhost ~]# xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Macintosh mouse button emulation"	id=2	[XExtensionPointer]
"Logitech USB Receiver"	id=3	[XExtensionKeyboard]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
[root@localhost ~]# xinput --get-button-map 3
device has no buttons
[root@localhost ~]# xinput --get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# 

No.
Comment 20 Lawrence Graves 2009-06-02 08:50:06 EDT
[legraves@localhost ~]$ su -
Password: 
[root@localhost ~]# xinput --set-button-map 4
usage: xinput set-button-map <device name> <map button 1> [<map button 2> [...]]
[root@localhost ~]# xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Macintosh mouse button emulation"	id=2	[XExtensionPointer]
"Logitech USB Receiver"	id=3	[XExtensionKeyboard]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
You have new mail in /var/spool/mail/root
[root@localhost ~]# xinput --get-button-map 4
device has no buttons
[root@localhost ~]# xinput --get-button-map 3
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# xinput --get-button-map 2
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[root@localhost ~]# 



I took the liberty of running <deviceid> 2 and from what I can tell [XExtensionPointer] is my mouse.  Look back at 17 in the comment list and you'll see there is a change in id 4. I think id4 is the keyboard and it is switching back and forth.  One time it has buttons and the next time it doesn't.
What's up with that?  Just trying to understand and learn.
Comment 21 Jean-Eudes ONFRAY 2009-06-02 09:41:43 EDT
Well, if you read it carefully, you'll notice Peter did a typo: in #18, instead of
 xinput --set-button-man <deviceid> 3 2 1 4 5 6 7
you should've read:
 xinput --set-button-map <deviceid> 3 2 1 4 5 6 7
That goes for you as:
 [legraves@localhost ~]$ xinput --set-button-map 4 3 2 1 4 5 6 7
(there's no need to be root to use xinput)

After doing this, please check again that
 [legraves@localhost ~]$ xinput --get-button-map 4
shows the 3 2 1 mapping for both logitech devices.
Comment 22 Lawrence Graves 2009-06-02 10:19:26 EDT
[legraves@localhost ~]$ xinput --set-button-map 4
usage: xinput set-button-map <device name> <map button 1> [<map button 2> [...]]
[legraves@localhost ~]$ xinput --get-button-map 4
device has no buttons
[legraves@localhost ~]$ 

As you ordered.
Comment 23 Jean-Eudes ONFRAY 2009-06-02 13:09:49 EDT
You're missing all the digits after <device name> ("4" here in your case)
 xinput --set-button-map 4 3 2 1 4 5 6 7
                           ^^^^^^^^^^^^^
Do you understand ? Try again please.
Comment 24 Lawrence Graves 2009-06-02 14:06:29 EDT
[legraves@localhost ~]$ xinput --set-button-map 4 3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
[legraves@localhost ~]$ xinput --get-button-map 4
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 18 19 20 21 22 23 24 25 26 27 28 29 30 31 
[legraves@localhost ~]$ 

You were right, I didn't understand.  I got the message now.  It is fixed!!!!!!!
Thank you, Thank you, Thank you.
Comment 25 Lawrence Graves 2009-06-02 14:40:18 EDT
I got too exited because it worked for about five minutes, now it's back the way it was.  I went back in the terminal and redone what you told me to do and not it has no effect on changing at all.  Looks like I put the cart before the horse in my excitement of seeing work after such a long time of not having it to work properly.  Back to the drawing board.  Sorry for the misleading.
Comment 26 Peter Hutterer 2009-06-02 19:19:04 EDT
the device ID is not guaranteed to stay the same, so device 4 might be your keyboard one time, your mouse the next time. Thats why you should always run xinput --list --short after a reboot, suspend or even VT switch to verify which device you're working on.


(In reply to comment #20)
> I took the liberty of running <deviceid> 2 and from what I can tell
> [XExtensionPointer] is my mouse.  

no. in the output you posted device 2 is the in-kernel emulation of the right mouse button (designed for apple laptops with a single button only). it is not your physical mouse. your mouse is one of the Logitech USB Receiver devices, your keyboard is the other one.

different approach:
run xinput --test <deviceid> for each device until you find the one that is your mouse (run it, move your mouse, if you see lots of output then you've found the right deviceid). then use --get-button-map to query the current button mapping and remember it. --set-button-map as above to apply the 3 2 1 mapping. Does this change your device to left-handed?

attach your Xorg.log (the one we have is still the one with the different mouse/keyboard combo) and attach the full output of "xinput --list" as a file. Don't forget to state which device id your mouse is, it's impossible to tell for me since both keyboard and mouse have the same name.
Comment 27 Lawrence Graves 2009-06-02 19:55:13 EDT
X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.6.el5 x86_64 
Current Operating System: Linux localhost.localdomain 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64
Kernel command line: ro root=/dev/mapper/vg_jesuschrist-lv_root rhgb quiet
Build Date: 18 May 2009  02:47:15PM
Build ID: xorg-x11-server 1.6.1.901-1.fc11 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun  2 15:23:42 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section.  Using the first Screen section.
(==) No screen section available. Using defaults.
(**) |-->Screen "Default Screen Section" (0)
(**) |   |-->Monitor "<default monitor>"
(==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
(**) |   |-->Device "Videocard0"
(==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
(**) Option "AIGLX" "on"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
(**) ModulePath set to "/usr/lib64/xorg/modules/extensions/nvidia,/usr/lib64/xorg/modules"
(**) Extension "Composite" is enabled
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
	If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x7b40
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 5.0
	X.Org XInput driver : 4.0
	X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 1

(--) PCI:*(0@1:0:0) nVidia Corporation GeForce 9500 GT rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/524288
(II) No APM support in BIOS or kernel
(II) System resource ranges:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/nvidia//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Server Extension
(II) NVIDIA GLX Module  180.51  Fri Apr 17 00:35:49 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib64/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  180.51  Fri Apr 17 00:15:00 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib64/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 9500 GT (G96) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 1048576 kBytes
(--) NVIDIA(0): VideoBIOS: 62.94.29.00.50
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 9500 GT at PCI:1:0:0:
(--) NVIDIA(0):     Acer AL2216W (CRT-0)
(--) NVIDIA(0): Acer AL2216W (CRT-0): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(==) NVIDIA(0): 
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0):     will be used as the requested mode.
(==) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
(--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) NVIDIA(0):     configuration option may not be set correctly.  When the
(II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0):     Config Options in the README.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device Macintosh mouse button emulation
(II) LoadModule: "evdev"
(II) Loading /usr/lib64/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 2.2.1
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 4.0
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event2"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event4"
(II) Logitech USB Receiver: Found 9 mouse buttons
(II) Logitech USB Receiver: Found x and y relative axes
(II) Logitech USB Receiver: Found scroll wheel(s)
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as mouse
(II) Logitech USB Receiver: Configuring as keyboard
(**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) filter chain progression: 2.00
(**) Logitech USB Receiver: (accel) filter stage 0: 20.00 ms
(**) Logitech USB Receiver: (accel) set acceleration profile 0
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event3"
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as keyboard
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105+inet"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Power Button (CM)
(**) Power Button (CM): always reports core events
(**) Power Button (CM): Device: "/dev/input/event1"
(II) Power Button (CM): Found keys
(II) Power Button (CM): Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button (CM)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Power Button (FF)
(**) Power Button (FF): always reports core events
(**) Power Button (FF): Device: "/dev/input/event0"
(II) Power Button (FF): Found keys
(II) Power Button (FF): Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button (FF)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: removing device Logitech USB Receiver
(II) Logitech USB Receiver: Close
(II) UnloadModule: "evdev"
(II) config/hal: removing device Logitech USB Receiver
(II) Logitech USB Receiver: Close
(II) UnloadModule: "evdev"
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event3"
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as keyboard
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105+inet"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event4"
(II) Logitech USB Receiver: Found 9 mouse buttons
(II) Logitech USB Receiver: Found x and y relative axes
(II) Logitech USB Receiver: Found scroll wheel(s)
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as mouse
(II) Logitech USB Receiver: Configuring as keyboard
(**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) filter chain progression: 2.00
(**) Logitech USB Receiver: (accel) filter stage 0: 20.00 ms
(**) Logitech USB Receiver: (accel) set acceleration profile 0
(II) config/hal: removing device Logitech USB Receiver
(II) Logitech USB Receiver: Close
(II) UnloadModule: "evdev"
(II) config/hal: removing device Logitech USB Receiver
(II) Logitech USB Receiver: Close
(II) UnloadModule: "evdev"
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event3"
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as keyboard
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105+inet"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event4"
(II) Logitech USB Receiver: Found 9 mouse buttons
(II) Logitech USB Receiver: Found x and y relative axes
(II) Logitech USB Receiver: Found scroll wheel(s)
(II) Logitech USB Receiver: Found keys
(II) Logitech USB Receiver: Configuring as mouse
(II) Logitech USB Receiver: Configuring as keyboard
(**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
(**) Logitech USB Receiver: (accel) filter chain progression: 2.00
(**) Logitech USB Receiver: (accel) filter stage 0: 20.00 ms
(**) Logitech USB Receiver: (accel) set acceleration profile 0[legraves@localhost ~]$ xinput --get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[legraves@localhost ~]$ xinput --get-button-map 3
device has no buttons
[legraves@localhost ~]$ xinput --set-button-map 3 3 2 1 4 5 6 7 8 9 10 
device has no buttons
[legraves@localhost ~]$ xinput --get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[legraves@localhost ~]$ xinput --set-button-map 4 3 2 1 4 5 6 7 8
[legraves@localhost ~]$ xinput --list
"Virtual core pointer"	id=0	[XPointer]
	Num_buttons is 32
	Num_axes is 2
	Mode is Relative
	Motion_buffer is 256
	Axis 0 :
		Min_value is -1
		Max_value is -1
		Resolution is 0
	Axis 1 :
		Min_value is -1
		Max_value is -1
		Resolution is 0
"Virtual core keyboard"	id=1	[XKeyboard]
	Num_keys is 248
	Min_keycode is 8
	Max_keycode is 255
"Macintosh mouse button emulation"	id=2	[XExtensionPointer]
	Num_buttons is 32
	Num_axes is 2
	Mode is Relative
	Motion_buffer is 256
	Axis 0 :
		Min_value is -1
		Max_value is -1
		Resolution is 1
	Axis 1 :
		Min_value is -1
		Max_value is -1
		Resolution is 1
"Power Button (CM)"	id=5	[XExtensionKeyboard]
	Num_keys is 248
	Min_keycode is 8
	Max_keycode is 255
"Power Button (FF)"	id=6	[XExtensionKeyboard]
	Num_keys is 248
	Min_keycode is 8
	Max_keycode is 255
"Logitech USB Receiver"	id=3	[XExtensionKeyboard]
	Num_keys is 248
	Min_keycode is 8
	Max_keycode is 255
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
	Num_keys is 248
	Min_keycode is 8
	Max_keycode is 255
	Num_buttons is 32
	Num_axes is 2
	Mode is Relative
	Motion_buffer is 256
	Axis 0 :
		Min_value is -1
		Max_value is -1
		Resolution is 1
	Axis 1 :
		Min_value is -1
		Max_value is -1
		Resolution is 1
[legraves@localhost ~]$ 

It changed my device to left-handed and id4 is my mouse
Comment 28 Lawrence Graves 2009-06-02 21:40:14 EDT
[legraves@localhost ~]$ xinput --set-button-map 4 3 2 1 4 5 6 7 8 
[legraves@localhost ~]$ xinput --set-button-map 3 1 2 3 4 5 6 7 8
[legraves@localhost ~]$ xinput --get-button-map 4
3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[legraves@localhost ~]$ xinput --get-button-map 3
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 10 
[legraves@localhost ~]$ xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Logitech USB Receiver"	id=2	[XExtensionKeyboard]
"Macintosh mouse button emulation"	id=3	[XExtensionPointer]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
[legraves@localhost ~]$ 

I sent this so you could see the change in the id numbers of the devices. I notice that while there is a change in my mouse and I am able to set to left-handed use now, it never changes on the desktop operations. I can go to system/preferences/mouse and change it from left to right or visa-versa and it will not affect my mouse one way or the other.  Also in my virtualbox everything is the opposite.  I cannot physically change my mouse at all. Strange.  But I have hope.
Comment 29 Lawrence Graves 2009-06-08 19:15:11 EDT
Just wanted to know how things are working out on my issue.
Comment 30 Bug Zapper 2009-06-09 12:18:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 Lawrence Graves 2009-06-12 07:52:44 EDT
I have reinstalled the final release and the problem still remains.  I have to go to the terminal and physically change my mouse from the right-handed position to the left-handed position.  In other words, nothing has changed.
Comment 32 Lawrence Graves 2009-07-22 13:52:01 EDT
Has this bug been moved to Fedora 12 project?  Should I expect the fix in Fedora 12? I know you are busy, thanks for any information you may have time to send.
Comment 33 Lawrence Graves 2009-08-07 10:18:35 EDT
I am now experiencing the problem of not only not being able to switch from the right hand to left hand use of my mouse but now when I change it manually, I can't use the scroller.  It will scroll down but will not scroll up. I don't mind changing the use of my mouse from right hand to left hand manually but it is frustrating that the scrolling capabilities will not work now.  This has been an on going problem with this Logitech combo.  They are sending me a new one and I will see if it is the OS causing the problem or the Logitech product.  We will be patient until something is done.
Comment 34 Peter Hutterer 2009-08-17 01:54:51 EDT
first of all, this seems to work fine with F11, I tried to reproduce this problem with no effect. so it's most likely some local configuration interfering.

second, why is this bug filed against vmmouse? do you run your server inside vmware? the logs don't indicate this.

after logging in, run xmodmap -pp. The output in both columns should be 1 2 3 4 ... etc.

then run "xinput --get-button-map 4", the output should be 1 2 3 4 etc.
run this command for all devices, from 2 to the highest deviceid. the output should be the same for all (except keyboards where it may fail, don't worry about those devices).

Then go to system->preferences->mouse and tick the left-handed option. after doing this, run all the commands again.

xmodmap output should be the same, ordering 1 2 3 4 etc.
the xinput --get-button-map output should now read 3 2 1 4 5 ...
for all devices (except keyboards).

if it doesn't, open gconf-editor and go to /desktop/gnome/peripherals/mouse. Is the left_handed checkbox ticked?
Comment 35 Matěj Cepl 2009-08-17 11:07:35 EDT
*** Bug 517782 has been marked as a duplicate of this bug. ***
Comment 36 Lawrence Graves 2009-08-17 11:56:16 EDT
I done all that I was told to do and yet system/preferences/mouse will not affect changing of left-handed to right-handed use of mouse.  There is something wrong the mapping for button 4.  It will not change.  I have to change it manually from 1 2 3 to 3 2 1.  I don't know what to do.  I received a new keyboard and mouse based on the illusion that something was wrong with my mouse and since have discovered that was not the case.  I don't know what information I need to send you in order for you to investigate this matter further.  Please advise.  I remain at your mercy.
Comment 37 Peter Hutterer 2009-08-18 02:07:18 EDT
Please try with a test user, I'm running out of ideas what could be wrong there.

Please answer all questions in my previous comment too.
Comment 38 Lawrence Graves 2009-08-18 19:44:23 EDT
created a fresh test user and tried what you asked. At first mapping was right-handed as expected.  Using system/preference/mouse didn't work.  Gconf editor showed that the left-handed mouse option was checked.

Output of xinput get button map before and after attempted changes is below:

[root@JesusChrist ~]# xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Logitech USB Receiver"	id=2	[XExtensionKeyboard]
"Macintosh mouse button emulation"	id=3	[XExtensionPointer]
"Logitech USB Receiver"	id=4	[XExtensionKeyboard]
"Power Button (CM)"	id=5	[XExtensionKeyboard]
"Power Button (FF)"	id=6	[XExtensionKeyboard]
[root@JesusChrist ~]# xinput get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 
You have new mail in /var/spool/mail/root
[root@JesusChrist ~]# xinput get-button-map 4
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 
[root@JesusChrist ~]# 

Looks like whatever is causing this goes beyond gconf editor. Both it and the mouse configuration tool show correct but xinput never gets the memo.

I didn't file against vmmouse, at least not intentionally. Don't know how it got there.
Of note, I have reinstalled F11 on this system several times for various reasons that have nothing to do with this problem and have been able to reproduce this issue every time.
Comment 39 Garrett Mitchener 2009-08-25 09:19:29 EDT
I'm seeing this bug as well and I would really like to have it fixed.

I'm using fedora 11 on a x86_64 system.

I think there's some confusion between the Macintosh mouse button emulation thingee and the Logitech USB receiver.  I'm using a Logitech wireless USB Wave keyboard-mouse combo that has a single dongle that connects to both physical devices.  Here's what I'm seeing:

Start with the mouse set up to be right handed.  Then:

[garrett@grograman]$ xinput --list --short
"Virtual core pointer"	id=0	[XPointer]
"Virtual core keyboard"	id=1	[XKeyboard]
"Wacom Stylus"	id=2	[XExtensionKeyboard]
"Wacom Eraser"	id=3	[XExtensionKeyboard]
"Wacom Cursor"	id=4	[XExtensionKeyboard]
"Macintosh mouse button emulation"	id=5	[XExtensionPointer]
"Power Button (CM)"	id=6	[XExtensionKeyboard]
"Power Button (FF)"	id=7	[XExtensionKeyboard]
"Logitech USB Receiver"	id=8	[XExtensionKeyboard]
"Logitech USB Receiver"	id=9	[XExtensionKeyboard]

[garrett@grograman]$ xinput --get-button-map 5
1 2 3 4 5 

[garrett@grograman]$ xinput --get-button-map 8
device has no buttons

[garrett@grograman]$ xinput --get-button-map 9
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

Now using the gnome control center, set the mouse to be left-handed.  The buttons don't actually switch their behavior.  But this is interesting:

[garrett@grograman]$ xinput --get-button-map 5
3 2 1 4 5

[garrett@grograman]$ xinput --get-button-map 8
device has no buttons

[garrett@grograman]$ xinput --get-button-map 9
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

So the control panel seems to be changing the Macintosh mouse button emulation thingee, but not the Logitech device.  Now when I change the other device at the command line:

[garrett@grograman]$ xinput --set-button-map 9  3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16

I now get a left-handed mouse.

So the problem is probably in how these keyboard-mouse combo devices are interpreted.  Maybe it's a bug in X or HAL or dbus or in how the gnome control center selects which input device number it should affect?

I noticed this in the Xorg log:

(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type:
KEYBOARD)

It appears twice, once for the wireless mouse and once for the wireless keyboard, and there's no line "Adding extended input device Logitech USB receiver (type: MOUSE)".  So it's possible that the control center queries the devices but can't see that the mouse is a mouse and so doesn't change it.  Or perhaps xinput is making that mistake.  Just throwing out some ideas here...

I also noticed a previous comment #27 listed a 64 bit kernel, so there might be a 32 bit <-> 64 bit issue, but I'd check out the device type label first.
Comment 40 Peter Hutterer 2009-08-25 20:25:15 EDT
thanks, that was it. gnome-settings-daemon has a check that skips this type of device. 

Please test this scratch build and let me know how you go.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1633844
Comment 41 Lawrence Graves 2009-08-25 21:38:14 EDT
Installed the scratch build and it works.  Thank you very much.
Comment 42 Fedora Update System 2009-08-26 00:19:46 EDT
gnome-settings-daemon-2.26.1-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.26.1-9.fc11
Comment 43 Robin Lee 2009-08-26 06:25:51 EDT
*** Bug 517862 has been marked as a duplicate of this bug. ***
Comment 44 Fedora Update System 2009-08-26 22:12:19 EDT
gnome-settings-daemon-2.26.1-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9025
Comment 45 tmgtsk 2009-10-06 17:48:51 EDT
Just installed the FC 11 with gnome-settings-daemon-2.26.1-11.fc11 (x86_64).  This bug has apparently reappeared.  I cannot set the mouse buttons for the left hand in the preferences. 

Can someone check to see if the fix got lost?
Comment 46 tmgtsk 2009-10-07 13:11:24 EDT
Never mind. For some reason a re-install cleared the problem.

Sorry to take up anyone's time.
Comment 47 Garrett Mitchener 2009-12-10 09:48:21 EST
I've upgraded to F12 and I haven't seen any sign of this bug with my same keyboard and mouse.
Comment 48 Göran Uddeborg 2010-04-07 12:29:15 EDT
Fixed since some time back.

Note You need to log in before you can comment on or make changes to this bug.