Bug 502138 - Software update displays shutdown dialog even after it says a logout is needed efter applying updates
Software update displays shutdown dialog even after it says a logout is neede...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 558072 563310 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 02:54 EDT by Kari Hautio
Modified: 2010-03-23 06:32 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 06:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kari Hautio 2009-05-22 02:54:25 EDT
Description of problem: When software upgrade prompts to logout/login after completing updates it sends user to shutdown dialog.


Version-Release number of selected component (if applicable):

gnome-packagekit-2.27.2-0.2.20090414git.fc11.i586

How reproducible:

Happened few times after applying updates by panel -> Update System Now. Did not try reproducing otherwise.

Steps to Reproduce:
1.
2.
3.
  
Actual results: After prompting that logout is needed after upgrades user is given the logout dialog.

Expected results: Logout dialog should be displayed.

Additional info:
Comment 1 Kari Hautio 2009-05-22 05:07:48 EDT
Further note:

Clicking the triangle in panel gives the logout dialog. (after canceling the shutdown).
Comment 2 Kari Hautio 2009-05-22 05:12:56 EDT
Just noticed a typo in "Actual Results" which is kind of obvioes based on desc.

Actual results: After prompting that logout is needed after upgrades user is
given the SHUTDOWN dialog.
Comment 3 Richard Hughes 2009-05-26 05:41:28 EDT
(In reply to comment #0)
> Description of problem: When software upgrade prompts to logout/login after
> completing updates it sends user to shutdown dialog.

Do you mean the "Suspend Hibernate Restart Cancel Shutdown" dialog?
Comment 4 Kari Hautio 2009-05-26 05:46:59 EDT
Yes
Comment 5 Richard Hughes 2009-06-03 05:35:30 EDT
Right, we just ask gnome-session to logout -- Jon, should we be doing this a different way?
Comment 6 Bug Zapper 2009-06-09 12:19:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Michael Cronenworth 2009-08-04 11:22:33 EDT
This bug is still around. Just got it this past week when nfs-utils was updated. After updates completed I was prompted by PackageKit to "Close" or "Logout" and clicking on "Logout" gave me a "Suspend Hibernate Restart Cancel Shutdown" dialog. A logout notification icon is displayed, too, and clicking on it to "Logout" also presents the "Suspend Hibernate Restart Cancel Shutdown" dialog.
Comment 8 Adam Goode 2010-02-15 13:08:59 EST
*** Bug 558072 has been marked as a duplicate of this bug. ***
Comment 9 Adam Goode 2010-02-15 13:10:38 EST
*** Bug 563310 has been marked as a duplicate of this bug. ***
Comment 10 Michael Cronenworth 2010-02-15 13:11:24 EST
(In reply to comment #5)
> Right, we just ask gnome-session to logout -- Jon, should we be doing this a
> different way?    

Richard, Jon, any update? I'm still setting this as of today's updates. I was told to logout by PackageKit and upon pressing "Log out" it presented me with a "Suspend Hibernate Restart Cancel Shutdown" dialog.
Comment 11 Richard Hughes 2010-03-23 06:32:48 EDT
I'm pretty sure we've now fixed this in F13. Please re-open if you can still reproduce with a fully updated system. Thanks.

Note You need to log in before you can comment on or make changes to this bug.