Bug 502171 - Errors at startup
Errors at startup
Status: CLOSED DUPLICATE of bug 502175
Product: Fedora
Classification: Fedora
Component: condor (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Farrellee
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 06:22 EDT by Adam Huffman
Modified: 2009-05-22 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 11:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2009-05-22 06:22:56 EDT
Description of problem:

When starting condor I see these errors in MasterLog:

5/22 10:35:20 DaemonCore: ERROR: Can't open pid file /var/run/condor/condor_master.pid
5/22 10:35:20 FileLock::obtain(1) failed - errno 11 (Resource temporarily unavailable)
5/22 10:35:20 ERROR "Can't get lock on "/var/lib/condor/log/InstanceLock"" at line 933 in file master.cpp

They don't seem to be fatal.

Version-Release number of selected component (if applicable):
condor-7.2.3-1.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Farrellee 2009-05-22 09:19:11 EDT
Those should be fatal. I'm guessing you ran the condor_master as a non-root user.

You should check to see if the files exist and who owns them.
Comment 2 Adam Huffman 2009-05-22 10:35:14 EDT
-rw------- 1 condor condor      0 2009-05-22 10:35 InstanceLock

so, it does exist.

As for /var/run/condor/condor_master.pid, there isn't even a /var/run/condor directory.
Comment 3 Matthew Farrellee 2009-05-22 11:21:00 EDT

*** This bug has been marked as a duplicate of bug 502175 ***

Note You need to log in before you can comment on or make changes to this bug.