Bug 502175 - Initscripts not showing status or stopping correctly
Initscripts not showing status or stopping correctly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: condor (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Farrellee
Fedora Extras Quality Assurance
:
: 502171 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 06:59 EDT by Adam Huffman
Modified: 2009-05-25 17:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.2.3-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 17:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2009-05-22 06:59:41 EDT
Description of problem:

When I run 'service condor status' I see the following output:

condor_master is stopped

even when condor is running.

When I run 'service condor stop' the condor daemons don't stop.

Version-Release number of selected component (if applicable):
condor-7.2.3-1.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Farrellee 2009-05-22 09:20:26 EDT
The init script only stops daemons that it started, the master's pidfile is used to enforce this.
Comment 2 Adam Huffman 2009-05-22 10:36:50 EDT
That doesn't seem to work though.  I've just stopped condor with pkill, started it again via the initscript, then tried to stop via the initscript.  It didn't have any effect.
Comment 3 Matthew Farrellee 2009-05-22 11:21:00 EDT
*** Bug 502171 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Farrellee 2009-05-22 11:23:44 EDT
You'll have to delete the InstanceLock because the condor_master didn't get a chance to clean it up on exit.

The issue here is the init script changed to use /var/{log,lock,run}/condor, but the package wasn't updated.
Comment 5 Fedora Update System 2009-05-22 12:13:24 EDT
condor-7.2.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/condor-7.2.3-2.fc10
Comment 6 Fedora Update System 2009-05-25 17:25:20 EDT
condor-7.2.3-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.