Bug 502204 - virt-manager's dialog to connect an existing CD-ROM to an ISO does not use storage pool interface
virt-manager's dialog to connect an existing CD-ROM to an ISO does not use st...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-22 10:52 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-manager-0.8.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 09:14:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (313.47 KB, image/png)
2009-05-22 10:52 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-22 10:52:32 EDT
Created attachment 345099 [details]
Screenshot

Description of problem:

 * Open up the details [tab] for a guest.  Select the "Disk hdc" or whichever corresponds to a virtual IDE CDROM.  Disconnect any existing ISO's the CDROM.  Connect that device to another ISO.  Observe the the dialog used is different from the dialogs when you create the IDE CDROM device.  Should they be the same?

Version-Release number of selected component (if applicable):

 * virt-manager-0.7.0-4.fc11.x86_64
 * libvirt-0.6.2-8.fc11.x86_64


How reproducible:


Steps to Reproduce:
1. Open virt-manager
2. Select a guest, select details [tab]
3. Select the "Disk hdc" or whichever corresponds to a virtual IDE CDROM.
4. Click "Disconnect" to existing break and connection with ISO images
5. Click "Connect" to make a new connection to an ISO image
6. Under "ISO Image location", select Browse
  
Actual results:

 * Just a normal GNOME file browser (See attached screenshot)

Expected results:

 * The storage pool browser interface used when I created the virtual CDROM device.

Additional info:
Comment 1 Mark McLoughlin 2009-05-25 11:52:35 EDT
Makes sense to me, at least
Comment 2 Bug Zapper 2009-06-09 12:20:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Cole Robinson 2009-06-18 11:08:12 EDT
Fixed upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/c18281683490

Moving to POST.
Comment 4 Mark McLoughlin 2009-06-22 11:16:19 EDT
*** Bug 505429 has been marked as a duplicate of this bug. ***
Comment 5 Mark McLoughlin 2009-08-07 09:14:14 EDT
This isn't going to cause people any great problems, so I think it's fine to close this as resolved in F-12 rather than attempt to backport the fix

Note You need to log in before you can comment on or make changes to this bug.