Bug 505429 - virt-manager can not read /var/lib/libvirt/boot/
virt-manager can not read /var/lib/libvirt/boot/
Status: CLOSED DUPLICATE of bug 504326
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:46 EDT by Allen
Modified: 2009-06-22 11:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 11:16:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen 2009-06-11 16:46:55 EDT
Description of problem:
After creating a logical volume to store all of the libvirt directory and mounting it on /var/lib/libvirt, I tried to to create a new vm using one of the ISO's stored in libvirt/boot. Using virt-manager's create-new-vm dialog I tried to select an ISO file as the install source. The file selection window showed the spining busy pointer and absolutely nothing in /var/lib/libvirt/boot. Neither can the full pathname of the ISO be specified.  

Version-Release number of selected component (if applicable):

python-virtinst-0.400.3-8.fc11.noarch
virt-manager-0.7.0-5.fc11.x86_64
libvirt-python-0.6.2-11.fc11.x86_64
virt-top-1.0.3-4.fc11.x86_64
libvirt-0.6.2-11.fc11.x86_64


How reproducible:
Always.

Steps to Reproduce:
1. from virt-manager select 'New'
2. follow dialogs to create a vm, select install media to be ISO image in libvirt/boot, click 'Browse'
3. the file selection dialog appears point to /var/lib/libvirt/boot
  
Actual results:
file selector displays nothing but busy pointer

Expected results:
display contents of directory

Additional info:
WORKAROUND: chmod o+rx boot/

I did run restorecond on the entire contents.

But it comes likes this out of the box. This is a fresh install of F11. I am able to access libvirt/images where disk images are kept which has the smae permissions.
Comment 1 Daniel Berrange 2009-06-12 06:04:38 EDT
The problem here really is that Virt-manager should not be using a file browser dialog here. It cannot expect to be able to read any directory on the managed system, not least because it could be running remotely. It really needs to use the storage pool volume browser for picking ISOs instead, such that libvirtd is the one who reads the real directories. Doing a chmod is not a satisfactory solution for the long term
Comment 2 Mark McLoughlin 2009-06-22 11:16:19 EDT
Pretty sure this is a dup of bug #502204, please re-open if not

*** This bug has been marked as a duplicate of bug 502204 ***
Comment 3 Mark McLoughlin 2009-06-22 11:17:39 EDT
Gah, wrong one

*** This bug has been marked as a duplicate of bug 504326 ***

Note You need to log in before you can comment on or make changes to this bug.