Bug 502421 - sane-backends-1.0.20 has been released
sane-backends-1.0.20 has been released
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 502933 (view as bug list)
Depends On:
Blocks: 508841
  Show dependency treegraph
 
Reported: 2009-05-25 02:17 EDT by Jakub Jelinek
Modified: 2009-07-22 17:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.20-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 508841 (view as bug list)
Environment:
Last Closed: 2009-07-22 17:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelinek 2009-05-25 02:17:11 EDT
Any plans to upgrade sane-backends in rawhide (and in F11 updates testing if the former works well?)?  I'm particularly looking for Canon iSENSYS MF-4150 scanner driver, which is supposed to be supported in 1.0.20, but guess owners of the other 70+ scanner models now supported would appreciate it as well.
Thanks.

New with 1.0.20, released 2009-05-03:

* New backends: canon_dr (Canon DR-series), coolscan3 (Nikon LS & Coolscan),
  rts8891 (Umax & HP 44xx), xerox_mfp (Samsung/Xerox/Dell MFPs) 
* Many backends updated.
* 75 more scanner models supported.
* New build system (thanks Chris and Olaf).
* Avahi support (thanks Julien).
* More network scanners supported
* Epson backend deprecated, use epson2
* Coolscan2 backend deprecated, use coolscan3
* Internal SCSI, USB, threading, TCP & UDP code updates.
* Updated HAL and udev support.
* Improved saned configuration.
* Scanimage updates.
* Updated translations.
* Documentation updates.
* Bugfixes.
Comment 1 Nils Philippsen 2009-05-25 09:48:00 EDT
(In reply to comment #0)
> Any plans to upgrade sane-backends in rawhide (and in F11 updates testing if
> the former works well?)?

Sure. We have some patches over upstream needed for distro integration (as usual, Fedora was a bit ahead of upstream sane-backends w.r.t. udev, hal, PolicyKit and the other usual suspects), I'll have to review these and either drop or update them.
Comment 2 Nils Philippsen 2009-05-28 10:01:57 EDT
*** Bug 502933 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2009-06-09 12:30:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Juha Tuomala 2009-06-11 11:41:47 EDT
Is there a list of scanner owners with models? I think with all these problems that would be useful. Also a mailing list that 'now you could try again if your scanner still sucks'. I've HP 7400something.
Comment 5 Fedora Update System 2009-06-17 05:54:25 EDT
sane-backends-1.0.20-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/sane-backends-1.0.20-2.fc11
Comment 6 Fedora Update System 2009-06-19 09:36:29 EDT
sane-backends-1.0.20-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sane-backends'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6710
Comment 7 Fedora Update System 2009-06-26 22:46:25 EDT
sane-backends-1.0.20-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sane-backends'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6710
Comment 8 Fedora Update System 2009-07-22 17:46:38 EDT
sane-backends-1.0.20-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.