This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 502430 - httping-1.3.0 doesn't build on Rawhide
httping-1.3.0 doesn't build on Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: httping (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
: 511730 (view as bug list)
Depends On:
Blocks: FTBFS ZedoraTracker F12FTBFS
  Show dependency treegraph
 
Reported: 2009-05-25 04:21 EDT by Dan Horák
Modified: 2009-08-31 05:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 05:46:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2009-05-25 04:21:27 EDT
httping-1.2.9-4 doesn't build on Rawhide because of "conflicting types for 'strndup'", see
https://koji.fedoraproject.org/koji/taskinfo?taskID=1375387
for full log

In my opinion the current strndup patch should be split into 2 parts - first with general improvements to makefile and the second one with the "strndup cleanup". If you don't object I can make the changes.
Comment 1 Fabian Affolter 2009-06-08 05:54:01 EDT
I would like if you make this changes because at the moment I'm a bit short on time.
Comment 2 Bug Zapper 2009-06-09 12:31:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fabian Affolter 2009-07-16 09:46:15 EDT
*** Bug 511730 has been marked as a duplicate of this bug. ***
Comment 4 Fabian Affolter 2009-07-17 10:46:16 EDT
I sent a message to upstream some minutes ago about this issue.
Comment 5 Alex Lancaster 2009-08-31 04:26:50 EDT
Still doesn't build on rawhide:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1644964

and now causing broken deps in rawhide because of the soname bump in openssl:

	httping-1.2.9-4.fc11.i586 requires libcrypto.so.8
	httping-1.2.9-4.fc11.i586 requires libssl.so.8

http://koji.fedoraproject.org/mash/rawhide-20090830/logs/depcheck

is it possible you could look into this ASAP?  Thanks.

Note You need to log in before you can comment on or make changes to this bug.