This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 502493 - Video playback leaves display blank, restarting X doesn't restore
Video playback leaves display blank, restarting X doesn't restore
Status: CLOSED DUPLICATE of bug 499895
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 10:01 EDT by Andy Burns
Modified: 2009-05-30 04:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-30 04:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file from before the problem (67.68 KB, text/plain)
2009-05-25 10:06 EDT, Andy Burns
no flags Details
Xorg logfile attempting to restart X after the problem (13.29 KB, text/plain)
2009-05-25 10:07 EDT, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2009-05-25 10:01:32 EDT
Running F11 latest rawhide, on machine with intel G35 graphics onboard, KMS with plymouth works.

Obviously I realise mythtv from ATRPMS isn't part of F11, but it seems to be tickling a bug in X or KMS.

Up to and including kernel-PAE 2.6.29.2-126.fc11 mythtv worked fine, but since 2.6.29.3-140.fc11 and 2.6.29.3-155.fc11 there is a problem, when I start full screen TV playback the display goes black, but the machine is not hung.

Xorg process still exists, no errors to var/log/xorg.0.log or /var/log/messages or dmesg, can't kill it with CTRL-ALT-BKSP (I've re-enabled Zapping), can't switch to a different VT, can't connect using vino, even init 3 followed by kill Xorg followed by init 5 from an SSH session won't bring back the display, though it does try.

If I boot back to kernel 2.6.29.2-126.fc11 it all works again.

xorg-x11-drv-intel.i586 is 2.7.0-6.fc11

intel_gpu_top shows

ring idle:   0%  ring space: 96/126976 (0%)
                          task  percent busy
            Projection and LOD: 100%
                   Bypass FIFO: 100%
              Color calculator: 100%
             Command Processor: 100%

I don't know if the output from intel_gpu_dump would help?

intel_stepping shows

Vendor: 0x8086, Device: 0x2982, Revision: 0x03 (E0)
Comment 1 Andy Burns 2009-05-25 10:06:02 EDT
Created attachment 345315 [details]
Xorg log file from before the problem
Comment 2 Andy Burns 2009-05-25 10:07:09 EDT
Created attachment 345316 [details]
Xorg logfile attempting to restart X after the problem
Comment 3 Andy Burns 2009-05-25 18:25:00 EDT
I have discovered that the X problem does not happen if I boot with "nomodeset" kernel parameter.

I will try to find if any other program apart from mythtv can produce the fault with KMS enabled.
Comment 4 Andy Burns 2009-05-30 04:28:16 EDT
Fixed by upgrading to

kernel-PAE-2.6.29.4-167.fc11.i686
 and/or
xorg-x11-drv-intel-2.7.0-7.fc11.i586

"Add intel-2.7-dont-vsync-xv.patch to disable Xv vsync, fixes hw
 lockup for full screen Xv (#499895)" sounds familiar.
Comment 5 Andy Burns 2009-05-30 04:40:03 EDT

*** This bug has been marked as a duplicate of bug 499895 ***

Note You need to log in before you can comment on or make changes to this bug.