Bug 499895 - Fullscreen movie on external monitor freezes Xorg
Fullscreen movie on external monitor freezes Xorg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
: Reopened
: 499245 502493 523005 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 14:52 EDT by Espen Stefansen
Modified: 2018-04-11 14:43 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 04:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (110.70 KB, text/plain)
2009-05-09 06:13 EDT, Espen Stefansen
no flags Details

  None (edit)
Description Espen Stefansen 2009-05-08 14:52:37 EDT
Description of problem:
I have a laptop with an onboard Intel graphicscard, which I've connected to a TV, so I can use dualscreen. When I play a movie on the laptopscreen, everything works fine. When I move the movie on the TV-screen and chooses fullscreen, Xorg freezes completely. Keyboard doesn't work either, so I have to turn off the power and restart.

lspci -v:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
	Subsystem: Dell Latitude D630
	Flags: bus master, fast devsel, latency 0, IRQ 28
	Memory at f6e00000 (64-bit, non-prefetchable) [size=1M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at eff8 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Mask- 64bit- Count=1/1 Enable+
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915
	Kernel modules: i915

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.7.0-4.fc11.x86_64
xorg-x11-server-common-1.6.1-11.fc11.x86_64
xorg-x11-server-Xorg-1.6.1-11.fc11.x86_64
mesa-dri-drivers-7.5-0.9.fc11.x86_64
mesa-libGL-7.5-0.9.fc11.x86_64
mesa-libGLU-7.5-0.9.fc11.x86_64
kernel-2.6.29.2-126.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2009-05-08 17:12:40 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Adam Jackson 2009-05-08 17:32:28 EDT
Also, please specify which movie player you're using, and whether you have compiz or another compositor enabled.
Comment 3 Espen Stefansen 2009-05-09 06:13:37 EDT
Created attachment 343200 [details]
Xorg log
Comment 4 Espen Stefansen 2009-05-09 06:16:42 EDT
The freze happens with both Totem and gnome-mplayer. And I have no compiz enabled.

I also tried updating to the latest kernel in koji, kernel-2.6.29.3-135.fc11.x86_64, since it had som intel-fixes, but it did not help.
Comment 5 Kristian Høgsberg 2009-05-28 15:22:15 EDT
*** Bug 499245 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2009-05-28 15:33:18 EDT
This is totally what I am seeing.  krh said to disable vsync and this should be worked around.  He said he intends on disabling it in a build soon.
Comment 7 Espen Stefansen 2009-05-29 06:15:55 EDT
The latest intel-driver [1] from koji fixes this problem. :)

[1] xorg-x11-drv-intel-2.7.0-7.fc11
Comment 8 Andy Burns 2009-05-30 04:38:36 EDT
I had a similar problem with mythtv (only occurs when booting with KMS enabled) the latest xorg-x11-drv-intel-2.7.0-7.fc11 from rawhide fixed it (perhaps at the cost of smooth video by no longer having vsync to prevent tearing?)
Comment 9 Andy Burns 2009-05-30 04:40:03 EDT
*** Bug 502493 has been marked as a duplicate of this bug. ***
Comment 10 Bug Zapper 2009-06-09 11:28:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Pavel Zhukov 2009-06-14 04:45:54 EDT
Similar problem with F11 release still exists. xorg-x11-drv-intel-2.7.0.7 installed, but it doesn't help
Comment 12 Frank 2009-07-18 07:02:06 EDT
Same Problem on Asus eeepc with Fedora 11 and xorg-drv-intel-2.7.0.7, no matter what video player. Fullscreen flash video from within firefox works, though.


(In reply to comment #11)
> Similar problem with F11 release still exists. xorg-x11-drv-intel-2.7.0.7
> installed, but it doesn't help
Comment 13 hsanchisalepuz 2009-09-11 07:10:43 EDT
The same here, on Asus eeepc 901 with Fedora 11 when trying to see fullscreen videos in an external screen using kaffeine, xine or gnome-mplayer.
Comment 14 Denis Auroux 2009-09-20 20:42:39 EDT
Same problem with a Lenovo X200 Tablet on Fedora 11. (Intel driver).

* kernel: 2.6.29.6-217.2.16.fc11.i686.PAE  (the 2.6.30.5-43.fc11.i686.PAE kernel doesn't allow X to start up properly)
* xorg-x11-server-Xorg-1.6.4-0.1.fc11.i586, xorg-x11-drv-intel-2.7.0-7.fc11.i586
* display config: 1280x800 internal panel on LVDS1, Dell 2005FP monitor (1600x1200) on VGA1; output of xrandr -q below.
* fullscreen video on the external monitor when in dual-screen mode crashes with at least mplayer and skype, but not with the flash plugin (v10) within firefox.

This is a major bug, please someone work on it! As a developer I can't understand how a mainstream distribution can ship with such awful bugs in it. (not to mention the inability of the X server to start with the 2.6.30.5-43 PAE kernel, or the completely messed up display when one tries to rotate the laptop panel display to portrait mode while in dual screen mode.

SOMEONE PLEASE BRING US BACK THE QUALITY CONTROL TEAM FROM FEDORA 10 !!
Comment 15 Denis Auroux 2009-09-20 21:29:58 EDT
Interestingly... this bug, like many others related to dual-display and tablet PC features (incorrect xrandr rotation while in dual display mode, incorrectly detected DVI outputs, etc.) goes away when passing "nomodeset" to the kernel command line. 

Denis
Comment 16 Peter Janakiev 2009-10-26 04:08:13 EDT
*** Bug 523005 has been marked as a duplicate of this bug. ***
Comment 18 Matěj Cepl 2009-11-05 13:28:48 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 19 Espen Stefansen 2009-11-05 14:30:41 EST
I have actually already upgraded to F12/Rawhide and the problem is fixed there. So consider this fixed for me. :)
Comment 20 Oded Arbel 2009-11-05 14:38:09 EST
I have also upgraded to F12 and indeed can't reproduce the problem there.
Comment 21 Matěj Cepl 2009-11-08 16:10:27 EST
Thank you for letting us know.
Comment 22 Werner Gold 2010-06-02 04:27:52 EDT
It looks like the bug is back in F13. At least for me.

[root@joe ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Fullscreen works on the internal Display. The external one freezes.
Comment 23 Werner Gold 2010-06-02 04:29:59 EDT
Oops sorry. I forgot to mention that I'm talking about Flash movies and Firefox.
Comment 24 Werner Gold 2010-06-02 04:38:59 EDT
Oh, close it. 598793  seems applicable.

Note You need to log in before you can comment on or make changes to this bug.