Bug 502505 - Value of HOSTNAME= in /etc/sysconfig/network is not changed by anaconda during install (nor, by the way, by the hostname command after install)
Value of HOSTNAME= in /etc/sysconfig/network is not changed by anaconda durin...
Status: CLOSED DUPLICATE of bug 492515
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 10:44 EDT by Peter Trenholme
Modified: 2009-06-03 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 23:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2009-05-25 10:44:57 EDT
Description of problem:
Hostname in /etc/sysconfig/network is not set to the value entered during the installation from the prerelease live CD

Version-Release number of selected component (if applicable):


How reproducible:
Every time I've tried it.

Steps to Reproduce:
1. Burn LiveCD
2. Select "Install to HD
3. Enter a hostname when prompted
  
Actual results:
/bin/hostname returns localhost.localdomain

Expected results:
/bin/hostname returns entered string

Additional info:
Changing the HOSTNAME= value in /etc/sysconfig/network fixes the problem
Comment 1 David Cantrell 2009-06-03 23:05:34 EDT
Confirmed that commit 5ebb7235d36390fa72faa730c1f5a452e3432eb1 fixes this problem.  The hostname entered during installation is written to the HOSTNAME= line in /etc/sysconfig/network.

This fix is present in anaconda-11.5.0.50-1 and later builds.

The hostname of the running system is not altered by anaconda.  The hostname you enter is written to /etc/sysconfig/network on the target system.
Comment 2 David Cantrell 2009-06-03 23:06:26 EDT

*** This bug has been marked as a duplicate of bug 492515 ***

Note You need to log in before you can comment on or make changes to this bug.