This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 492515 - liveinst, hostname set during anaconda does not stick
liveinst, hostname set during anaconda does not stick
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 495419 502505 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 03:08 EDT by Warren Togami
Modified: 2009-06-03 23:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 14:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-03-27 03:08:52 EDT
LiveCD x86_64 from March 26th, 2009

* Boot LiveCD
* Install to Hard Drive
* When it asks for hostname, I erase the default "localhost.localdomain" and write "mylaptop".
* After booted into system, I find that the hostname is still localhost.localdomain.
Comment 1 Warren Togami 2009-04-12 23:08:50 EDT
Still broken in F11 Snapshot1 Live install.
Comment 2 David Cantrell 2009-04-21 21:40:18 EDT
On the newly booted system that you installed via the livecd, what is in /etc/hosts and /etc/sysconfig/network?
Comment 3 David Cantrell 2009-04-21 22:02:59 EDT
*** Bug 495419 has been marked as a duplicate of this bug. ***
Comment 4 Benjamin Bellec 2009-05-04 02:39:20 EDT
Hello,
I have also this bug with the F11 Preview (install from the Gnome LiveCD x86).
And when I re-set the hostname (with the command "hostname my_computer_name" in root), this was not stored and at the next boot the default hostname ("localhost.localdomain") is still set.

After re-set the hostname, the file "/etc/hosts" and "/etc/sysconfig/network" still indicate "localhost.localdomain". But the gnome-system-monitor indicate the new hostname (during the current session and it's reset after reboot).
Comment 5 David Cantrell 2009-05-05 22:38:57 EDT
As of commit c1aaab41558216ea1ba16400aaad60657fa76dae, anaconda no longer does anything with /etc/hosts (see bug #491808).

However, we still write out /etc/sysconfig/network, which contains HOSTNAME.  I've patched anaconda so that HOSTNAME contains the value you enter in anaconda during a LiveCD install.

Submitted patch for review by the team.
Comment 6 David Cantrell 2009-05-06 14:31:35 EDT
Fixed in anaconda-11.5.0.50-1.fc11 and later.
Comment 7 David Cantrell 2009-06-03 23:06:26 EDT
*** Bug 502505 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.