Bug 502702 - Thinkpad x200s laptop buttons in KDE
Thinkpad x200s laptop buttons in KDE
Status: CLOSED DUPLICATE of bug 475247
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 21:33 EDT by Andrei Gaponenko
Modified: 2009-05-26 22:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 22:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Gaponenko 2009-05-26 21:33:15 EDT
Hi,

Good news first, many "laptop" things work out of the box in the
current rawhide on my new Lenovo Thinkpad x200s.  It does suspend when
the lid is closed while on battery power.  The slider in the popup one
gets by clicking on the "Battery monitor" on the KDE panel does change
the screen brightness.

But the Fn+F4 (suspend), Fn+Home/End (brightness), Fn+F2 (lock screen)
key combinations that do work in GNOME (and in Fedora 10 running
KDE-3's kpowersave) are ignored in the F11 beta KDE install.
(I did not test a few other keys such as display switching.)

It would be good if KDE power management settings (such as "When Sleep
Button pressed: suspend to RAM") corresponded to the actual behavior.

Regards,
Andrei
Comment 1 Rex Dieter 2009-05-26 22:23:17 EDT

*** This bug has been marked as a duplicate of bug 475247 ***

Note You need to log in before you can comment on or make changes to this bug.