Bug 502714 - switch to using PolicyKit
switch to using PolicyKit
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qpxtool (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 502765
  Show dependency treegraph
 
Reported: 2009-05-26 23:52 EDT by Rahul Sundaram
Modified: 2013-03-13 01:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 08:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-26 23:52:58 EDT
Description of problem:

usermode/consolehelper is deprecated since Fedora has a better framework now called PolicyKit. Please switch to using that instead

http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Adel Gadllah 2009-05-27 08:11:48 EDT
No switching to another framework is not the solution here.

The reason this app requires root privileges is that it sends vendor specific SCSI commands that may be harmful when sent to a device that does not support it.

I have made the kernel SCSI cmdfilter user space configurable during the 2.6.27 development cycle.

With this filter we can simply allow the commands for the supported devices and qpxtool should work fine as a user.

Unfortunately the sysfs part of the command filter has been commented out (i.e. disabled) before the release of the kernel 2.6.27, due to kobject related bugs.

Since than nobody (me included) tried to fix this, the infrastructure is still in the kernel but the user space interface is not enabled.

So instead of wasting time/effort on porting this to PolicyKit time should be spent to fix the kernel interface (I might get some free time to do this for F12, but can't promise anything).

As always patches welcome ;)

Closing this WONTFIX because I wont waste my time replacing a hack with another one.

Note You need to log in before you can comment on or make changes to this bug.