Bug 502765 - [Tracker] Deprecate consolehelper and switch apps to use PolicyKit 1 for Fedora 12
[Tracker] Deprecate consolehelper and switch apps to use PolicyKit 1 for Fedo...
Status: NEW
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vokal
Radek Vokal
: Tracking
Depends On: 480902 493901 493903 493908 502717 502719 502721 502723 502731 502734 502735 502738 502740 502751 502753 502754 502756 502758 502800 502802 502803 493904 493909 493916 502714 502715 502716 502718 502720 502722 502724 502725 502726 502727 502729 502730 502732 502733 502736 502739 502741 502742 502743 502748 502749 502750 502752 502755 502757 502759 502760 502761 502762 502801 502804 502808 1145813
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 01:47 EDT by Rahul Sundaram
Modified: 2014-09-24 11:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-27 01:47:20 EDT
Description of problem:


Bugs have been filed against all software in Fedora using consolehelper/usermode asking them to switch to PolicyKit 1.  This is the tracker bug for that.

http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Jaroslav Reznik 2009-05-27 02:39:56 EDT
Hi,
reported bugs for system configuration tools are duplicates of already filled ones by System Configuration Tools Cleanup Project. As this bug depends on this project too I think it's to close new ones as duplicates - we can take care about the rest of s-c-* tools too.
Comment 2 John Poelstra 2009-06-08 15:24:32 EDT
Adding 'Tracking' keyword to be excluded from rawhide rebase to Fedora 11
Comment 3 Axel Thimm 2009-07-25 09:07:43 EDT
I got two applications with bugzillas asking to move to PolicyKit, and while googling around to see if there is a HOWTO for that I found the following:

(In reply to bug #502736 comment #2)
> (In reply to bug #502736 comment #0)
> > Description of problem:
> > 
> > usermode/consolehelper is deprecated since Fedora has a better framework now
> > called PolicyKit. Please switch to using that instead
> > 
> > http://fedoraproject.org/wiki/Features/PolicyKitOne  
> 
> I think it is to early to start using PolicyKitOne, it is still a moving target
> and there is no useful documentation to convert application from consolehelper
> to PolicyKitOne.
> 
> Application need to be redesigned from scratch and split into a backend doing
> the root actions and a frontend running as a normal user and some DBUS magic to
> communicate between the backend and frontend.
> Some of the work in splitting yumex into a frontend gui and a backend doing the
> yum actions is already done i Yum Extender Nextgen, but the PolicyKitOne have
> no python bindings and there is no good docs on how to use it and there is only
> a porting guide for PolicyKit to PolicyKitOne, not for consolehelper type of
> applications to using PolicyKitOne.  

Also out of the 50 bugs filed, none did resolve to fixed, they are either all still open, closed as duplicates or closed as wontfix/cantfix with arguments like "Closing this WONTFIX because I wont waste my time replacing a hack with another one." or "Can't really afford to spend time on PolicyKit integration, but patches are happily accepted. For now, consolehelper does the job."

Maybe the request to integrate PolicyKit everywhere is too early and perhaps submitted at the wrong layer? It does look like it takes upstream skills to integrate it into an application, while usermode/consolehelper was trivial to implement.

Anyway if a HOWTO pops up and the packagers are properly guided to make the switch it has better chances of happening.
Comment 4 Rahul Sundaram 2009-07-25 14:55:41 EDT
You can merely pass on the RFE upstream. It is not just a packaging issue.

Note You need to log in before you can comment on or make changes to this bug.