Bug 502736 - switch to using PolicyKit
switch to using PolicyKit
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 502765
  Show dependency treegraph
 
Reported: 2009-05-27 00:25 EDT by Rahul Sundaram
Modified: 2013-03-13 01:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 01:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-27 00:25:15 EDT
Description of problem:

usermode/consolehelper is deprecated since Fedora has a better framework now
called PolicyKit. Please switch to using that instead

http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 John Poelstra 2009-06-08 16:18:36 EDT
Added 'FutureFeature' keyword to avoid rawhide base
Comment 2 Tim Lauridsen 2009-06-11 06:41:46 EDT
(In reply to comment #0)
> Description of problem:
> 
> usermode/consolehelper is deprecated since Fedora has a better framework now
> called PolicyKit. Please switch to using that instead
> 
> http://fedoraproject.org/wiki/Features/PolicyKitOne  

I think it is to early to start using PolicyKitOne, it is still a moving target and there is no useful documentation to convert application from consolehelper to PolicyKitOne.

Application need to be redesigned from scratch and split into a backend doing the root actions and a frontend running as a normal user and some DBUS magic to communicate between the backend and frontend.
Some of the work in splitting yumex into a frontend gui and a backend doing the yum actions is already done i Yum Extender Nextgen, but the PolicyKitOne have no python bindings and there is no good docs on how to use it and there is only a porting guide for PolicyKit to PolicyKitOne, not for consolehelper type of applications to using PolicyKitOne.
Comment 3 Tim Lauridsen 2009-09-23 01:04:05 EDT
Current yumex in rawhide, only uses consolehelper for spawning a child doing the the backend yum actions, and the gui runs as normal user. So the the security reasons to split the parts needing root access from the gui is implemented.
So i will close this a wontfix, feel free to reopen when PolicyKitOne matures and has has good documentation and python python bindings, so i don't have to reimplement any thing i C to make it work with PolicyKitOne :)

Note You need to log in before you can comment on or make changes to this bug.