Bug 502741 - switch to using PolicyKit
switch to using PolicyKit
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 502765
  Show dependency treegraph
 
Reported: 2009-05-27 00:35 EDT by Rahul Sundaram
Modified: 2013-03-13 01:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 12:45:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-27 00:35:27 EDT
Description of problem:

usermode/consolehelper is deprecated since Fedora has a better framework now
called PolicyKit. Please switch to using that instead

http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 John Poelstra 2009-06-08 16:18:39 EDT
Added 'FutureFeature' keyword to avoid rawhide base
Comment 2 Jeremy Katz 2009-07-06 15:15:00 EDT
Hmmm, pkexec would be the obvious way to do this, but pkexec drops most environment variables.

I've read the comments at https://bugs.freedesktop.org/show_bug.cgi?id=17970#c26
 but quite frankly, that misses the point a little bit.  I'm 110% behind dropping them by default, but having a way to add environment variables to preserve in the polkit auth file would make this doable.

Otherwise, we're going to have to do some other hack around sudo or su or something which I'd obviously rather not do :-)
Comment 4 Brian Lane 2010-11-18 12:45:37 EST
PolKit is overkill for this, especially given that consolehelper is functioning just fine.

Note You need to log in before you can comment on or make changes to this bug.