Bug 502778 - Avoid Duplicate language names for locales that uses different scripts
Avoid Duplicate language names for locales that uses different scripts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 502984 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 03:48 EDT by Parag Nemade
Modified: 2015-01-14 18:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 14:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm-language-selection-list (40.18 KB, image/png)
2009-05-27 03:48 EDT, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2009-05-27 03:48:07 EDT
Created attachment 345574 [details]
gdm-language-selection-list

Description of problem:
In F-11 gdm language selection list, I found that for locales ks_IN and ks_IN@devanagari are showing same language name "Kashmiri (India)". Both of these locales are for India country but divided based on scripts. ks_IN uses Perso-Arabic script whereas ks_IN@devanagari uses Devanagari script.

Version-Release number of selected component (if applicable):
gdm-2.26.1-10.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. look into gdm language selection list
2.
3.
  
Actual results:
Both locales shows same language name and confuses which language is selected.

Expected results:
Can we have some way to identify which locale is selected or Can we have some kind of change in language list?

Additional info:
Comment 1 Ray Strode [halfline] 2009-05-27 13:45:07 EDT
It's supposed to show the language name in the native language and script.  There must not be good enough translation coverage in the iso-codes package.  Reassigning.
Comment 2 A S Alam 2009-05-28 02:46:41 EDT
*** Bug 502984 has been marked as a duplicate of this bug. ***
Comment 3 Parag Nemade 2009-05-28 02:55:45 EDT
(In reply to comment #1)
> It's supposed to show the language name in the native language and script. 
> There must not be good enough translation coverage in the iso-codes package. 
> Reassigning.  

Is this really translation issue? But as per https://bugzilla.redhat.com/show_bug.cgi?id=502984#c2, it looks language name construction issue.
Comment 4 Ray Strode [halfline] 2009-05-29 00:46:37 EDT
nope, you're right, moving back to gdm.
Comment 5 Ray Strode [halfline] 2009-05-29 01:04:07 EDT
looks like a broken regex.  This:

--- a/gui/simple-greeter/gdm-languages.c
+++ b/gui/simple-greeter/gdm-languages.c
@@ -123,7 +123,7 @@ gdm_parse_language_name (const char *name,
         error = NULL;
         re = g_regex_new ("^(?P<language>[^_.@[:space:]]+)"
                           "(_(?P<territory>[[:upper:]]+))?"
-                          "(.(?P<codeset>[-_0-9a-zA-Z]+))?"
+                          "(\\.(?P<codeset>[-_0-9a-zA-Z]+))?"
                           "(@(?P<modifier>[[:ascii:]]+))?$",
                           0, 0, &error);
         if (re == NULL) {

should fix it.
Comment 6 Bug Zapper 2009-06-09 12:37:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Parag Nemade 2009-06-25 05:10:56 EDT
if this fix is applied then can we close this bug?

Note You need to log in before you can comment on or make changes to this bug.