Bug 502984 - selecting Kashmiri (India) (2nd from top list) from Language list don't work, 'Locale not Supported' Error
selecting Kashmiri (India) (2nd from top list) from Language list don't work,...
Status: CLOSED DUPLICATE of bug 502778
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 01:54 EDT by A S Alam
Modified: 2015-01-14 18:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 02:46:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2009-05-28 01:54:03 EDT
Description of problem:
 after login by selecting Kashmiri (India) [2nd from list, not first], giving the Error while run any application, even locale command give error.

Version-Release number of selected component (if applicable):
glibc-2.10.1-2

How reproducible:
100%

Steps to Reproduce:
1. at GDM, select Language Kashmiri (India) (2nd Language out of Two Kashmiri (India))
2. Login
3. open gnome -terminal and type 'locale'
4. run gedit from Terminal
  
Actual results:
Error as following:
----------
After step 3

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or direct

After step 4
Gtk-Warning **: Locale is not supported  by C library.

--------

Expected results:

Should  be error free and environment should be proper 'ks'

Additional info:
Comment 1 A S Alam 2009-05-28 01:56:19 EDT
$echo $LANG
ks_IN.devanagari

$locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=ks_IN.devanagari
LC_CTYPE="ks_IN.devanagari"
LC_NUMERIC="ks_IN.devanagari"
LC_TIME="ks_IN.devanagari"
LC_COLLATE="ks_IN.devanagari"
LC_MONETARY="ks_IN.devanagari"
LC_MESSAGES="ks_IN.devanagari"
LC_PAPER="ks_IN.devanagari"
LC_NAME="ks_IN.devanagari"
LC_ADDRESS="ks_IN.devanagari"
LC_TELEPHONE="ks_IN.devanagari"
LC_MEASUREMENT="ks_IN.devanagari"
LC_IDENTIFICATION="ks_IN.devanagari"
LC_ALL=
Comment 2 Jakub Jelinek 2009-05-28 02:03:49 EDT
ks_IN.devanagari is not a valid locale name, devanagari is not a character set name.
You want ks_IN@devanagari or ks_IN.UTF-8@devanagari, which are supported, devanagari is a locale modifier, locale names look like:
language[_territory][.codeset][@modifier]
Comment 3 A S Alam 2009-05-28 02:30:16 EDT
ah, then GDM  language list making wrong locale setting for language having @modifier (like devanagari or cyrillic)
Language includes:
Kashimiri, Sandhi, uz

gdm-2.26.1-10
Comment 4 A S Alam 2009-05-28 02:46:41 EDT
it is duplicate for bug #502778

*** This bug has been marked as a duplicate of bug 502778 ***

Note You need to log in before you can comment on or make changes to this bug.