Bug 502862 - libvirt runs qemu-system-ppc with wrong machine type - should be g3beige, not g3bw
libvirt runs qemu-system-ppc with wrong machine type - should be g3beige, not...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-27 11:01 EDT by Thomas J. Baker
Modified: 2009-06-24 15:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.6.2-12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
g3bw to g3beige patch (1.50 KB, text/plain)
2009-05-27 12:12 EDT, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2009-05-27 11:01:12 EDT
I updated to virt-manager-0.7.0-5.fc11 and now when trying to create a ppc
machine, it fails because it specifies '-M g3bw' to qemu-system-ppc when the
option should be '-M g3beige' or nothing because g3beige is apparently the
default.

From the log:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-system-ppc -S -M g3bw
-m 1024 -smp 1 -name sawhorse -uuid d88aa53c-db68-4091-56df-1a8010e8c4e7
-monitor pty -pidfile /var/run/libvirt/qemu//sawhorse.pid -no-reboot -boot d
-drive file=/var/lib/libvirt/images/sawhorse-3.img,if=ide,index=0 -drive
file=/tmp/Fedora-9-ppc-DVD.iso,if=ide,media=cdrom,index=2 -net
nic,macaddr=54:52:00:11:c0:91,vlan=0 -net tap,fd=22,script=,vlan=0,ifname=vnet0
-serial pty -parallel none -usb -vnc 127.0.0.1:0 
Supported machines are:
g3beige    Heathrow based PowerMAC (default)
mac99      Mac99 based PowerMAC
prep       PowerPC PREP platform
ref405ep   ref405ep
taihu      taihu
bamboo     bamboo
mpc8544ds  mpc8544ds
Comment 1 Thomas J. Baker 2009-05-27 12:11:48 EDT
I tried rebuilding the libvirt-0.6.3-11.fc12.src.rpm with a patch (soon attached) that replaced all occurrences of g3bw with g3beige and now creating a ppc system seems to start OK but just hangs with a black screen. An error is logged:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin HOME=/root USER=tjb LOGNAME=tjb /usr/bin/qemu-system-ppc -S -M g3beige -m 512 -smp 1 -name sawhorse -uuid d1f92863-ee9b-b0fd-fc0a-d69ba5ce3511 -monitor pty -pidfile /var/run/libvirt/qemu//sawhorse.pid -no-reboot -boot d -drive file=/var/lib/libvirt/images/sawhorse.img,if=ide,index=0 -drive file=/tmp/Fedora-9-ppc-DVD.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:02:36:2a,vlan=0 -net tap,fd=18,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 
char device redirected to /dev/pts/3
char device redirected to /dev/pts/4
invalid/unsupported opcode: 00 - 18 - 01 (00004070) 00000004 1
invalid/unsupported opcode: 00 - 04 - 17 (000095c8) 000095ec 0
Comment 2 Thomas J. Baker 2009-05-27 12:12:37 EDT
Created attachment 345637 [details]
g3bw to g3beige patch
Comment 3 Daniel Veillard 2009-05-28 04:36:07 EDT
Hum, the QEmu PPC emulation has changed since qemu support was added
to libvirt. Patch looks fine, but I would prefer to have this handled directly
on the libvir-list@redhat.com as for other upstream libvirt issues.

https://www.redhat.com/mailman/listinfo/libvir-list

Daniel
Comment 4 Thomas J. Baker 2009-05-28 08:23:22 EDT
What about the fact that it doesn't run even after patched? I can't really open another bug report about a patched version of libvirt, can I? Is PPC emulation supposed to work at all?
Comment 5 Daniel Berrange 2009-05-28 08:30:49 EDT
Well libvirt's responsbility ends once the QEMU process succesfully starts. The errors you now see

invalid/unsupported opcode: 00 - 18 - 01 (00004070) 00000004 1
invalid/unsupported opcode: 00 - 04 - 17 (000095c8) 000095ec 0  

should be reported against 'QEMU', since it looks like their PPC emulation bugs.
Comment 6 Mark McLoughlin 2009-05-28 09:40:07 EDT
(In reply to comment #3)
> Hum, the QEmu PPC emulation has changed since qemu support was added
> to libvirt. Patch looks fine, but I would prefer to have this handled directly
> on the libvir-list@redhat.com as for other upstream libvirt issues.
> 
> https://www.redhat.com/mailman/listinfo/libvir-list

Thomas, please post the patch to libvir-list and we'll cherry-pick it into F-11 when it gets applied upstream.

(In reply to comment #1)

> invalid/unsupported opcode: 00 - 18 - 01 (00004070) 00000004 1
> invalid/unsupported opcode: 00 - 04 - 17 (000095c8) 000095ec 0  

See bug #494075 - try openbios from updates-testing

(In reply to comment #4)

> Is PPC emulation supposed to work at all?

Of course! There may just not be many people testing it, is all. We'll do our best to fix any issues you come across, just please do file them as separate bugs.
Comment 7 Thomas J. Baker 2009-05-28 13:49:02 EDT
I posted the patch to the list. I updated to the updates-testing openbios. Now libvirt correctly starts a ppc machine which appears to start up correctly but it doesn't boot from the CDROM image I specified. It just gives me a '0 >' prompt and I don't understand how to boot it. Should I bugzilla this as an openbios bug? Thanks.
Comment 8 Mark McLoughlin 2009-06-04 11:44:51 EDT
tjb: yeah, any further problems you have, please file in another bug

Patch is upstream now, need to pull it into F11
Comment 9 Mark McLoughlin 2009-06-05 07:51:05 EDT
Building this update:

* Fri Jun  5 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-12.fc11
- Use the correct QEMU machine type for ppc (bug #502862)
- Fix crash with TLS connections (bug #503066)
- Fix broken networking with newer qemu releases (bug #503275)
- Remove the qemu BuildRequires
Comment 10 Fedora Update System 2009-06-05 09:23:07 EDT
libvirt-0.6.2-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-12.fc11
Comment 11 Bug Zapper 2009-06-09 12:38:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Fedora Update System 2009-06-15 21:33:06 EDT
libvirt-0.6.2-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6060
Comment 13 Fedora Update System 2009-06-24 15:21:01 EDT
libvirt-0.6.2-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.