Bug 503275 - invalid parameters passed to qemu
invalid parameters passed to qemu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Reopened
: 505106 (view as bug list)
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-30 11:22 EDT by darrell pfeifer
Modified: 2009-06-26 14:42 EDT (History)
10 users (show)

See Also:
Fixed In Version: 0.6.2-12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:21:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2009-05-30 11:22:06 EDT
Description of problem:

virt-manager passes invalid parameters to qemu. The problem seems to have started with the newest version


Version-Release number of selected component (if applicable):

virt-manager-0.7.0-5.fc12.i586
libvirt-0.6.4-1.fc12.i586
qemu-kvm-0.10.50-4.kvm86.fc12.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

[Sat, 30 May 2009 07:47:45 virt-manager 12119] DEBUG (engine:491) Starting vm 'f10'
.
[Sat, 30 May 2009 07:47:50 virt-manager 12119] DEBUG (error:76) Uncaught Error: Err
or starting domain: internal error unable to start guest: qemu: invalid parameter '
16' in 'fd=16,script=,vlan=0,ifname=vnet0'
 : Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
    self.vm.create()
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 291, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: qemu: invalid parameter '16' in
 'fd=16,script=,vlan=0,ifname=vnet0'



Expected results:


Additional info:
Comment 1 Daniel Berrange 2009-06-01 05:55:23 EDT
I don't believe that you are actually running libvirt 0.6.4, because this bug was fixed in the 0.6.4 release. Please reboot the host, or restart the libvirtd daemon and re-verify. I doubt you'll be able to reproduce this bug after doing that.
Comment 2 darrell pfeifer 2009-06-01 09:14:56 EDT
You're correct. Works after a reboot. (Usually I remember, but must be slipping in my old age)
Comment 3 Mark McLoughlin 2009-06-05 07:50:55 EDT
You'll get this error on F-11 if you update to qemu-0.10.50, though - we might as well fix it

Building this update:

* Fri Jun  5 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-12.fc11
- Use the correct QEMU machine type for ppc (bug #502862)
- Fix crash with TLS connections (bug #503066)
- Fix broken networking with newer qemu releases (bug #503275)
- Remove the qemu BuildRequires
Comment 4 Fedora Update System 2009-06-05 09:23:21 EDT
libvirt-0.6.2-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-12.fc11
Comment 5 Fedora Update System 2009-06-15 21:33:19 EDT
libvirt-0.6.2-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6060
Comment 6 Mark McLoughlin 2009-06-22 09:12:17 EDT
*** Bug 505106 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2009-06-24 15:21:14 EDT
libvirt-0.6.2-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Erik Jacobson 2009-06-26 14:42:39 EDT
The change looks good to me.  See 505106 for more detail on the test.

Note You need to log in before you can comment on or make changes to this bug.