Bug 50304 - rpmb --rebuild doesn't work
Summary: rpmb --rebuild doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL: http://people.mandrakesoft.com/~flepi...
Whiteboard:
Keywords:
: 50305 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-30 07:03 UTC by Frederic Lepied
Modified: 2008-05-01 15:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-07-30 13:55:14 UTC


Attachments (Terms of Use)

Description Frederic Lepied 2001-07-30 07:03:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-4mdk i686; Nav)

Description of problem:
rpmb --rebuild on this package doesn't work but if you issue rpm -i and
then rpm -ba, it works fine.

How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild <srpm>
2.
3.
	

Actual Results:  an exit code 1 after the find-requires but with no error
message.

Expected Results:  packages rebuilt

Additional info:

tested with current cvs 20010730

Comment 1 Jeff Johnson 2001-07-30 13:47:09 UTC
This builds fine for me.

The problem is probably with the "%description -l fr", try deleting
that and rebuilding. If that builds, then the underlying problem is
that you're probably building in a different locale than I am. Try
building with LANG=en_US. If I can get the problem reproduced,
I will fix.

Comment 2 Jeff Johnson 2001-07-30 13:55:10 UTC
*** Bug 50305 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2001-08-03 04:57:41 UTC
FIxed in rpm-4.0.3-0.86.


Note You need to log in before you can comment on or make changes to this bug.