Bug 503302 - Crash going back after install's partitioning stage
Crash going back after install's partitioning stage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
: 501297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-30 21:40 EDT by Gordon Messmer
Modified: 2009-11-10 03:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 03:44:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda's state dump (248.20 KB, text/plain)
2009-05-30 21:41 EDT, Gordon Messmer
no flags Details

  None (edit)
Description Gordon Messmer 2009-05-30 21:40:47 EDT
Description of problem:
If a user proceeds though Anaconda to the partitioning stage of the Install process, then decides that he wants to go back and Upgrade instead, anaconda will crash.  I don't know if this is specific to a system with an encrypted /home partition, but the tested system was so configured.

Version-Release number of selected component (if applicable):
11.5.0.56

How reproducible:
Always

Steps to Reproduce:
1. PXE boot the installer (I expect other methods to fail as well).  Select the language, keyboard type, URL install method, DHCP configuration, and provide the URL to start the anaconda GUI.
2. Click Next on anaconda's first (useless) screen.
3. Anaconda tries to find storage devices.  A logical volume is encrypted, and anaconda asks for the passphrase.
4. Select "Install Fedora"
5. Proceed through hostname, timezone, and root password inputs.
6. On the partitioning page, click "Next".  Anaconda asks if the user would like to write the new partitions to the disk.  The user decides at the last moment to do an upgrade instead.
7. Click back until the option to Install or Upgrade is offered again.  Select Upgrade and click Next.
Comment 1 Gordon Messmer 2009-05-30 21:41:44 EDT
Created attachment 345993 [details]
Anaconda's state dump
Comment 2 Andy Lindeberg 2009-06-01 11:24:10 EDT
*** Bug 501297 has been marked as a duplicate of this bug. ***
Comment 3 Jeffrey R. Evans 2009-06-01 17:14:10 EDT
Andy seems to be fluent in that new math, the Math where the 18th of May is younger than the 30th of May of the same year.
Comment 4 Andy Lindeberg 2009-06-02 08:58:58 EDT
As clumens said in your own bug, this one has more information and is thus being used as the master bug. I understand that having a bug marked as a dupe might be a terrible blow to one's self esteem, but would you please stop spamming bugs about it?
Comment 5 Bug Zapper 2009-06-09 12:52:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Radek Vykydal 2009-07-20 08:21:49 EDT
This should be fixed in version 12.0 of anaconda. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.