Bug 503308 - udev does not create /dev/fd0
udev does not create /dev/fd0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 507484 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 04:00 EDT by Allen Kistler
Modified: 2010-07-29 10:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: 141-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allen Kistler 2009-05-31 04:00:03 EDT
Description of problem:
There is no /dev/fd0.

Version-Release number of selected component (if applicable):
udev-141-3.fc11.i586 (from RC2 i386 DVD)

How reproducible:
Always

Steps to Reproduce:
1. Boot
2. ls /dev/fd0
  
Actual results:
No such file or directory

Expected results:
It should exist.

Additional info:
"lsmod | grep floppy" shows the module isn't loaded.
Manually modprobing for "floppy" loads the module and adds /dev/fd0.

Perhaps this bug is a more extreme version of Bug 492404.
Comment 1 Bug Zapper 2009-06-09 12:52:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Allen Kistler 2009-06-25 15:39:52 EDT
Hopping in the wayback machine, if I create /etc/sysconfig/modules/udev-stw.modules with the following content:

#!/bin/sh
MODULES="floppy"
for i in $MODULES ; do
  modprobe $i >/dev/null 2>&1
done

everything is fine at boot.  At some point udev-stw.modules went away because the kernel and udev didn't need it anymore.  Regression?
Comment 3 Harald Hoyer 2009-06-26 05:34:27 EDT
It was replaced by:

$ cat /etc/modprobe.d/floppy-pnp.conf 
alias pnp:dPNP0700 floppy

Most BIOSes provide the plug and play symbol, so autoloading works for 99,99% of all machines.

Your /sys/block/fd0/device/modalias might contain another string. Please provide the output of:

# modprobe floppy
# cat /sys/block/fd0/device/modalias
Comment 4 Àlex Magaz Graça 2009-06-26 07:41:23 EDT
I'm also having this problem. Here is the output from the cat command:

# cat /sys/block/fd0/device/modalias
platform:floppy

By the way, bugs #500066 and #507484 look the same as this one.
Comment 5 Michael Cronenworth 2009-06-26 11:03:57 EDT
(In reply to comment #3)
> Most BIOSes provide the plug and play symbol, so autoloading works for 99,99%
> of all machines.

Looks like that assumption was incorrect.

$ cat /sys/block/fd0/device/modalias
platform:floppy

ASUS P4P800-E motherboard (P4-based), latest BIOS
Comment 6 Allen Kistler 2009-06-26 14:34:34 EDT
(In reply to comment #3)
> It was replaced by:
> 
> $ cat /etc/modprobe.d/floppy-pnp.conf 
> alias pnp:dPNP0700 floppy
> 
> Most BIOSes provide the plug and play symbol, so autoloading works for 99,99%
> of all machines.

I've got 3 machines (4 if you count VMware Workstation) where the floppy module does not load automatically unless I load it manually or use the extra sysconfig file.  (Homebrew with Tyan motherboard, Dell minitower, Compaq laptop)  F9 had no problem with the floppy on these same machines.

> Your /sys/block/fd0/device/modalias might contain another string. Please
> provide the output of:
> 
> # modprobe floppy
> # cat /sys/block/fd0/device/modalias  

As with the others, cat /sys/block/fd0/device/modalias yields
platform:floppy

Only 1 of my machines (not including VMware) still has an F9 partition, but F9 yields the same value on that one, as well (but works automatically, as I said above).

FWIW, when I searched before posting this report, I didn't search 0xFFFF (nor would I want to), so I missed 500066.
Comment 7 Harald Hoyer 2009-06-30 04:51:25 EDT
*** Bug 507484 has been marked as a duplicate of this bug. ***
Comment 8 Harald Hoyer 2009-06-30 04:57:03 EDT
If running

# grep PNP0700 /sys/bus/acpi/devices/*/modalias

outputs s.th. like

/sys/bus/acpi/devices/PNP0700:00/modalias:acpi:PNP0700:

this should help

# echo "alias acpi:PNP0700: floppy" >> /etc/modprobe.d/floppy-pnp.conf 


Because in recent kernels the floppy module has this module alias, the udev rule was removed. I will add this to floppy-pnp.conf for F-11 as a workaround.
Comment 9 Àlex Magaz Graça 2009-06-30 05:50:40 EDT
It works for me after adding the line to floppy-pnp.conf.
Comment 10 Fedora Update System 2009-06-30 08:05:36 EDT
udev-141-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/udev-141-4.fc11
Comment 11 Àlex Magaz Graça 2009-06-30 08:40:33 EDT
It also works after installing the new package.
Comment 12 Allen Kistler 2009-06-30 11:32:00 EDT
Fix confirmed.  I'll bless it in bohdi.

I'll also close this report once the package hits updates, too, if it's not closed automatically.
Comment 13 Fedora Update System 2009-07-02 01:45:36 EDT
udev-141-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7208
Comment 14 Mike Perrin 2009-07-06 15:43:54 EDT
I don't believe the 99.99% claim either. My motherboard is a Biostar MCP6P M2+. Curiously, the BIOS does not have the "PNP Aware OS" option that I am used to finding on older boards. Floppy disk operation is still broken after installing the udev-141-4.fc11 version as suggested in comment #13. The behavior observed is:

After boot up, at the login screen, the floppy drive light is off and the drive is quiet. After user login, the floppy disk activity light is continuously on and drive-bashing, presumably the same as reported in bug 489083, occurs. The floppy kernel module is loaded and the drive shows up in the Computer browser window as "Unnamed Drive (/dev/fd0)". Inserting a floppy disk stops the bashing. Attempting to open the drive from the file browser produces the error window: "Unable to mount location\ No media in the drive". However, accessing the floppy from the command line with mtools (e.g. mdir a:) is successful. When the floppy disk is removed, the drive-bashing resumes.

Floppy drive operation is normal on an identical system running Fedora 10.
Comment 15 dedded 2009-07-06 17:12:20 EDT
Motherboard: ASUSTeK M3A78

I see the same (exactly the same) drive-bashing described in comment #14 with udev-141-4.fc11.
Comment 16 Joseph L. Casale 2009-07-12 17:14:06 EDT
Motherboard: ASUSTeK P5K-VM

After applying the resolution in Comment #8, I had comment #14's problems.
udev-141-4.fc11 has cured the exact problem comment #14 describes for me, but I can not access the floppy from the Dolphin, the first attempt to mount the floppy access the drive after which nothing is displayed. mount shows it is mounted, but apparently only root can access and create/modify data on the /media/<floppy mount> directory.
Comment 17 Mike Perrin 2009-07-12 20:20:14 EDT
Further observations to those in comment #14.

If I boot up with a disk in the floppy drive, the drive remains quiescent (light off) until either:
- 5 minutes from start of boot if I have logged in before then.
- A few seconds after log in if wait more than 5 minutes from start of boot.
At that time, the drive light turns on (which I believe indicates that the motor is running) and the behavior is the same as booting with the floppy drive empty as previously described: The drive light remains on at all times and drive bashing (2 second periodic seek motion) occurs whenever the floppy disk is removed. The one enduring difference is that the floppy drive does not appear in the Computer browser window.

Whether I boot with or without the floppy disk inserted, if I mount the floppy drive as root from a terminal window the floppy icon appears on my desktop and the files are accessible through nautilus. The floppy drive remains absent from the Computer browser if I booted with the floppy disk installed.

With reference to comment #8, my /etc/modprobe.d/floppy-pnp.conf is
alias pnp:dPNP0700 floppy
alias acpi:PNP0700: floppy
Comment 18 Joseph L. Casale 2009-07-12 23:06:16 EDT
Sorry guys, I spoke to soon. The drive access issue remains for me as well.
Comment 19 Allen Kistler 2009-07-13 01:06:11 EDT
Re: Drive bashing/access

The fact that "something" is continually accessing the floppy drive is a Gnome issue, not a udev issue.  Basically that fact that the floppy wasn't there before hid the fact that Gnome polls the floppy drive every 5 sec or so to see if it should automount any inserted media.  (Whether it actually does so even then is yet another bug which isn't this one.)  If the floppy's not there, Gnome doesn't poll it.  If the floppy is there, then Gnome polls it.

This *udev* bug was/is only about whether the floppy module loads at boot and creates /dev/fd0.

Personally, I've always turned off Gnome automouting using GConf, even before F11.  The point being that what Gnome does with /dev/fd0 is what Gnome does with /dev/fd0.

Anyway, with udev-141-4.fc11 I get, at boot:

$ ls -Z /dev/floppy /dev/fd0
brw-rw----. root floppy system_u:object_r:removable_device_t:s0 /dev/fd0
lrwxrwxrwx. root root   system_u:object_r:device_t:s0    /dev/floppy -> fd0

Does anyone not?
Comment 20 Àlex Magaz Graça 2009-07-13 04:18:56 EDT
Look at the following bug report for the drive access problem:

https://bugzilla.redhat.com/show_bug.cgi?id=489083
Comment 21 Mike Perrin 2009-07-13 14:50:17 EDT
Thanks. My apologies for cluttering up this thread.
Comment 22 Fedora Update System 2009-07-22 17:44:09 EDT
udev-141-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Patrick Lanove 2010-07-29 10:11:54 EDT
I am encountering the same problem in F13

version information:
kernel 2.6.33.6-147.x86_64
udev-111-10.fc13

output of ls command:
#ls /dev/fd0
ls: cannot access /dev/fd0: No such file or directory

# lsmod | grep floppy
shows no output

as before, modprobing floppy loads the module.

Note You need to log in before you can comment on or make changes to this bug.