Bug 503310 - kickstart loses existing RAID config
kickstart loses existing RAID config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 04:31 EDT by Allen Kistler
Modified: 2009-07-22 15:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 19:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Really simple ks without any storage lines (w/password=password) (355 bytes, text/plain)
2009-05-31 16:43 EDT, Allen Kistler
no flags Details
i386 Preview anaconda.log (ks works) (40.12 KB, text/plain)
2009-05-31 16:46 EDT, Allen Kistler
no flags Details
i386 Preview program.log (ks works) (3.19 KB, text/plain)
2009-05-31 16:46 EDT, Allen Kistler
no flags Details
i386 Preview storage.log (ks works) (50.28 KB, text/plain)
2009-05-31 16:48 EDT, Allen Kistler
no flags Details
i386 Preview syslog (ks works) (43.79 KB, text/plain)
2009-05-31 16:49 EDT, Allen Kistler
no flags Details
i386 RC2 anaconda.log (ks doesn't work) (37.45 KB, text/plain)
2009-05-31 16:49 EDT, Allen Kistler
no flags Details
i386 RC2 program.log (ks doesn't work) (1.25 KB, text/plain)
2009-05-31 16:50 EDT, Allen Kistler
no flags Details
i386 RC2 storage.log (ks doesn't work) (39.26 KB, text/plain)
2009-05-31 16:50 EDT, Allen Kistler
no flags Details
i386 RC2 syslog (ks doesn't work) (42.72 KB, text/plain)
2009-05-31 16:51 EDT, Allen Kistler
no flags Details
ks to reuse existing raid-1 arrays (722 bytes, text/plain)
2009-06-02 00:44 EDT, Allen Kistler
no flags Details
i386 Preview anaconda.log (ks works) (47.70 KB, text/plain)
2009-06-02 00:45 EDT, Allen Kistler
no flags Details
i386 Preview program.log (ks works) (7.58 KB, text/plain)
2009-06-02 00:46 EDT, Allen Kistler
no flags Details
i386 Preview storage.log (ks works) (67.52 KB, text/plain)
2009-06-02 00:46 EDT, Allen Kistler
no flags Details
i386 Preview syslog (ks works) (26.50 KB, text/plain)
2009-06-02 00:47 EDT, Allen Kistler
no flags Details
i386 RC2 anaconda.log (ks doesn't work) (24.60 KB, text/plain)
2009-06-02 00:48 EDT, Allen Kistler
no flags Details
i386 RC2 program.log (ks doesn't work) (1.07 KB, text/plain)
2009-06-02 00:48 EDT, Allen Kistler
no flags Details
i386 RC2 storage.log (ks doesn't work) (31.98 KB, text/plain)
2009-06-02 00:48 EDT, Allen Kistler
no flags Details
i386 RC2 syslog (ks doesn't work) (23.83 KB, text/plain)
2009-06-02 00:49 EDT, Allen Kistler
no flags Details

  None (edit)
Description Allen Kistler 2009-05-31 04:31:48 EDT
Description of problem:
Booting with a kickstart file with a missing section should prompt for that info manually.  In this case, leaving out the partitioning info should run the installation automatically, until it prompts for disk layout to be entered manually, then run to completion automatically.  However, when prompting for disk layout, entering custom layout does not display any existing RAID configuration.  The config appears to be lost.  The same problem does not occur when not using kickstart.

Version-Release number of selected component (if applicable):
11.5.0.57 (RC2 i386 DVD)

How reproducible:
Always

Steps to Reproduce:
1. create ks.cfg with all info but the partitioning
2. boot into installation using that ks
3. select create custom layout when prompted

Actual results:
The existing RAID partitions on physical devices is displayed, but all RAID configuration (md0, md1, etc.) is gone

Expected results:
Existing RAID configuration should be retained

Additional info:

Clicking the RESET button to rescan the storage devices doesn't help.

As noted above, running without a kickstart does not exhibit this bug, but then running without a kickstart means running without a kickstart.

This bug is a regression from previous versions (alpha, beta, preview) of F11 DVDs, which worked fine in this regard.
Comment 1 Allen Kistler 2009-05-31 16:43:52 EDT
Created attachment 346022 [details]
Really simple ks without any storage lines (w/password=password)

I'll attach some files from one of my "real-world" examples to provide something tangible.  The disks are laid out as follows:

sda1 RAID-1 md0 /boot
sdb1

sda2 swap
sdb2 swap

sda3 RAID-1 md1 lvm (assorted and variable uses)
sdb3

sda4 RAID-1 md2 / (currently F9)
sdb4

It's a little weird maybe, but not too weird.
Comment 2 Allen Kistler 2009-05-31 16:46:10 EDT
Created attachment 346023 [details]
i386 Preview anaconda.log (ks works)
Comment 3 Allen Kistler 2009-05-31 16:46:52 EDT
Created attachment 346024 [details]
i386 Preview program.log (ks works)
Comment 4 Allen Kistler 2009-05-31 16:48:16 EDT
Created attachment 346025 [details]
i386 Preview storage.log (ks works)
Comment 5 Allen Kistler 2009-05-31 16:49:00 EDT
Created attachment 346026 [details]
i386 Preview syslog (ks works)
Comment 6 Allen Kistler 2009-05-31 16:49:51 EDT
Created attachment 346027 [details]
i386 RC2 anaconda.log (ks doesn't work)
Comment 7 Allen Kistler 2009-05-31 16:50:22 EDT
Created attachment 346028 [details]
i386 RC2 program.log (ks doesn't work)
Comment 8 Allen Kistler 2009-05-31 16:50:56 EDT
Created attachment 346029 [details]
i386 RC2 storage.log (ks doesn't work)
Comment 9 Allen Kistler 2009-05-31 16:51:24 EDT
Created attachment 346030 [details]
i386 RC2 syslog (ks doesn't work)
Comment 10 Allen Kistler 2009-05-31 17:00:31 EDT
Adding to F11AnacondaBlocker.  Although I like to do manual layout (my maze of twisty little machines are all different), I think the RAID config is lost before the manual part starts, so it would affect more people than just my use case.
Comment 11 Chris Lumens 2009-06-01 09:15:56 EDT
It's unfortunately really too late to add things to F11AnacondaBlocker unless they are data corrupters or prevent installation for a very large percentage of users.
Comment 12 Allen Kistler 2009-06-01 14:34:25 EDT
Re: Comment 11

Even though it's late to report a bug like this, it has only recently occurred.  It didn't/doesn't occur on installations from the Preview DVD, just the RC2 DVD.  (I didn't try the RC1 DVD, though.)  That's why I included logs from the Preview for comparison, i.e., to compare to a working installation.

I think that the bug would affect anyone doing kickstart installations that reuse existing RAID.  My use case was just one example.  I understand it's a judgment call, but how large does a very large percentage of users have to be?

Would it at least be large enough to include in the Release Notes as "kickstart installation with preexisting RAID arrays is not supported."  It's a pretty drastic statement for a final release.

I'm not trying to be argumentative.  I'm just wondering what the best way to handle the situation is.  Mostly I'd recommend not ignoring it, because I would expect questions later and as of now it's a known issue.
Comment 13 James Laska 2009-06-01 15:10:55 EDT
ackistler: we can certainly work up an entry on the Common_F11_Bugs page that describes this issue (see https://fedoraproject.org/wiki/Common_F11_bugs).  I'll be happy to help draft content if you like.  Alternatively, you can edit that page directly if you are comfortable ... and we can modified as needed then.
Comment 14 James Laska 2009-06-01 15:58:01 EDT
I can confirm 1) the behavioural difference when running a semi-automated kickstart install on top of a set of RAID disks, and 2) this is indeed a change from F10.  

Certainly worthy of a Common_F11_Bugs entry.  The tests I performed (with results) are below.

= Test#1 =
Perform manual install on top of raid0 installed disks

== Actions ==
1) Install raid0 setup
2) Initiate a manual install and select "Custom partition"

== Results ==
* /dev/md0 is setup already, see http://jlaska.fedorapeople.org/raid0-no-ks.png


= Test#2 =
Perform a semi-automated kickstart install (without any partition options) on top of raid0 installed disks.  Proceed manually when prompted for disk partitioning.

== Actions ==
1) Install raid0 setup
2) Initiate a new kickstart install with *no* ks partition options, when prompted select "Custom partition"

== Results ==
* /dev/md0 is *not* setup already, see http://jlaska.fedorapeople.org/raid0-ks.png
Comment 15 Allen Kistler 2009-06-01 18:16:09 EDT
James:

You can test F11-rc2 vs. F11-preview, too, not just vs. F10.
RAID config is okay in the Preview, but lost in RC2.

I'll try one more use case on my own to confirm that this bug is as bad as I think it could be, i.e., with a fully-automated ks install over existing RAID, I expect the install to just bomb.

Then I'll think up what to say on the wiki.  Give me another day or so to make it happen.
Comment 16 Adam Williamson 2009-06-01 19:10:08 EDT
added to common issues:

https://fedoraproject.org/wiki/Common_F11_bugs#503310

i don't think i phrased it very well, please do feel free to improve my wording. thanks.
Comment 17 Allen Kistler 2009-06-02 00:44:26 EDT
Created attachment 346182 [details]
ks to reuse existing raid-1 arrays

I was able to verify the worst case I could think of.  Kickstarting and reusing existing RAID doesn't work at all.  I set up a test machine in F9 as follows:

sda1
sdb1  md0 RAID-1 /boot

sda2 swap
sdb2 swap

sda3
sdb3 md1 RAID-1 F9 /

sda4
sdb4 md2 RAID-1 unused (to be F11 /)

Then using the attached kickstart, the idea is to set up dual-boot with F11.

The installation fails using F11-rc2.
After storage detection:

  The following error was found while parsing your kickstart configuration
  The following problem occurred on line 24 of the kickstart file
  No preexisting RAID device with the name "md0" was found

The installation succeeds using F11-Preview.
Comment 18 Allen Kistler 2009-06-02 00:45:49 EDT
Created attachment 346183 [details]
i386 Preview anaconda.log (ks works)
Comment 19 Allen Kistler 2009-06-02 00:46:18 EDT
Created attachment 346184 [details]
i386 Preview program.log (ks works)
Comment 20 Allen Kistler 2009-06-02 00:46:48 EDT
Created attachment 346185 [details]
i386 Preview storage.log (ks works)
Comment 21 Allen Kistler 2009-06-02 00:47:30 EDT
Created attachment 346186 [details]
i386 Preview syslog (ks works)
Comment 22 Allen Kistler 2009-06-02 00:48:00 EDT
Created attachment 346187 [details]
i386 RC2 anaconda.log (ks doesn't work)
Comment 23 Allen Kistler 2009-06-02 00:48:24 EDT
Created attachment 346188 [details]
i386 RC2 program.log (ks doesn't work)
Comment 24 Allen Kistler 2009-06-02 00:48:51 EDT
Created attachment 346189 [details]
i386 RC2 storage.log (ks doesn't work)
Comment 25 Allen Kistler 2009-06-02 00:49:15 EDT
Created attachment 346190 [details]
i386 RC2 syslog (ks doesn't work)
Comment 26 Allen Kistler 2009-06-02 00:53:40 EDT
Changed bug name to reflect that *all* kickstarting, including fully automated, loses RAID info in RC2.
Comment 27 James Laska 2009-06-02 08:52:12 EDT
(In reply to comment #16)
> added to common issues:
> 
> https://fedoraproject.org/wiki/Common_F11_bugs#503310
> 
> i don't think i phrased it very well, please do feel free to improve my
> wording. thanks.  

Thanks Adam, your phrasing matches my current understanding of this issue.
Comment 28 Radek Vykydal 2009-06-02 09:12:21 EDT
The latest attached logs seem to point to the same issue as in
https://bugzilla.redhat.com/show_bug.cgi?id=503681#c9.
Comment 29 Allen Kistler 2009-06-02 14:29:44 EDT
(In reply to comment #27)
> (In reply to comment #16)
> > added to common issues:
> > 
> > https://fedoraproject.org/wiki/Common_F11_bugs#503310
> > 
> > i don't think i phrased it very well, please do feel free to improve my
> > wording. thanks.  
> 
> Thanks Adam, your phrasing matches my current understanding of this issue.  

Heh.  Thanks, James.  The version you like is mine.
Comment 30 Adam Williamson 2009-06-02 14:36:55 EDT
yeah, it's much better than mine =)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 31 James Laska 2009-06-02 15:14:53 EDT
Doh!  Nice find on both these issues (RAID and LVM).
Comment 32 Radek Vykydal 2009-06-03 06:30:15 EDT
I posted a patch which should fix the problem for a review.
If you want you can try this updates file, it is for version .58 of anaconda:
http://rvykydal.fedorapeople.org/updates.clearpart.img
Comment 33 Allen Kistler 2009-06-03 19:01:10 EDT
Doh!  I just noticed I screwed up the order of the sd.2 and sd.3 partitions in Comment 17.  Oh, well....

Re: Comment 32

Confirmed.  The patch works for me.  I actually tried it with two ks files, the one included and the one I'll actually use when I install real systems.

You can set this bug to MODIFIED, too.

Thanks for the effort.
Comment 34 Adam Williamson 2009-06-04 15:10:20 EDT
it gets set to MODIFIED only once the code is actually committed somewhere 'live', not just to a random test image :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 35 Radek Vykydal 2009-06-05 03:21:41 EDT
Should be fixed in next build of anaconda for rawhide.
Comment 36 Bug Zapper 2009-06-09 12:52:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 37 Allen Kistler 2009-06-10 13:20:37 EDT
Re: Comment 36

Moving from F11 back to rawhide.  It only makes sense there.
Comment 38 Allen Kistler 2009-06-25 16:27:01 EDT
According to koji, there have been no builds for anaconda since 2 June.
Therefore this bug cannot be fixed yet.
Am I missing something?
Comment 39 Adam Williamson 2009-06-25 17:12:52 EDT
You are missing that bugs are allowed to be closed as soon as a fix is committed to CVS, in Rawhide. It would have been nice to have an explanation of the closure, though - it helps make it clear for cases like this. Andy?
Comment 40 Allen Kistler 2009-07-08 00:55:50 EDT
Unable to verify fix in anaconda-12.0 due to Bug 509572
Unable to verify fix in anaconda-12.1 due to Bug 510172
Comment 41 Radek Vykydal 2009-07-20 08:27:35 EDT
Putting to modified, fix has been pushed into anaconda 12.0.
Comment 42 Allen Kistler 2009-07-21 19:08:25 EDT
I was able to verify the fix in anaconda-12.3 with today's (21 July 2009) boot.iso.

Closing...
Comment 43 Nicholas 2009-07-22 15:13:24 EDT
Does this mean that the fix is not going to be available for Fedora 11?
Is there a way for me to make this fix available in Fedora 11?
Comment 44 Allen Kistler 2009-07-22 15:57:39 EDT
(In reply to comment #43)
> Does this mean that the fix is not going to be available for Fedora 11?
> Is there a way for me to make this fix available in Fedora 11?  

The update in Comment #32 still seems to be available.  It's not really an "official" fix, but it might get you by if you really need to kickstart F11.  Since it's in a developer's "people" directory, there's no guarantee it will stay available.  Otherwise manual F11 installs work fine.

Since anaconda runs only from the installation medium, there would have to be a re-issuance of the F11 CD/DVD images to get a fix into F11.  That won't happen until there's a respin.  Since I've never used a respin myself, I can't comment on whether even a respin would have an updated anaconda in it.

HTH

Note You need to log in before you can comment on or make changes to this bug.