Bug 503584 - Cobbler's Apache config files overwrite PythonPath supplied by Satellite's Apache config files
Cobbler's Apache config files overwrite PythonPath supplied by Satellite's Ap...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Steve Salevan
:
: 483156 504674 (view as bug list)
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-06-01 15:21 EDT by Steve Salevan
Modified: 2009-09-10 16:37 EDT (History)
7 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:37:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-06-01 15:21:14 EDT
Description of problem:
Since the earliest builds of 530, both developers and QA personnel have seen what appear to be deterministic 500 ISE errors upon accessing the XMLRPC API functionality of the Satellite.  jsherrill and pkilambi believe that these issues derive from an issue wherein Cobbler's Apache configuration files override the PythonPath variable supplied by the Satellite's Apache config files.

Regardless of whether this problem is the root cause of the deterministic ISEs, this configuration problem should be rectified.

Version-Release number of selected component (if applicable):
530, 5/29 build

How reproducible:
Deterministic

Steps to Reproduce:
1. View /etc/httpd/conf.d/cobbler.conf
2. Run a number of tests that hit Satellite's frontend and backend XMLRPC APIs (for instance, respectively: run a few api calls in a loop, register a lot of systems)
  
Actual results:
PythonPath overridden by cobbler's configuration file, 500 ISEs appear deterministically

Expected results:
PythonPath not overridden by cobbler's configuration file, 500 ISEs don't appear

Additional info:
Comment 3 Clifford Perry 2009-06-04 13:22:50 EDT
Prad - this needs reviewing. See if we can replicate and maybe fix. 

Cliff
Comment 4 Justin Sherrill 2009-06-04 13:44:07 EDT
So prad and I have discussed this at great length and while we think that it may have something to do with it, we can't remove those PythonPath lines from the cobbler config.

Those were added because we were setting the PythonPath explicitly in our configs and when it got to the cobbler sections, apache (in a Directory config) wouldn't automatically include that directory in the PythonPath (which it would if we hadn't of set the PythonPath).  So if we remove those lines cobbler will stop working.

Those lines shouldn't automatically cause an issue because they are simply appending a directory to the python path and not overriding it.  More investigation needs to be done.
Comment 6 Pradeep Kilambi 2009-06-05 14:45:39 EDT
will leave it on my plate for now..
Comment 7 Clifford Perry 2009-06-09 16:00:47 EDT
*** Bug 504674 has been marked as a duplicate of this bug. ***
Comment 8 Justin Sherrill 2009-06-09 16:15:12 EDT
How i was able to reproduce this issue:

1. run "rhn-satellite restart"
2.  Ensure that nothing else is trying to contact the satellite (no other clients or anything)
2. kickstart a box and wait for it to finish
3.  AS SOON as it has rebooted, simply run "rhn_check" on that specific client about 10 times.
4.  Should see an ISE within 10 tries


I kickstarted using the cobbler boot iso but it shouldn't make a difference.
Comment 10 Pradeep Kilambi 2009-06-10 08:49:56 EDT
*** Bug 483156 has been marked as a duplicate of this bug. ***
Comment 11 Steve Salevan 2009-06-24 16:19:20 EDT
VERIFIED on 6/19 build (as far as my testing can tell).
Comment 12 Miroslav Suchý 2009-08-18 05:36:13 EDT
verified in stage on xen5.englab.brq
Comment 13 Brandon Perkins 2009-09-10 16:37:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.