Bug 503791 - System/console beep sounds _terrible_, 20090528.4, firstboot sound check is fine
System/console beep sounds _terrible_, 20090528.4, firstboot sound check is fine
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
: Desktop, Regression
Depends On:
Blocks: 533192 525215
  Show dependency treegraph
 
Reported: 2009-06-02 14:05 EDT by Suzanne Hillman
Modified: 2013-01-10 03:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 10:05:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info output (20.58 KB, text/plain)
2009-07-22 10:09 EDT, Suzanne Hillman
no flags Details

  None (edit)
Description Suzanne Hillman 2009-06-02 14:05:13 EDT
Description of problem:
The console beep that you hear if in a virtual terminal and tab complete can't complete, or when gdm lets you know you can log in, sounds absolutely terrible on Dell Precision M6300.

The sound during the firstboot sound check is fine, however. And beep in BIOS sounds fine, as well.

May be related to bug #503787?

Version-Release number of selected component (if applicable):
2.6.18-151.el5

How reproducible:
Always, at least on this machine with 5.4 tree.

Steps to Reproduce:
1. Install 20090528.4 tree on Dell Precision M6300
2. get to GDM prompt or tab complete in virtual terminal.
  
Actual results:
Beep sounds sick.

Expected results:
Normal sounding beep.

Additional info:
Regression. 

Has been suggested that because of the way that this beep works, it may be a bug in acpi causing the timing of the signal sent to the device to be off (may be a poor rephrase of what was said; I didn't totally follow).
Comment 1 Matthew Garrett 2009-07-20 09:49:01 EDT
I suspect this is CONFIG_HDA_INPUT_BEEP, which is new in the ALSA backport for 5.4 and appears to have been turned on. This causes the console beep to be generated by the sound hardware rather than using the traditional PC speaker interface, so it may well sound different. Maybe this should be turned off if we want to avoid perceived regressions?
Comment 2 Jaroslav Kysela 2009-07-21 03:21:12 EDT
The HDA beep might be turned off using mixer - 'alsamixer -c 0'. Look for Speaker word. It look like two beep generators (HDA and old one) are running simultaneously on this machine.

Also, please, attach output from 'alsa-info.sh --no-upload' script (can be downloaded from http://www.alsa-project.org/alsa-info.sh').
Comment 4 Suzanne Hillman 2009-07-22 10:09:27 EDT
Created attachment 354694 [details]
alsa-info output
Comment 5 Suzanne Hillman 2009-07-22 10:10:45 EDT
turning down, and muting "Speaker" had no effect on the nasty beep sound.
Comment 6 Jaroslav Kysela 2009-07-22 10:20:10 EDT
Sorry, try "PC Beep"..
Comment 7 Suzanne Hillman 2009-07-22 10:22:46 EDT
That definitely makes it be quiet, although I could have sworn that I'd previously tried that!
Comment 10 RHEL Product and Program Management 2009-10-20 10:05:49 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 11 Jaroslav Kysela 2009-11-06 03:40:31 EST
It appears like a similar problem to bug#526751 which is resolved.

Note You need to log in before you can comment on or make changes to this bug.