Bug 503888 - sugar-toolkit should require python-cjson instead of python-json
sugar-toolkit should require python-cjson instead of python-json
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sugar-toolkit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
:
: 528579 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 03:59 EDT by Ricky Zhou
Modified: 2010-03-30 08:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 08:33:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Zhou 2009-06-03 03:59:05 EDT
The sugar-toolkit package current requires python-json, but the code has been updated to use python-cjson instead.
Comment 1 Bug Zapper 2009-06-09 13:01:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Ricky Zhou 2009-07-17 08:19:22 EDT
As a side note to this, the python-cjson package was in the list of orphaned packages set to be purged sent out recently:

https://www.redhat.com/archives/fedora-devel-announce/2009-July/msg00008.html

so that may be of interest to you, since sugar-toolkit now requires it.

To be clearer on the spec change that this bug involves, it'd be removing the lines:

Requires: python-simplejson
Requires: python-json

and replacing them with

Requires: python-cjson
Comment 3 Ricky Zhou 2009-12-06 14:20:32 EST
Ping?  python-cjson seems to have a maintainer now, so that's good.  However, the requires in this package are still incorrect, as sugar-toolkit does not require python-simplejson or python-json at all, only python-cjson.
Comment 4 Ricky Zhou 2010-02-21 15:42:42 EST
Ping?  This require still seems to be wrong, and it's a very simple fix.
Comment 5 Bug Zapper 2010-03-15 08:38:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Peter Robinson 2010-03-30 08:33:43 EDT
Package has moved to depend on python-simplejson
Comment 7 Peter Robinson 2010-03-30 08:33:58 EDT
*** Bug 528579 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.